2021-02-19 10:00:46

by Selvakumar Elangovan

[permalink] [raw]
Subject: [PATCH] staging: vt6656: fixed a CamelCase coding style issue.

This patch renames CamelCase macros uVar and uModulo into u_var and
u_module in device.h

This issue was reported by checkpatch.pl

Signed-off-by: Selvakumar Elangovan <[email protected]>
---
drivers/staging/vt6656/device.h | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/staging/vt6656/device.h b/drivers/staging/vt6656/device.h
index 947530fefe94..6615d356f74a 100644
--- a/drivers/staging/vt6656/device.h
+++ b/drivers/staging/vt6656/device.h
@@ -385,11 +385,11 @@ struct vnt_private {
struct ieee80211_low_level_stats low_stats;
};

-#define ADD_ONE_WITH_WRAP_AROUND(uVar, uModulo) { \
- if ((uVar) >= ((uModulo) - 1)) \
- (uVar) = 0; \
+#define ADD_ONE_WITH_WRAP_AROUND(u_var, u_modulo) { \
+ if ((u_var) >= ((u_modulo) - 1)) \
+ (u_var) = 0; \
else \
- (uVar)++; \
+ (u_var)++; \
}

int vnt_init(struct vnt_private *priv);
--
2.17.1


2021-02-19 10:42:13

by Greg Kroah-Hartman

[permalink] [raw]
Subject: Re: [PATCH] staging: vt6656: fixed a CamelCase coding style issue.

On Fri, Feb 19, 2021 at 03:28:35PM +0530, Selvakumar Elangovan wrote:
> This patch renames CamelCase macros uVar and uModulo into u_var and
> u_module in device.h
>
> This issue was reported by checkpatch.pl
>
> Signed-off-by: Selvakumar Elangovan <[email protected]>
> ---
> drivers/staging/vt6656/device.h | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/vt6656/device.h b/drivers/staging/vt6656/device.h
> index 947530fefe94..6615d356f74a 100644
> --- a/drivers/staging/vt6656/device.h
> +++ b/drivers/staging/vt6656/device.h
> @@ -385,11 +385,11 @@ struct vnt_private {
> struct ieee80211_low_level_stats low_stats;
> };
>
> -#define ADD_ONE_WITH_WRAP_AROUND(uVar, uModulo) { \
> - if ((uVar) >= ((uModulo) - 1)) \
> - (uVar) = 0; \
> +#define ADD_ONE_WITH_WRAP_AROUND(u_var, u_modulo) { \

"u_" does not really make any sense, right?

Just use "var" and "modulo" please.

But first, why is this needed at all? Isn't there an in-kernel function
that should be used instead?

thanks,

greg k-h

2021-02-19 12:14:45

by Dan Carpenter

[permalink] [raw]
Subject: Re: [PATCH] staging: vt6656: fixed a CamelCase coding style issue.

You're not asking the right questions.

On Fri, Feb 19, 2021 at 03:28:35PM +0530, Selvakumar Elangovan wrote:
> This patch renames CamelCase macros uVar and uModulo into u_var and
> u_module in device.h
>

Is "u_var" a good name? What does the "u_" even mean?

> This issue was reported by checkpatch.pl
>
> Signed-off-by: Selvakumar Elangovan <[email protected]>
> ---
> drivers/staging/vt6656/device.h | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/vt6656/device.h b/drivers/staging/vt6656/device.h
> index 947530fefe94..6615d356f74a 100644
> --- a/drivers/staging/vt6656/device.h
> +++ b/drivers/staging/vt6656/device.h
> @@ -385,11 +385,11 @@ struct vnt_private {
> struct ieee80211_low_level_stats low_stats;
> };
>
> -#define ADD_ONE_WITH_WRAP_AROUND(uVar, uModulo) { \
> - if ((uVar) >= ((uModulo) - 1)) \
> - (uVar) = 0; \
> +#define ADD_ONE_WITH_WRAP_AROUND(u_var, u_modulo) { \
> + if ((u_var) >= ((u_modulo) - 1)) \

The \ is not aligned any more.

> + (u_var) = 0; \
> else \
> - (uVar)++; \
> + (u_var)++; \
> }


This macro is rubbish. How does the wrap around even make sense?
I hope that if you review the code a bit I think you will find that the
wrap around is impossible? Just fix the two callers and delete this
macro.

regards,
dan carpenter

2021-02-19 12:24:24

by Selvakumar Elangovan

[permalink] [raw]
Subject: Re: [PATCH] staging: vt6656: fixed a CamelCase coding style issue.

Hi Dan Carpenter

Thanks for the feedback, I'll work on the suggestion and come back with a fix.

Regards
Selvakumar Elangovan

On Fri, Feb 19, 2021 at 5:42 PM Dan Carpenter <[email protected]> wrote:
>
> You're not asking the right questions.
>
> On Fri, Feb 19, 2021 at 03:28:35PM +0530, Selvakumar Elangovan wrote:
> > This patch renames CamelCase macros uVar and uModulo into u_var and
> > u_module in device.h
> >
>
> Is "u_var" a good name? What does the "u_" even mean?
>
> > This issue was reported by checkpatch.pl
> >
> > Signed-off-by: Selvakumar Elangovan <[email protected]>
> > ---
> > drivers/staging/vt6656/device.h | 8 ++++----
> > 1 file changed, 4 insertions(+), 4 deletions(-)
> >
> > diff --git a/drivers/staging/vt6656/device.h b/drivers/staging/vt6656/device.h
> > index 947530fefe94..6615d356f74a 100644
> > --- a/drivers/staging/vt6656/device.h
> > +++ b/drivers/staging/vt6656/device.h
> > @@ -385,11 +385,11 @@ struct vnt_private {
> > struct ieee80211_low_level_stats low_stats;
> > };
> >
> > -#define ADD_ONE_WITH_WRAP_AROUND(uVar, uModulo) { \
> > - if ((uVar) >= ((uModulo) - 1)) \
> > - (uVar) = 0; \
> > +#define ADD_ONE_WITH_WRAP_AROUND(u_var, u_modulo) { \
> > + if ((u_var) >= ((u_modulo) - 1)) \
>
> The \ is not aligned any more.
>
> > + (u_var) = 0; \
> > else \
> > - (uVar)++; \
> > + (u_var)++; \
> > }
>
>
> This macro is rubbish. How does the wrap around even make sense?
> I hope that if you review the code a bit I think you will find that the
> wrap around is impossible? Just fix the two callers and delete this
> macro.
>
> regards,
> dan carpenter
>