2021-05-26 13:46:28

by Yue Haibing

[permalink] [raw]
Subject: [PATCH -next] RDMA/core: use DEVICE_ATTR_RO macro

Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <[email protected]>
---
drivers/infiniband/core/ucma.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/infiniband/core/ucma.c b/drivers/infiniband/core/ucma.c
index 1f198c180aa1..74144e513dc7 100644
--- a/drivers/infiniband/core/ucma.c
+++ b/drivers/infiniband/core/ucma.c
@@ -1830,13 +1830,13 @@ static struct ib_client rdma_cma_client = {
};
MODULE_ALIAS_RDMA_CLIENT("rdma_cm");

-static ssize_t show_abi_version(struct device *dev,
+static ssize_t abi_version_show(struct device *dev,
struct device_attribute *attr,
char *buf)
{
return sysfs_emit(buf, "%d\n", RDMA_USER_CM_ABI_VERSION);
}
-static DEVICE_ATTR(abi_version, S_IRUGO, show_abi_version, NULL);
+static DEVICE_ATTR_RO(abi_version);

static int __init ucma_init(void)
{
--
2.17.1


2021-05-28 23:43:32

by Jason Gunthorpe

[permalink] [raw]
Subject: Re: [PATCH -next] RDMA/core: use DEVICE_ATTR_RO macro

On Wed, May 26, 2021 at 09:29:49PM +0800, YueHaibing wrote:
> Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
>
> Signed-off-by: YueHaibing <[email protected]>
> ---
> drivers/infiniband/core/ucma.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)

Applied to for-next, also touched with clang-format

Thanks,
Jason