2021-06-19 02:22:07

by Yury Norov

[permalink] [raw]
Subject: [PATCH 0/3] for_each_*_bit: move to find.h and reconsider

for_each_bit() macro family uses find_bit() functions, so it's better
to have for_each_bit() and find_bit() functions in the same header.

This series puts for_each_bit() to a proper place and optimizes its
usage over the kernel.

The series is based on this:
https://lore.kernel.org/linux-arch/[email protected]/

The full series can be found here:
https://github.com/norov/linux/commits/bm-final

Yury Norov (3):
include/linux: move for_each_bit() macros from bitops.h to find.h
find: micro-optimize for_each_{set,clear}_bit()
Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

arch/x86/kernel/apic/vector.c | 4 ++--
drivers/gpu/drm/etnaviv/etnaviv_gpu.c | 4 ++--
drivers/hwmon/ltc2992.c | 3 +--
include/linux/bitops.h | 34 ---------------------------
include/linux/find.h | 34 +++++++++++++++++++++++++++
5 files changed, 39 insertions(+), 40 deletions(-)

--
2.30.2


2021-06-19 03:43:09

by Yury Norov

[permalink] [raw]
Subject: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

A couple of kernel functions call for_each_*_bit_from() with start
bit equal to 0. Replace them with for_each_*_bit().

No functional changes, but might improve on readability.

Signed-off-by: Yury Norov <[email protected]>
---
arch/x86/kernel/apic/vector.c | 4 ++--
drivers/gpu/drm/etnaviv/etnaviv_gpu.c | 4 ++--
drivers/hwmon/ltc2992.c | 3 +--
3 files changed, 5 insertions(+), 6 deletions(-)

diff --git a/arch/x86/kernel/apic/vector.c b/arch/x86/kernel/apic/vector.c
index fb67ed5e7e6a..d099ef226f55 100644
--- a/arch/x86/kernel/apic/vector.c
+++ b/arch/x86/kernel/apic/vector.c
@@ -760,9 +760,9 @@ void __init lapic_update_legacy_vectors(void)

void __init lapic_assign_system_vectors(void)
{
- unsigned int i, vector = 0;
+ unsigned int i, vector;

- for_each_set_bit_from(vector, system_vectors, NR_VECTORS)
+ for_each_set_bit(vector, system_vectors, NR_VECTORS)
irq_matrix_assign_system(vector_matrix, vector, false);

if (nr_legacy_irqs() > 1)
diff --git a/drivers/gpu/drm/etnaviv/etnaviv_gpu.c b/drivers/gpu/drm/etnaviv/etnaviv_gpu.c
index 4102bcea3341..42ce3287d3be 100644
--- a/drivers/gpu/drm/etnaviv/etnaviv_gpu.c
+++ b/drivers/gpu/drm/etnaviv/etnaviv_gpu.c
@@ -1032,7 +1032,7 @@ int etnaviv_gpu_debugfs(struct etnaviv_gpu *gpu, struct seq_file *m)

void etnaviv_gpu_recover_hang(struct etnaviv_gpu *gpu)
{
- unsigned int i = 0;
+ unsigned int i;

dev_err(gpu->dev, "recover hung GPU!\n");

@@ -1045,7 +1045,7 @@ void etnaviv_gpu_recover_hang(struct etnaviv_gpu *gpu)

/* complete all events, the GPU won't do it after the reset */
spin_lock(&gpu->event_spinlock);
- for_each_set_bit_from(i, gpu->event_bitmap, ETNA_NR_EVENTS)
+ for_each_set_bit(i, gpu->event_bitmap, ETNA_NR_EVENTS)
complete(&gpu->event_free);
bitmap_zero(gpu->event_bitmap, ETNA_NR_EVENTS);
spin_unlock(&gpu->event_spinlock);
diff --git a/drivers/hwmon/ltc2992.c b/drivers/hwmon/ltc2992.c
index 2a4bed0ab226..7352d2b3c756 100644
--- a/drivers/hwmon/ltc2992.c
+++ b/drivers/hwmon/ltc2992.c
@@ -248,8 +248,7 @@ static int ltc2992_gpio_get_multiple(struct gpio_chip *chip, unsigned long *mask

gpio_status = reg;

- gpio_nr = 0;
- for_each_set_bit_from(gpio_nr, mask, LTC2992_GPIO_NR) {
+ for_each_set_bit(gpio_nr, mask, LTC2992_GPIO_NR) {
if (test_bit(LTC2992_GPIO_BIT(gpio_nr), &gpio_status))
set_bit(gpio_nr, bits);
}
--
2.30.2

2021-06-19 03:43:09

by Yury Norov

[permalink] [raw]
Subject: [PATCH 1/3] include/linux: move for_each_bit() macros from bitops.h to find.h

for_each_bit() macros depend on find_bit() machinery, and so the
proper place for them is the find.h header.

Signed-off-by: Yury Norov <[email protected]>
---
include/linux/bitops.h | 34 ----------------------------------
include/linux/find.h | 34 ++++++++++++++++++++++++++++++++++
2 files changed, 34 insertions(+), 34 deletions(-)

diff --git a/include/linux/bitops.h b/include/linux/bitops.h
index 26bf15e6cd35..31ae1ae1a974 100644
--- a/include/linux/bitops.h
+++ b/include/linux/bitops.h
@@ -31,40 +31,6 @@ extern unsigned long __sw_hweight64(__u64 w);
*/
#include <asm/bitops.h>

-#define for_each_set_bit(bit, addr, size) \
- for ((bit) = find_first_bit((addr), (size)); \
- (bit) < (size); \
- (bit) = find_next_bit((addr), (size), (bit) + 1))
-
-/* same as for_each_set_bit() but use bit as value to start with */
-#define for_each_set_bit_from(bit, addr, size) \
- for ((bit) = find_next_bit((addr), (size), (bit)); \
- (bit) < (size); \
- (bit) = find_next_bit((addr), (size), (bit) + 1))
-
-#define for_each_clear_bit(bit, addr, size) \
- for ((bit) = find_first_zero_bit((addr), (size)); \
- (bit) < (size); \
- (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
-
-/* same as for_each_clear_bit() but use bit as value to start with */
-#define for_each_clear_bit_from(bit, addr, size) \
- for ((bit) = find_next_zero_bit((addr), (size), (bit)); \
- (bit) < (size); \
- (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
-
-/**
- * for_each_set_clump8 - iterate over bitmap for each 8-bit clump with set bits
- * @start: bit offset to start search and to store the current iteration offset
- * @clump: location to store copy of current 8-bit clump
- * @bits: bitmap address to base the search on
- * @size: bitmap size in number of bits
- */
-#define for_each_set_clump8(start, clump, bits, size) \
- for ((start) = find_first_clump8(&(clump), (bits), (size)); \
- (start) < (size); \
- (start) = find_next_clump8(&(clump), (bits), (size), (start) + 8))
-
static inline int get_bitmask_order(unsigned int count)
{
int order;
diff --git a/include/linux/find.h b/include/linux/find.h
index 6048f8c97418..4500e8ab93e2 100644
--- a/include/linux/find.h
+++ b/include/linux/find.h
@@ -279,4 +279,38 @@ unsigned long find_next_bit_le(const void *addr, unsigned
#error "Please fix <asm/byteorder.h>"
#endif

+#define for_each_set_bit(bit, addr, size) \
+ for ((bit) = find_first_bit((addr), (size)); \
+ (bit) < (size); \
+ (bit) = find_next_bit((addr), (size), (bit) + 1))
+
+/* same as for_each_set_bit() but use bit as value to start with */
+#define for_each_set_bit_from(bit, addr, size) \
+ for ((bit) = find_next_bit((addr), (size), (bit)); \
+ (bit) < (size); \
+ (bit) = find_next_bit((addr), (size), (bit) + 1))
+
+#define for_each_clear_bit(bit, addr, size) \
+ for ((bit) = find_first_zero_bit((addr), (size)); \
+ (bit) < (size); \
+ (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
+
+/* same as for_each_clear_bit() but use bit as value to start with */
+#define for_each_clear_bit_from(bit, addr, size) \
+ for ((bit) = find_next_zero_bit((addr), (size), (bit)); \
+ (bit) < (size); \
+ (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
+
+/**
+ * for_each_set_clump8 - iterate over bitmap for each 8-bit clump with set bits
+ * @start: bit offset to start search and to store the current iteration offset
+ * @clump: location to store copy of current 8-bit clump
+ * @bits: bitmap address to base the search on
+ * @size: bitmap size in number of bits
+ */
+#define for_each_set_clump8(start, clump, bits, size) \
+ for ((start) = find_first_clump8(&(clump), (bits), (size)); \
+ (start) < (size); \
+ (start) = find_next_clump8(&(clump), (bits), (size), (start) + 8))
+
#endif /*__LINUX_FIND_H_ */
--
2.30.2

2021-06-19 20:31:34

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

On Sat, Jun 19, 2021 at 01:49:58PM +0300, Andy Shevchenko wrote:
> On Fri, Jun 18, 2021 at 12:57:35PM -0700, Yury Norov wrote:
> > A couple of kernel functions call for_each_*_bit_from() with start
> > bit equal to 0. Replace them with for_each_*_bit().
> >
> > No functional changes, but might improve on readability.
>
> ...
>
> > --- a/drivers/hwmon/ltc2992.c
> > +++ b/drivers/hwmon/ltc2992.c
> > @@ -248,8 +248,7 @@ static int ltc2992_gpio_get_multiple(struct gpio_chip *chip, unsigned long *mask
> >
> > gpio_status = reg;
> >
> > - gpio_nr = 0;
> > - for_each_set_bit_from(gpio_nr, mask, LTC2992_GPIO_NR) {
> > + for_each_set_bit(gpio_nr, mask, LTC2992_GPIO_NR) {
> > if (test_bit(LTC2992_GPIO_BIT(gpio_nr), &gpio_status))
> > set_bit(gpio_nr, bits);
> > }
>
> I would replace the entire loop by bitmap_replace() call.
>
> Something like
> bitmap_replace(bits, bits, &gpio_status, mask, LTC2992_GPIO_NR);

Okay, it wouldn't work directly because it involves LTC2992_GPIO_BIT()
macro. So, it rather some kind of bitmap_remap().

--
With Best Regards,
Andy Shevchenko


2021-06-19 20:31:53

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH 1/3] include/linux: move for_each_bit() macros from bitops.h to find.h

On Fri, Jun 18, 2021 at 12:57:33PM -0700, Yury Norov wrote:
> for_each_bit() macros depend on find_bit() machinery, and so the
> proper place for them is the find.h header.

Fine with me.
Reviewed-by: Andy Shevchenko <[email protected]>

> Signed-off-by: Yury Norov <[email protected]>
> ---
> include/linux/bitops.h | 34 ----------------------------------
> include/linux/find.h | 34 ++++++++++++++++++++++++++++++++++
> 2 files changed, 34 insertions(+), 34 deletions(-)
>
> diff --git a/include/linux/bitops.h b/include/linux/bitops.h
> index 26bf15e6cd35..31ae1ae1a974 100644
> --- a/include/linux/bitops.h
> +++ b/include/linux/bitops.h
> @@ -31,40 +31,6 @@ extern unsigned long __sw_hweight64(__u64 w);
> */
> #include <asm/bitops.h>
>
> -#define for_each_set_bit(bit, addr, size) \
> - for ((bit) = find_first_bit((addr), (size)); \
> - (bit) < (size); \
> - (bit) = find_next_bit((addr), (size), (bit) + 1))
> -
> -/* same as for_each_set_bit() but use bit as value to start with */
> -#define for_each_set_bit_from(bit, addr, size) \
> - for ((bit) = find_next_bit((addr), (size), (bit)); \
> - (bit) < (size); \
> - (bit) = find_next_bit((addr), (size), (bit) + 1))
> -
> -#define for_each_clear_bit(bit, addr, size) \
> - for ((bit) = find_first_zero_bit((addr), (size)); \
> - (bit) < (size); \
> - (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
> -
> -/* same as for_each_clear_bit() but use bit as value to start with */
> -#define for_each_clear_bit_from(bit, addr, size) \
> - for ((bit) = find_next_zero_bit((addr), (size), (bit)); \
> - (bit) < (size); \
> - (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
> -
> -/**
> - * for_each_set_clump8 - iterate over bitmap for each 8-bit clump with set bits
> - * @start: bit offset to start search and to store the current iteration offset
> - * @clump: location to store copy of current 8-bit clump
> - * @bits: bitmap address to base the search on
> - * @size: bitmap size in number of bits
> - */
> -#define for_each_set_clump8(start, clump, bits, size) \
> - for ((start) = find_first_clump8(&(clump), (bits), (size)); \
> - (start) < (size); \
> - (start) = find_next_clump8(&(clump), (bits), (size), (start) + 8))
> -
> static inline int get_bitmask_order(unsigned int count)
> {
> int order;
> diff --git a/include/linux/find.h b/include/linux/find.h
> index 6048f8c97418..4500e8ab93e2 100644
> --- a/include/linux/find.h
> +++ b/include/linux/find.h
> @@ -279,4 +279,38 @@ unsigned long find_next_bit_le(const void *addr, unsigned
> #error "Please fix <asm/byteorder.h>"
> #endif
>
> +#define for_each_set_bit(bit, addr, size) \
> + for ((bit) = find_first_bit((addr), (size)); \
> + (bit) < (size); \
> + (bit) = find_next_bit((addr), (size), (bit) + 1))
> +
> +/* same as for_each_set_bit() but use bit as value to start with */
> +#define for_each_set_bit_from(bit, addr, size) \
> + for ((bit) = find_next_bit((addr), (size), (bit)); \
> + (bit) < (size); \
> + (bit) = find_next_bit((addr), (size), (bit) + 1))
> +
> +#define for_each_clear_bit(bit, addr, size) \
> + for ((bit) = find_first_zero_bit((addr), (size)); \
> + (bit) < (size); \
> + (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
> +
> +/* same as for_each_clear_bit() but use bit as value to start with */
> +#define for_each_clear_bit_from(bit, addr, size) \
> + for ((bit) = find_next_zero_bit((addr), (size), (bit)); \
> + (bit) < (size); \
> + (bit) = find_next_zero_bit((addr), (size), (bit) + 1))
> +
> +/**
> + * for_each_set_clump8 - iterate over bitmap for each 8-bit clump with set bits
> + * @start: bit offset to start search and to store the current iteration offset
> + * @clump: location to store copy of current 8-bit clump
> + * @bits: bitmap address to base the search on
> + * @size: bitmap size in number of bits
> + */
> +#define for_each_set_clump8(start, clump, bits, size) \
> + for ((start) = find_first_clump8(&(clump), (bits), (size)); \
> + (start) < (size); \
> + (start) = find_next_clump8(&(clump), (bits), (size), (start) + 8))
> +
> #endif /*__LINUX_FIND_H_ */
> --
> 2.30.2
>

--
With Best Regards,
Andy Shevchenko


2021-06-19 20:31:56

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

On Fri, Jun 18, 2021 at 12:57:35PM -0700, Yury Norov wrote:
> A couple of kernel functions call for_each_*_bit_from() with start
> bit equal to 0. Replace them with for_each_*_bit().
>
> No functional changes, but might improve on readability.

...

> --- a/drivers/hwmon/ltc2992.c
> +++ b/drivers/hwmon/ltc2992.c
> @@ -248,8 +248,7 @@ static int ltc2992_gpio_get_multiple(struct gpio_chip *chip, unsigned long *mask
>
> gpio_status = reg;
>
> - gpio_nr = 0;
> - for_each_set_bit_from(gpio_nr, mask, LTC2992_GPIO_NR) {
> + for_each_set_bit(gpio_nr, mask, LTC2992_GPIO_NR) {
> if (test_bit(LTC2992_GPIO_BIT(gpio_nr), &gpio_status))
> set_bit(gpio_nr, bits);
> }

I would replace the entire loop by bitmap_replace() call.

Something like
bitmap_replace(bits, bits, &gpio_status, mask, LTC2992_GPIO_NR);

(Good to split sometimes :-)

--
With Best Regards,
Andy Shevchenko


2021-06-21 20:18:49

by Guenter Roeck

[permalink] [raw]
Subject: Re: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

On Fri, Jun 18, 2021 at 12:57:35PM -0700, Yury Norov wrote:
> A couple of kernel functions call for_each_*_bit_from() with start
> bit equal to 0. Replace them with for_each_*_bit().
>
> No functional changes, but might improve on readability.
>
> Signed-off-by: Yury Norov <[email protected]>
> ---
> arch/x86/kernel/apic/vector.c | 4 ++--
> drivers/gpu/drm/etnaviv/etnaviv_gpu.c | 4 ++--
> drivers/hwmon/ltc2992.c | 3 +--

This should be three different patches, one per subsystem.

Guenter

> 3 files changed, 5 insertions(+), 6 deletions(-)
>
> diff --git a/arch/x86/kernel/apic/vector.c b/arch/x86/kernel/apic/vector.c
> index fb67ed5e7e6a..d099ef226f55 100644
> --- a/arch/x86/kernel/apic/vector.c
> +++ b/arch/x86/kernel/apic/vector.c
> @@ -760,9 +760,9 @@ void __init lapic_update_legacy_vectors(void)
>
> void __init lapic_assign_system_vectors(void)
> {
> - unsigned int i, vector = 0;
> + unsigned int i, vector;
>
> - for_each_set_bit_from(vector, system_vectors, NR_VECTORS)
> + for_each_set_bit(vector, system_vectors, NR_VECTORS)
> irq_matrix_assign_system(vector_matrix, vector, false);
>
> if (nr_legacy_irqs() > 1)
> diff --git a/drivers/gpu/drm/etnaviv/etnaviv_gpu.c b/drivers/gpu/drm/etnaviv/etnaviv_gpu.c
> index 4102bcea3341..42ce3287d3be 100644
> --- a/drivers/gpu/drm/etnaviv/etnaviv_gpu.c
> +++ b/drivers/gpu/drm/etnaviv/etnaviv_gpu.c
> @@ -1032,7 +1032,7 @@ int etnaviv_gpu_debugfs(struct etnaviv_gpu *gpu, struct seq_file *m)
>
> void etnaviv_gpu_recover_hang(struct etnaviv_gpu *gpu)
> {
> - unsigned int i = 0;
> + unsigned int i;
>
> dev_err(gpu->dev, "recover hung GPU!\n");
>
> @@ -1045,7 +1045,7 @@ void etnaviv_gpu_recover_hang(struct etnaviv_gpu *gpu)
>
> /* complete all events, the GPU won't do it after the reset */
> spin_lock(&gpu->event_spinlock);
> - for_each_set_bit_from(i, gpu->event_bitmap, ETNA_NR_EVENTS)
> + for_each_set_bit(i, gpu->event_bitmap, ETNA_NR_EVENTS)
> complete(&gpu->event_free);
> bitmap_zero(gpu->event_bitmap, ETNA_NR_EVENTS);
> spin_unlock(&gpu->event_spinlock);
> diff --git a/drivers/hwmon/ltc2992.c b/drivers/hwmon/ltc2992.c
> index 2a4bed0ab226..7352d2b3c756 100644
> --- a/drivers/hwmon/ltc2992.c
> +++ b/drivers/hwmon/ltc2992.c
> @@ -248,8 +248,7 @@ static int ltc2992_gpio_get_multiple(struct gpio_chip *chip, unsigned long *mask
>
> gpio_status = reg;
>
> - gpio_nr = 0;
> - for_each_set_bit_from(gpio_nr, mask, LTC2992_GPIO_NR) {
> + for_each_set_bit(gpio_nr, mask, LTC2992_GPIO_NR) {
> if (test_bit(LTC2992_GPIO_BIT(gpio_nr), &gpio_status))
> set_bit(gpio_nr, bits);
> }

2021-06-21 21:35:09

by Yury Norov

[permalink] [raw]
Subject: Re: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

On Mon, Jun 21, 2021 at 01:17:11PM -0700, Guenter Roeck wrote:
> On Fri, Jun 18, 2021 at 12:57:35PM -0700, Yury Norov wrote:
> > A couple of kernel functions call for_each_*_bit_from() with start
> > bit equal to 0. Replace them with for_each_*_bit().
> >
> > No functional changes, but might improve on readability.
> >
> > Signed-off-by: Yury Norov <[email protected]>
> > ---
> > arch/x86/kernel/apic/vector.c | 4 ++--
> > drivers/gpu/drm/etnaviv/etnaviv_gpu.c | 4 ++--
> > drivers/hwmon/ltc2992.c | 3 +--
>
> This should be three different patches, one per subsystem.

It was discussed recently.
https://lore.kernel.org/linux-arch/[email protected]/

2021-07-28 15:01:10

by Yury Norov

[permalink] [raw]
Subject: Re: [PATCH 0/3] for_each_*_bit: move to find.h and reconsider

Ping?

On Fri, Jun 18, 2021 at 12:57:32PM -0700, Yury Norov wrote:
> for_each_bit() macro family uses find_bit() functions, so it's better
> to have for_each_bit() and find_bit() functions in the same header.
>
> This series puts for_each_bit() to a proper place and optimizes its
> usage over the kernel.
>
> The series is based on this:
> https://lore.kernel.org/linux-arch/[email protected]/
>
> The full series can be found here:
> https://github.com/norov/linux/commits/bm-final
>
> Yury Norov (3):
> include/linux: move for_each_bit() macros from bitops.h to find.h
> find: micro-optimize for_each_{set,clear}_bit()
> Replace for_each_*_bit_from() with for_each_*_bit() where appropriate
>
> arch/x86/kernel/apic/vector.c | 4 ++--
> drivers/gpu/drm/etnaviv/etnaviv_gpu.c | 4 ++--
> drivers/hwmon/ltc2992.c | 3 +--
> include/linux/bitops.h | 34 ---------------------------
> include/linux/find.h | 34 +++++++++++++++++++++++++++
> 5 files changed, 39 insertions(+), 40 deletions(-)
>
> --
> 2.30.2