2022-06-06 06:02:41

by Ira Weiny

[permalink] [raw]
Subject: [PATCH V10 2/9] PCI: Replace magic constant for PCI Sig Vendor ID

From: Ira Weiny <[email protected]>

Replace the magic value in pci_bus_crs_vendor_id() with
PCI_VENDOR_ID_PCI_SIG.

Reviewed-by: Dan Williams <[email protected]>
Reviewed-by: Davidlohr Bueso <[email protected]>
Suggested-by: Bjorn Helgaas <[email protected]>
Acked-by: Bjorn Helgaas <[email protected]>
Signed-off-by: Ira Weiny <[email protected]>

---
Changes from V6
Simplify commit message
---
drivers/pci/probe.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index 17a969942d37..6280e780a48c 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
@@ -2312,7 +2312,7 @@ EXPORT_SYMBOL(pci_alloc_dev);

static bool pci_bus_crs_vendor_id(u32 l)
{
- return (l & 0xffff) == 0x0001;
+ return (l & 0xffff) == PCI_VENDOR_ID_PCI_SIG;
}

static bool pci_bus_wait_crs(struct pci_bus *bus, int devfn, u32 *l,
--
2.35.1