2022-07-27 02:50:18

by Yu Zhe

[permalink] [raw]
Subject: [PATCH] dn_route: use time_is_before_jiffies(a) to replace "jiffies - a > 0"

time_is_before_jiffies deals with timer wrapping correctly.

Signed-off-by: Yu Zhe <[email protected]>
---
net/decnet/dn_route.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/decnet/dn_route.c b/net/decnet/dn_route.c
index 552a53f1d5d0..0a4bed0bc2e3 100644
--- a/net/decnet/dn_route.c
+++ b/net/decnet/dn_route.c
@@ -201,7 +201,7 @@ static void dn_dst_check_expire(struct timer_list *unused)
}
spin_unlock(&dn_rt_hash_table[i].lock);

- if ((jiffies - now) > 0)
+ if (time_is_before_jiffies(now))
break;
}

--
2.11.0


2022-07-28 13:25:29

by Paolo Abeni

[permalink] [raw]
Subject: Re: [PATCH] dn_route: use time_is_before_jiffies(a) to replace "jiffies - a > 0"

On Wed, 2022-07-27 at 10:46 +0800, Yu Zhe wrote:
> time_is_before_jiffies deals with timer wrapping correctly.
>
> Signed-off-by: Yu Zhe <[email protected]>
> ---
> net/decnet/dn_route.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/net/decnet/dn_route.c b/net/decnet/dn_route.c
> index 552a53f1d5d0..0a4bed0bc2e3 100644
> --- a/net/decnet/dn_route.c
> +++ b/net/decnet/dn_route.c
> @@ -201,7 +201,7 @@ static void dn_dst_check_expire(struct timer_list *unused)
> }
> spin_unlock(&dn_rt_hash_table[i].lock);
>
> - if ((jiffies - now) > 0)
> + if (time_is_before_jiffies(now))

Uhmm... it looks like the wrap-around condition can happen only in
theory: 'now' is initialized just before entering this loop, and we
will break as soon as jiffies increment. The wrap-around could happen
only if a single iteration of the loop takes more than LONG_MAX
jiffies.

If that happens, we have a completely different kind of much more
serious problem, I think ;)

So this change is mostly for core readability's sake. I personally find
more readable:

if (jiffies != now)

Cheers,

Paolo

p.s. given the above I guess this is for the net-next tree, right?

2022-07-29 06:13:11

by Yu Zhe

[permalink] [raw]
Subject: Re: [PATCH] dn_route: use time_is_before_jiffies(a) to replace "jiffies - a > 0"

在 2022年07月28日 21:11, Paolo Abeni 写道:

> On Wed, 2022-07-27 at 10:46 +0800, Yu Zhe wrote:
>> time_is_before_jiffies deals with timer wrapping correctly.
>>
>> Signed-off-by: Yu Zhe <[email protected]>
>> ---
>> net/decnet/dn_route.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/net/decnet/dn_route.c b/net/decnet/dn_route.c
>> index 552a53f1d5d0..0a4bed0bc2e3 100644
>> --- a/net/decnet/dn_route.c
>> +++ b/net/decnet/dn_route.c
>> @@ -201,7 +201,7 @@ static void dn_dst_check_expire(struct timer_list *unused)
>> }
>> spin_unlock(&dn_rt_hash_table[i].lock);
>>
>> - if ((jiffies - now) > 0)
>> + if (time_is_before_jiffies(now))
> Uhmm... it looks like the wrap-around condition can happen only in
> theory: 'now' is initialized just before entering this loop, and we
> will break as soon as jiffies increment. The wrap-around could happen
> only if a single iteration of the loop takes more than LONG_MAX
> jiffies.
>
> If that happens, we have a completely different kind of much more
> serious problem, I think ;)
>
> So this change is mostly for core readability's sake. I personally find
> more readable:
>
> if (jiffies != now)

I agree and I will send a v2 patch later.

>
> Cheers,
>
> Paolo
>
> p.s. given the above I guess this is for the net-next tree, right?
>
yes

>

2022-07-29 06:21:33

by Yu Zhe

[permalink] [raw]
Subject: [PATCH v2] dn_route: replace "jiffies-now>0" with "jiffies!=now"

Use "jiffies != now" to replace "jiffies - now > 0" to make
code more readable.

Signed-off-by: Yu Zhe <[email protected]>
---
net/decnet/dn_route.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/decnet/dn_route.c b/net/decnet/dn_route.c
index 552a53f1d5d0..ac2ee1689111 100644
--- a/net/decnet/dn_route.c
+++ b/net/decnet/dn_route.c
@@ -201,7 +201,7 @@ static void dn_dst_check_expire(struct timer_list *unused)
}
spin_unlock(&dn_rt_hash_table[i].lock);

- if ((jiffies - now) > 0)
+ if (jiffies != now)
break;
}

--
2.11.0

2022-07-30 03:34:56

by patchwork-bot+netdevbpf

[permalink] [raw]
Subject: Re: [PATCH v2] dn_route: replace "jiffies-now>0" with "jiffies!=now"

Hello:

This patch was applied to netdev/net-next.git (master)
by Jakub Kicinski <[email protected]>:

On Fri, 29 Jul 2022 14:17:12 +0800 you wrote:
> Use "jiffies != now" to replace "jiffies - now > 0" to make
> code more readable.
>
> Signed-off-by: Yu Zhe <[email protected]>
> ---
> net/decnet/dn_route.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

Here is the summary with links:
- [v2] dn_route: replace "jiffies-now>0" with "jiffies!=now"
https://git.kernel.org/netdev/net-next/c/0f14a8351abd

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html