2022-08-06 20:02:16

by Christophe JAILLET

[permalink] [raw]
Subject: [PATCH] vfio/fsl-mc: Fix a typo in a comment

L and S are swapped/
s/VFIO_FLS_MC/VFIO_FSL_MC/

Signed-off-by: Christophe JAILLET <[email protected]>
---
All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
prefix.
As they are dev_ function, the driver should already be displayed.

So, does it make sense or could they be all removed?
---
drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
index 3feff729f3ce..66d01db1d240 100644
--- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
+++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
@@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)

if (WARN_ON(ret))
dev_warn(&mc_cont->dev,
- "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
+ "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

vfio_fsl_mc_irqs_cleanup(vdev);

--
2.34.1


2022-08-08 10:08:02

by Cornelia Huck

[permalink] [raw]
Subject: Re: [PATCH] vfio/fsl-mc: Fix a typo in a comment

On Sat, Aug 06 2022, Christophe JAILLET <[email protected]> wrote:

$SUBJECT: s/comment/message/

> L and S are swapped/
> s/VFIO_FLS_MC/VFIO_FSL_MC/
>
> Signed-off-by: Christophe JAILLET <[email protected]>
> ---
> All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
> prefix.
> As they are dev_ function, the driver should already be displayed.
>
> So, does it make sense or could they be all removed?

From a quick glance, there seem to be messages for when the device is
_not_ bound to the fsl-mc driver (e.g. in vfio_fsl_mc_bus_notifier());
I'd just fix the typo for now.

> ---
> drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)

Acked-by: Cornelia Huck <[email protected]>

2022-08-09 16:44:46

by Jason Gunthorpe

[permalink] [raw]
Subject: Re: [PATCH] vfio/fsl-mc: Fix a typo in a comment

On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
> L and S are swapped/
> s/VFIO_FLS_MC/VFIO_FSL_MC/
>
> Signed-off-by: Christophe JAILLET <[email protected]>
> ---
> All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
> prefix.
> As they are dev_ function, the driver should already be displayed.
>
> So, does it make sense or could they be all removed?
> ---
> drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> index 3feff729f3ce..66d01db1d240 100644
> --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>
> if (WARN_ON(ret))
> dev_warn(&mc_cont->dev,
> - "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
> + "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

WARN_ON already prints, this is better written as

WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

Jason

2022-08-16 15:30:43

by Jason Gunthorpe

[permalink] [raw]
Subject: Re: [PATCH] vfio/fsl-mc: Fix a typo in a comment

On Tue, Aug 16, 2022 at 05:00:50PM +0200, Christophe JAILLET wrote:
> Le 09/08/2022 à 18:20, Jason Gunthorpe a écrit :
> > On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
> > > L and S are swapped/
> > > s/VFIO_FLS_MC/VFIO_FSL_MC/
> > >
> > > Signed-off-by: Christophe JAILLET <[email protected]>
> > > ---
> > > All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
> > > prefix.
> > > As they are dev_ function, the driver should already be displayed.
> > >
> > > So, does it make sense or could they be all removed?
> > > ---
> > > drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
> > > 1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > > index 3feff729f3ce..66d01db1d240 100644
> > > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
> > > @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
> > > if (WARN_ON(ret))
> > > dev_warn(&mc_cont->dev,
> > > - "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
> > > + "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
> >
> > WARN_ON already prints, this is better written as
> >
> > WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>
> Or maybe, just:
> if (ret)
> dev_warn(&mc_cont->dev,
> "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>
> This keep information about the device, avoid the duplicate printing related
> to WARN_ON+dev_warn and is more in line with error handling in other files.
>
> Do you agree or do you prefer a v2 as you proposed with WARN()?

If the original author wrote WARN I would not degrade it to just a
dev_warn.

Jason

2022-08-16 15:51:22

by Christophe JAILLET

[permalink] [raw]
Subject: Re: [PATCH] vfio/fsl-mc: Fix a typo in a comment

Le 09/08/2022 à 18:20, Jason Gunthorpe a écrit :
> On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
>> L and S are swapped/
>> s/VFIO_FLS_MC/VFIO_FSL_MC/
>>
>> Signed-off-by: Christophe JAILLET <[email protected]>
>> ---
>> All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
>> prefix.
>> As they are dev_ function, the driver should already be displayed.
>>
>> So, does it make sense or could they be all removed?
>> ---
>> drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> index 3feff729f3ce..66d01db1d240 100644
>> --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>>
>> if (WARN_ON(ret))
>> dev_warn(&mc_cont->dev,
>> - "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
>> + "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>
> WARN_ON already prints, this is better written as
>
> WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);

Or maybe, just:
if (ret)
dev_warn(&mc_cont->dev,
"VFIO_FSL_MC: reset device has failed (%d)\n", ret);

This keep information about the device, avoid the duplicate printing
related to WARN_ON+dev_warn and is more in line with error handling in
other files.

Do you agree or do you prefer a v2 as you proposed with WARN()?

CJ


>
> Jason
>

2022-08-22 09:59:39

by Cornelia Huck

[permalink] [raw]
Subject: Re: [PATCH] vfio/fsl-mc: Fix a typo in a comment

On Tue, Aug 16 2022, Jason Gunthorpe <[email protected]> wrote:

> On Tue, Aug 16, 2022 at 05:00:50PM +0200, Christophe JAILLET wrote:
>> Le 09/08/2022 à 18:20, Jason Gunthorpe a écrit :
>> > On Sat, Aug 06, 2022 at 09:56:13PM +0200, Christophe JAILLET wrote:
>> > > L and S are swapped/
>> > > s/VFIO_FLS_MC/VFIO_FSL_MC/
>> > >
>> > > Signed-off-by: Christophe JAILLET <[email protected]>
>> > > ---
>> > > All the dev_ logging functions in the file have the "VFIO_FSL_MC: "
>> > > prefix.
>> > > As they are dev_ function, the driver should already be displayed.
>> > >
>> > > So, does it make sense or could they be all removed?
>> > > ---
>> > > drivers/vfio/fsl-mc/vfio_fsl_mc.c | 2 +-
>> > > 1 file changed, 1 insertion(+), 1 deletion(-)
>> > >
>> > > diff --git a/drivers/vfio/fsl-mc/vfio_fsl_mc.c b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> > > index 3feff729f3ce..66d01db1d240 100644
>> > > --- a/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> > > +++ b/drivers/vfio/fsl-mc/vfio_fsl_mc.c
>> > > @@ -110,7 +110,7 @@ static void vfio_fsl_mc_close_device(struct vfio_device *core_vdev)
>> > > if (WARN_ON(ret))
>> > > dev_warn(&mc_cont->dev,
>> > > - "VFIO_FLS_MC: reset device has failed (%d)\n", ret);
>> > > + "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>> >
>> > WARN_ON already prints, this is better written as
>> >
>> > WARN(ret, "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>>
>> Or maybe, just:
>> if (ret)
>> dev_warn(&mc_cont->dev,
>> "VFIO_FSL_MC: reset device has failed (%d)\n", ret);
>>
>> This keep information about the device, avoid the duplicate printing related
>> to WARN_ON+dev_warn and is more in line with error handling in other files.
>>
>> Do you agree or do you prefer a v2 as you proposed with WARN()?
>
> If the original author wrote WARN I would not degrade it to just a
> dev_warn.

Having to decide between losing the WARN and losing the device info, I'd
just... fix the typo :)