2021-03-18 10:41:56

by Bhaskar Chowdhury

[permalink] [raw]
Subject: [PATCH] drm: Few typo fixes


s/instatiated/instantiated/
s/unreference/unreferenced/

Signed-off-by: Bhaskar Chowdhury <[email protected]>
---
drivers/gpu/drm/drm_property.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/drm_property.c b/drivers/gpu/drm/drm_property.c
index 6ee04803c362..27c824a6eb60 100644
--- a/drivers/gpu/drm/drm_property.c
+++ b/drivers/gpu/drm/drm_property.c
@@ -43,7 +43,7 @@
* property types and ranges.
*
* Properties don't store the current value directly, but need to be
- * instatiated by attaching them to a &drm_mode_object with
+ * instantiated by attaching them to a &drm_mode_object with
* drm_object_attach_property().
*
* Property values are only 64bit. To support bigger piles of data (like gamma
@@ -644,7 +644,7 @@ EXPORT_SYMBOL(drm_property_blob_get);
* @id: id of the blob property
*
* If successful, this takes an additional reference to the blob property.
- * callers need to make sure to eventually unreference the returned property
+ * callers need to make sure to eventually unreferenced the returned property
* again, using drm_property_blob_put().
*
* Return:
--
2.26.2


2021-03-18 13:27:03

by Daniel Vetter

[permalink] [raw]
Subject: Re: [PATCH] drm: Few typo fixes

On Thu, Mar 18, 2021 at 04:07:39PM +0530, Bhaskar Chowdhury wrote:
>
> s/instatiated/instantiated/
> s/unreference/unreferenced/
>
> Signed-off-by: Bhaskar Chowdhury <[email protected]>

Queued for 5.13 in drm-misc-next, thanks for your patch.
-Daniel

> ---
> drivers/gpu/drm/drm_property.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_property.c b/drivers/gpu/drm/drm_property.c
> index 6ee04803c362..27c824a6eb60 100644
> --- a/drivers/gpu/drm/drm_property.c
> +++ b/drivers/gpu/drm/drm_property.c
> @@ -43,7 +43,7 @@
> * property types and ranges.
> *
> * Properties don't store the current value directly, but need to be
> - * instatiated by attaching them to a &drm_mode_object with
> + * instantiated by attaching them to a &drm_mode_object with
> * drm_object_attach_property().
> *
> * Property values are only 64bit. To support bigger piles of data (like gamma
> @@ -644,7 +644,7 @@ EXPORT_SYMBOL(drm_property_blob_get);
> * @id: id of the blob property
> *
> * If successful, this takes an additional reference to the blob property.
> - * callers need to make sure to eventually unreference the returned property
> + * callers need to make sure to eventually unreferenced the returned property
> * again, using drm_property_blob_put().
> *
> * Return:
> --
> 2.26.2
>

--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch

2021-03-18 14:27:34

by Joe Perches

[permalink] [raw]
Subject: Re: [PATCH] drm: Few typo fixes

On Thu, 2021-03-18 at 16:07 +0530, Bhaskar Chowdhury wrote:
> s/instatiated/instantiated/
> s/unreference/unreferenced/

[]> diff --git a/drivers/gpu/drm/drm_property.c b/drivers/gpu/drm/drm_property.c
[]
> @@ -644,7 +644,7 @@ EXPORT_SYMBOL(drm_property_blob_get);
> ??* @id: id of the blob property
> ??*
> ??* If successful, this takes an additional reference to the blob property.
> - * callers need to make sure to eventually unreference the returned property
> + * callers need to make sure to eventually unreferenced the returned property

I think this is worse.


2021-03-18 18:05:16

by Randy Dunlap

[permalink] [raw]
Subject: Re: [PATCH] drm: Few typo fixes

On 3/18/21 7:25 AM, Joe Perches wrote:
> On Thu, 2021-03-18 at 16:07 +0530, Bhaskar Chowdhury wrote:
>> s/instatiated/instantiated/
>> s/unreference/unreferenced/
>
> []> diff --git a/drivers/gpu/drm/drm_property.c b/drivers/gpu/drm/drm_property.c
> []
>> @@ -644,7 +644,7 @@ EXPORT_SYMBOL(drm_property_blob_get);
>>   * @id: id of the blob property
>>   *
>>   * If successful, this takes an additional reference to the blob property.
>> - * callers need to make sure to eventually unreference the returned property
>> + * callers need to make sure to eventually unreferenced the returned property
>
> I think this is worse.

Agreed -- not good.

--
~Randy