2023-01-16 13:12:42

by Leon Romanovsky

[permalink] [raw]
Subject: [PATCH rdma-next 11/13] nvme: Introduce a local variable

From: Israel Rukshin <[email protected]>

The patch doesn't change any logic.

Signed-off-by: Israel Rukshin <[email protected]>
Signed-off-by: Leon Romanovsky <[email protected]>
---
drivers/nvme/host/core.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
index 7be562a4e1aa..51a9880db6ce 100644
--- a/drivers/nvme/host/core.c
+++ b/drivers/nvme/host/core.c
@@ -1870,6 +1870,7 @@ static void nvme_update_disk_info(struct gendisk *disk,
sector_t capacity = nvme_lba_to_sect(ns, le64_to_cpu(id->nsze));
unsigned short bs = 1 << ns->lba_shift;
u32 atomic_bs, phys_bs, io_opt = 0;
+ struct nvme_ctrl *ctrl = ns->ctrl;

/*
* The block layer can't support LBA sizes larger than the page size
@@ -1892,7 +1893,7 @@ static void nvme_update_disk_info(struct gendisk *disk,
if (id->nsfeat & NVME_NS_FEAT_ATOMICS && id->nawupf)
atomic_bs = (1 + le16_to_cpu(id->nawupf)) * bs;
else
- atomic_bs = (1 + ns->ctrl->subsys->awupf) * bs;
+ atomic_bs = (1 + ctrl->subsys->awupf) * bs;
}

if (id->nsfeat & NVME_NS_FEAT_IO_OPT) {
@@ -1922,7 +1923,7 @@ static void nvme_update_disk_info(struct gendisk *disk,
if (IS_ENABLED(CONFIG_BLK_DEV_INTEGRITY) &&
(ns->features & NVME_NS_METADATA_SUPPORTED))
nvme_init_integrity(disk, ns,
- ns->ctrl->max_integrity_segments);
+ ctrl->max_integrity_segments);
else if (!nvme_ns_has_pi(ns))
capacity = 0;
}
@@ -1931,7 +1932,7 @@ static void nvme_update_disk_info(struct gendisk *disk,

nvme_config_discard(disk, ns);
blk_queue_max_write_zeroes_sectors(disk->queue,
- ns->ctrl->max_zeroes_sectors);
+ ctrl->max_zeroes_sectors);
}

static bool nvme_ns_is_readonly(struct nvme_ns *ns, struct nvme_ns_info *info)
--
2.39.0


2023-01-17 00:41:56

by Chaitanya Kulkarni

[permalink] [raw]
Subject: Re: [PATCH rdma-next 11/13] nvme: Introduce a local variable

On 1/16/23 05:05, Leon Romanovsky wrote:
> From: Israel Rukshin <[email protected]>
>
> The patch doesn't change any logic.
>
> Signed-off-by: Israel Rukshin <[email protected]>
> Signed-off-by: Leon Romanovsky <[email protected]>
> ---
> drivers/nvme/host/core.c | 7 ++++---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
> index 7be562a4e1aa..51a9880db6ce 100644
> --- a/drivers/nvme/host/core.c
> +++ b/drivers/nvme/host/core.c
> @@ -1870,6 +1870,7 @@ static void nvme_update_disk_info(struct gendisk *disk,
> sector_t capacity = nvme_lba_to_sect(ns, le64_to_cpu(id->nsze));
> unsigned short bs = 1 << ns->lba_shift;
> u32 atomic_bs, phys_bs, io_opt = 0;
> + struct nvme_ctrl *ctrl = ns->ctrl;
>

I don't think this patch is needed, existing code is more readable and
gives much clarity that we are accessing ctrl from namespace since we
are in nvme_update_disk_info() which is namespace based.

-ck

2023-01-17 12:46:04

by Leon Romanovsky

[permalink] [raw]
Subject: Re: [PATCH rdma-next 11/13] nvme: Introduce a local variable

On Tue, Jan 17, 2023 at 12:32:59AM +0000, Chaitanya Kulkarni wrote:
> On 1/16/23 05:05, Leon Romanovsky wrote:
> > From: Israel Rukshin <[email protected]>
> >
> > The patch doesn't change any logic.
> >
> > Signed-off-by: Israel Rukshin <[email protected]>
> > Signed-off-by: Leon Romanovsky <[email protected]>
> > ---
> > drivers/nvme/host/core.c | 7 ++++---
> > 1 file changed, 4 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
> > index 7be562a4e1aa..51a9880db6ce 100644
> > --- a/drivers/nvme/host/core.c
> > +++ b/drivers/nvme/host/core.c
> > @@ -1870,6 +1870,7 @@ static void nvme_update_disk_info(struct gendisk *disk,
> > sector_t capacity = nvme_lba_to_sect(ns, le64_to_cpu(id->nsze));
> > unsigned short bs = 1 << ns->lba_shift;
> > u32 atomic_bs, phys_bs, io_opt = 0;
> > + struct nvme_ctrl *ctrl = ns->ctrl;
> >
>
> I don't think this patch is needed, existing code is more readable and
> gives much clarity that we are accessing ctrl from namespace since we
> are in nvme_update_disk_info() which is namespace based.

I don't have strong opinion here.

Thanks

>
> -ck
>