Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751360AbaB1KIV (ORCPT ); Fri, 28 Feb 2014 05:08:21 -0500 Received: from atrey.karlin.mff.cuni.cz ([195.113.26.193]:38358 "EHLO atrey.karlin.mff.cuni.cz" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751018AbaB1KIS (ORCPT ); Fri, 28 Feb 2014 05:08:18 -0500 Date: Fri, 28 Feb 2014 11:08:16 +0100 From: Pavel Machek To: Jenny Tc Cc: Linus Walleij , "linux-kernel@vger.kernel.org" , Dmitry Eremin-Solenikov , Anton Vorontsov , Anton Vorontsov , Kim Milo , Lee Jones , Jingoo Han , Chanwoo Choi , Sachin Kamat , Lars-Peter Clausen , Pali =?iso-8859-1?Q?Roh=E1r?= , Rhyland Klein , "Rafael J. Wysocki" , David Woodhouse , Tony Lindgren , Russell King , Sebastian Reichel , Aaro Koskinen , Pallala Ramakrishna , =?utf-8?B?0JjQstCw0LnQu9C+INCU0LjQvNC40YLRgNC+0LI=?= , Linux-OMAP Subject: Re: [PATCH 3/4] power_supply: Introduce PSE compliant algorithm Message-ID: <20140228100816.GA13406@amd.pavel.ucw.cz> References: <1391490780-6141-1-git-send-email-jenny.tc@intel.com> <1391490780-6141-4-git-send-email-jenny.tc@intel.com> <20140228030727.GB27921@jenny-desktop> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20140228030727.GB27921@jenny-desktop> User-Agent: Mutt/1.5.20 (2009-06-14) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri 2014-02-28 08:37:27, Jenny Tc wrote: > On Thu, Feb 27, 2014 at 09:18:57PM +0100, Linus Walleij wrote: > > On Tue, Feb 4, 2014 at 6:12 AM, Jenny TC wrote: > > > > > +static inline bool __is_battery_full > > > + (long volt, long cur, long iterm, unsigned long cv) > > > > Overall I wonder if you've run checkpatch on these patches, but why > > are you naming this one function with a double __underscore? > > Just is_battery_full_check() or something would work fine I guess? > > Just to convey that is_battery_full is a local function and not generic. You > can find similar usage in power_supply_core.c (__power_supply_changed_work) > and in other drivers. Isn't it advised to have __ prefixes? It is static; everybody sees it is local. __ prefix usually means something else. > > > + u16 capacity; /* mAh */ > > > + u16 voltage_max; /* mV */ > > > + /* charge termination current */ > > > + u16 chrg_term_mA; > > > + /* Low battery level voltage */ > > > + u16 low_batt_mV; > > > + /* upper and lower temperature limits on discharging */ > > > + s8 disch_temp_ul; /* Degree Celsius */ > > > + s8 disch_temp_ll; /* Degree Celsius */ > > > + /* number of temperature monitoring ranges */ > > > + u16 temp_mon_ranges; > > > + struct psy_ps_temp_chg_table temp_mon_range[BATT_TEMP_NR_RNG]; > > > + /* lowest temperature supported */ > > > + s8 temp_low_lim; > > > +} __packed; > > > > Why packed, and convert to kerneldoc for this struct. > > Battery charging profile, may come from EEPROM/emmc which would be packed. Do you need to do endianness conversion, too? Pavel -- (english) http://www.livejournal.com/~pavelmachek (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/