Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751744AbaFREQu (ORCPT ); Wed, 18 Jun 2014 00:16:50 -0400 Received: from mail-ve0-f178.google.com ([209.85.128.178]:42192 "EHLO mail-ve0-f178.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750970AbaFREQs (ORCPT ); Wed, 18 Jun 2014 00:16:48 -0400 MIME-Version: 1.0 In-Reply-To: References: <1402954800-28215-1-git-send-email-dianders@chromium.org> <1402954800-28215-5-git-send-email-dianders@chromium.org> Date: Tue, 17 Jun 2014 21:16:47 -0700 X-Google-Sender-Auth: 99_DlLluWZ4742uELaXOVQJNWBw Message-ID: Subject: Re: [PATCH 04/10] mfd: cros_ec: Tweak struct cros_ec_device for clarity From: Doug Anderson To: Simon Glass Cc: Lee Jones , Andrew Bresticker , Stephen Warren , Olof Johansson , Sonny Rao , linux-samsung-soc , Javier Martinez Canillas , Bill Richardson , Wolfram Sang , Mark Brown , Samuel Ortiz , lk Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Simon, On Tue, Jun 17, 2014 at 8:35 PM, Simon Glass wrote: > Hi Doug, > > On 16 June 2014 14:39, Doug Anderson wrote: >> From: Bill Richardson >> >> The members of struct cros_ec_device were improperly commented, and >> intermixed the private and public sections. This is just cleanup to make it >> more obvious what goes with what. >> >> [dianders: left lock in the structure but gave it the name that will >> eventually be used.] >> >> Signed-off-by: Bill Richardson >> Signed-off-by: Doug Anderson >> --- >> drivers/mfd/cros_ec.c | 2 +- >> drivers/mfd/cros_ec_i2c.c | 4 +-- >> drivers/mfd/cros_ec_spi.c | 10 +++---- >> include/linux/mfd/cros_ec.h | 65 ++++++++++++++++++++++++--------------------- >> 4 files changed, 43 insertions(+), 38 deletions(-) >> >> diff --git a/drivers/mfd/cros_ec.c b/drivers/mfd/cros_ec.c >> index bd6f936..a9eede5 100644 >> --- a/drivers/mfd/cros_ec.c >> +++ b/drivers/mfd/cros_ec.c >> @@ -57,7 +57,7 @@ static int cros_ec_command_sendrecv(struct cros_ec_device *ec_dev, >> msg.in_buf = in_buf; >> msg.in_len = in_len; >> >> - return ec_dev->command_xfer(ec_dev, &msg); >> + return ec_dev->cmd_xfer(ec_dev, &msg); > > Why do this rename? It makes it different from the other members. All I know of the history of this change is at . My best guess is that Bill was trying to differentiate public vs. private function pointers. Perhaps he will chime in. If it helps the other command_xxx() function pointers are removed in the later "mfd: cros_ec: cleanup: Remove EC wrapper functions" If you wish I can skip this rename, just let me know and it won't be too much trouble. -Doug -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/