Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752865AbaKQV40 (ORCPT ); Mon, 17 Nov 2014 16:56:26 -0500 Received: from mx1.redhat.com ([209.132.183.28]:52862 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752685AbaKQV4Y (ORCPT ); Mon, 17 Nov 2014 16:56:24 -0500 Message-ID: <546A6EB2.6020304@redhat.com> Date: Mon, 17 Nov 2014 13:54:58 -0800 From: Alexander Duyck User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.2.0 MIME-Version: 1.0 To: Linus Torvalds CC: "linux-arch@vger.kernel.org" , Network Development , Linux Kernel Mailing List , Mathieu Desnoyers , Peter Zijlstra , Benjamin Herrenschmidt , Heiko Carstens , Ingo Molnar , Michael Neuling , Russell King - ARM Linux , donald.c.skidmore@intel.com, matthew.vick@intel.com, Geert Uytterhoeven , Jeff Kirsher , Francois Romieu , Paul McKenney , nic_swsd@realtek.com, Will Deacon , Michael Ellerman , Tony Luck , Oleg Nesterov , Martin Schwidefsky , =?UTF-8?B?RnLDqWTDqXJpYyBXZWlzYmVja2Vy?= , David Miller Subject: Re: [PATCH 2/4] arch: Add lightweight memory barriers fast_rmb() and fast_wmb() References: <20141117171005.22333.96544.stgit@ahduyck-server> <20141117171812.22333.90395.stgit@ahduyck-server> In-Reply-To: Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 11/17/2014 12:52 PM, Linus Torvalds wrote: > On Mon, Nov 17, 2014 at 9:18 AM, Alexander Duyck > wrote: >> There are a number of situations where the mandatory barriers rmb() and >> wmb() are used to order memory/memory operations in the device drivers >> and those barriers are much heavier than they actually need to be. > Ugh. I absolutely despise the name. > > It's not "fast". It's just limited. It's the same as "smp_*mb()", in > that it works on cacheable memory, but it actually stays around even > for non-SMP builds. > > So I think the name is actively misleading. > > Naming should be about what it does, not about some kind of PR thing > that confuses people into thinking it's "better". > > Maybe "dma_*mb()" would be acceptable, and ends up having the same > naming convention as "smb_*mb()", and explains what it's about. What would you think of the name "coherent_*mb()"? I would prefer to avoid dma in the name since, at least in my mind, that implies MMIO. It also ties in well with dma_alloc_coherent/dma_free_coherent which is what would typically be used to allocate the memory we would be using the barrier to protect anyway. > And yes, in the same spirit, it would probably be good to try to > eventually get rid of the plain "*mb()" functions, and perhaps call > them "mmio_*mb()" to clarify that they are about ordering memory wrt > mmio. > > Hmm? > > Linus I will work on pulling all of the coherent barrier cases out of using the plain "*mb()" calls first. We need to sort that out before we could look at renaming the plain barrier functions. - Alex -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/