Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932329AbbD0HjQ (ORCPT ); Mon, 27 Apr 2015 03:39:16 -0400 Received: from mail-wi0-f169.google.com ([209.85.212.169]:34834 "EHLO mail-wi0-f169.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932200AbbD0HjN (ORCPT ); Mon, 27 Apr 2015 03:39:13 -0400 Message-ID: <553DE799.5050608@profitbricks.com> Date: Mon, 27 Apr 2015 09:39:05 +0200 From: Michael Wang User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.6.0 MIME-Version: 1.0 To: Liran Liss , Roland Dreier , Sean Hefty , Hal Rosenstock , "linux-rdma@vger.kernel.org" , "linux-kernel@vger.kernel.org" CC: Steve Wise , Tom Talpey , Jason Gunthorpe , Doug Ledford , Ira Weiny , Tom Tucker , Hoang-Nam Nguyen , "raisch@de.ibm.com" , Mike Marciniszyn , Eli Cohen , Faisal Latif , Jack Morgenstein , Or Gerlitz , Haggai Eran Subject: Re: [PATCH v6 01/26] IB/Verbs: Implement new callback query_transport() References: <1429878230-11749-1-git-send-email-yun.wang@profitbricks.com> <1429878230-11749-2-git-send-email-yun.wang@profitbricks.com> In-Reply-To: Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1836 Lines: 61 On 04/24/2015 05:12 PM, Liran Liss wrote: >> From: linux-rdma-owner@vger.kernel.org [mailto:linux-rdma- >> > [snip] >> a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.h index >> 65994a1..d54f91e 100644 >> --- a/include/rdma/ib_verbs.h >> +++ b/include/rdma/ib_verbs.h >> @@ -75,10 +75,13 @@ enum rdma_node_type { }; >> >> enum rdma_transport_type { >> + /* legacy for users */ >> RDMA_TRANSPORT_IB, >> RDMA_TRANSPORT_IWARP, >> RDMA_TRANSPORT_USNIC, >> - RDMA_TRANSPORT_USNIC_UDP >> + RDMA_TRANSPORT_USNIC_UDP, >> + /* new transport */ >> + RDMA_TRANSPORT_IBOE, > > Remove RDMA_TRANSPORT_IBOE - it is not a transport. > ROCE uses IBTA transport. > > If any code should test for ROCE should invoke a specific helper, e.g., rdma_protocol_iboe(). > This is what you currently call "rdma_tech_iboe" is patch 02/26. > > I think that pretty much everybody agrees that rdma_protocol_*() is a better name than rdma_tech_*(), right? > So, let's change this. Sure, sounds reasonable now, about the IBOE, we still need it to separate the port support IB/ETH without the check on link-layer, So what about a new enum on protocol type? Like: enum rdma_protocol { RDMA_PROTOCOL_IB, RDMA_PROTOCOL_IBOE, RDMA_PROTOCOL_IWARP, RDMA_PROTOCOL_USNIC_UDP }; So we could use query_protocol() to ask device provide the protocol type, and there will be no mixing with the legacy transport type anymore :-) Regards, Michael Wang > > The semantics are: "check that a link supports a certain wire protocol, or a set of wire protocols", where 'certain' > refers to the specific helper... > > -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/