Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S934760AbbEOTzt (ORCPT ); Fri, 15 May 2015 15:55:49 -0400 Received: from mail-ie0-f173.google.com ([209.85.223.173]:34475 "EHLO mail-ie0-f173.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S933913AbbEOTzp (ORCPT ); Fri, 15 May 2015 15:55:45 -0400 Date: Fri, 15 May 2015 12:55:41 -0700 From: Brian Norris To: Rob Herring , Pawel Moll , Mark Rutland , Ian Campbell , Kumar Gala Cc: linux-mtd@lists.infradead.org, devicetree@vger.kernel.org, linux-kernel@vger.kernel.org, Stephen Warren , Geert Uytterhoeven , Marek Vasut , =?utf-8?B?UmFmYcWCIE1pxYJlY2tp?= Subject: Re: [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Message-ID: <20150515195541.GL11598@ld-irv-0074> References: <1431624773-4165-1-git-send-email-computersforpeace@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <1431624773-4165-1-git-send-email-computersforpeace@gmail.com> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 4928 Lines: 118 It really helps if I test patches... On Thu, May 14, 2015 at 10:32:53AM -0700, Brian Norris wrote: > In commit 8ff16cf77ce3 ("Documentation: devicetree: m25p80: add "nor-jedec" > binding"), we added a generic "nor-jedec" binding to catch all > mostly-compatible SPI NOR flash which can be detected via the READ ID > opcode (0x9F). This was discussed and reviewed at the time, however > objections have come up since then as part of this discussion: > > http://lkml.kernel.org/g/20150511224646.GJ32500@ld-irv-0074 > > It seems the parties involved agree that "jedec,spi-nor" does a better > job of capturing the fact that this is SPI-specific, not just any NOR > flash. > > This binding was only merged for v4.1-rc1, so it's still OK to change > the naming. > > At the same time, let's move the documentation to a better name. > > Next up: prune the m25p_ids[] table to the minimal necessary listing, so > we can stop referring to code (drivers/mtd/devices/m25p80.c) from the > documentation. > > Signed-off-by: Brian Norris > Cc: Stephen Warren > Cc: Geert Uytterhoeven > Cc: Marek Vasut > Cc: Rafał Miłecki > Cc: Rob Herring > Cc: Pawel Moll > Cc: Mark Rutland > Cc: Ian Campbell > Cc: Kumar Gala > Cc: devicetree@vger.kernel.org > --- > I'd *really* like to get an 'ack' from a DT maintainer for this, those those > are apparently very hard to come by. And I'd really not like to have to revisit > this again in a few weeks. We have patches getting queued up for 4.2 that are > using the "nor-jedec" binding, and I'd like to nip those in the bud ASAP. > > .../devicetree/bindings/mtd/{m25p80.txt => jedec,spi-nor.txt} | 6 +++--- > drivers/mtd/devices/m25p80.c | 6 +++--- > 2 files changed, 6 insertions(+), 6 deletions(-) > rename Documentation/devicetree/bindings/mtd/{m25p80.txt => jedec,spi-nor.txt} (85%) > ... > diff --git a/drivers/mtd/devices/m25p80.c b/drivers/mtd/devices/m25p80.c > index 7c8b1694a134..3d59ebc16b6e 100644 > --- a/drivers/mtd/devices/m25p80.c > +++ b/drivers/mtd/devices/m25p80.c > @@ -223,7 +223,7 @@ static int m25p_probe(struct spi_device *spi) > */ > if (data && data->type) > flash_name = data->type; > - else if (!strcmp(spi->modalias, "nor-jedec")) > + else if (!strcmp(spi->modalias, "jedec,spi-nor")) > flash_name = NULL; /* auto-detect */ > else > flash_name = spi->modalias; > @@ -255,7 +255,7 @@ static int m25p_remove(struct spi_device *spi) > * since most of these flash are compatible to some extent, and their > * differences can often be differentiated by the JEDEC read-ID command, we > * encourage new users to add support to the spi-nor library, and simply bind > - * against a generic string here (e.g., "nor-jedec"). > + * against a generic string here (e.g., "jedec,spi-nor"). > * > * Many flash names are kept here in this list (as well as in spi-nor.c) to > * keep them available as module aliases for existing platforms. > @@ -305,7 +305,7 @@ static const struct spi_device_id m25p_ids[] = { > * Generic support for SPI NOR that can be identified by the JEDEC READ > * ID opcode (0x9F). Use this, if possible. > */ > - {"nor-jedec"}, > + {"jedec,spi-nor"}, So I forgot (again; we hit this before) that the SPI/OF framework strips everything before the first comma before binding devices. See of_modalias_node(). So I'll have to squash in the patch below to get a usable binding. > { }, > }; > MODULE_DEVICE_TABLE(spi, m25p_ids); This patch will make the code bind against anything like ",spi-nor", but we'll leave the comment to recommend using "jedec,spi-nor". Signed-off-by: Brian Norris diff --git a/drivers/mtd/devices/m25p80.c b/drivers/mtd/devices/m25p80.c index 3d59ebc16b6e..3af137f49ac9 100644 --- a/drivers/mtd/devices/m25p80.c +++ b/drivers/mtd/devices/m25p80.c @@ -223,7 +223,7 @@ static int m25p_probe(struct spi_device *spi) */ if (data && data->type) flash_name = data->type; - else if (!strcmp(spi->modalias, "jedec,spi-nor")) + else if (!strcmp(spi->modalias, "spi-nor")) flash_name = NULL; /* auto-detect */ else flash_name = spi->modalias; @@ -305,7 +305,7 @@ static const struct spi_device_id m25p_ids[] = { * Generic support for SPI NOR that can be identified by the JEDEC READ * ID opcode (0x9F). Use this, if possible. */ - {"jedec,spi-nor"}, + {"spi-nor"}, { }, }; MODULE_DEVICE_TABLE(spi, m25p_ids); -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/