Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754308AbbFSIRn (ORCPT ); Fri, 19 Jun 2015 04:17:43 -0400 Received: from opensource.wolfsonmicro.com ([80.75.67.52]:55900 "EHLO opensource.wolfsonmicro.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752772AbbFSIRj (ORCPT ); Fri, 19 Jun 2015 04:17:39 -0400 Date: Fri, 19 Jun 2015 09:17:37 +0100 From: Charles Keepax To: cw00.choi@samsung.com Cc: Lee Jones , "myungjoo.ham@samsung.com" , Samuel Ortiz , devicetree , linux-kernel , patches@opensource.wolfsonmicro.com Subject: Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings Message-ID: <20150619081737.GS32730@opensource.wolfsonmicro.com> References: <1434638631-16451-1-git-send-email-ckeepax@opensource.wolfsonmicro.com> <1434638631-16451-3-git-send-email-ckeepax@opensource.wolfsonmicro.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.5.17+20080114 (2008-01-14) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1571 Lines: 53 On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote: > Hi Charles, > > On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax > wrote: > > This patch adds bindings for the basic microphone detection platform > > data. > > > > Signed-off-by: Charles Keepax > > --- > > + dbtime = 0; > > + device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime); > > + switch (dbtime) { > > + case 2: > > I'd like you to define the constant variable for specific integer > value to improve the readability. > e.g., > > #define MICD_DBTIME_XXX 2 > #define MICD_DBTIME_XXX 4 > > > + pdata->micd_dbtime = 0x10000; > > Also, you better to define the constant variable for "0x10000" to > improbe readability in the include/linux/mfd/arizona.h. If you just > use the hex value, the other developer cannot analyze the meaning of > "0x10000". > > > + break; > > + case 4: > > ditto. > I am not sure these two really warrant a define the number in DT indicates the number of debounces to perform. #define MICD_DBTIME_TWO 2 switch (dbtime) case MICD_DBTIME_TWO: Is if anything less clear than just using 2 directly. I could perhaps rename the varible to num_debounces instead? Thanks, Charles -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/