Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753570AbbG2OYD (ORCPT ); Wed, 29 Jul 2015 10:24:03 -0400 Received: from smtp.citrix.com ([66.165.176.89]:35573 "EHLO SMTP.CITRIX.COM" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753472AbbG2OYA (ORCPT ); Wed, 29 Jul 2015 10:24:00 -0400 X-IronPort-AV: E=Sophos;i="5.15,571,1432598400"; d="scan'208";a="285659039" Message-ID: <55B8E1C7.6070608@citrix.com> Date: Wed, 29 Jul 2015 15:23:03 +0100 From: Julien Grall User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.7.0 MIME-Version: 1.0 To: Boris Ostrovsky , CC: , "H. Peter Anvin" , "Jiri Slaby" , , Russell King , , , Tomi Valkeinen , , Jean-Christophe Plagniol-Villard , , Konrad Rzeszutek Wilk , "James E.J. Bottomley" , Thomas Gleixner , Ingo Molnar , , Juergen Gross , "Wei Liu" , Greg Kroah-Hartman , Dmitry Torokhov , , David Vrabel , , , =?windows-1252?Q?Roger_Pau_Monn=E9?= Subject: Re: [PATCH 4/8] xen: Use the correctly the Xen memory terminologies References: <1438095769-2560-1-git-send-email-julien.grall@citrix.com> <1438095769-2560-5-git-send-email-julien.grall@citrix.com> <55B7D40B.5080903@oracle.com> <55B8B846.2060103@citrix.com> <55B8DFD7.6070107@oracle.com> In-Reply-To: <55B8DFD7.6070107@oracle.com> Content-Type: text/plain; charset="windows-1252" Content-Transfer-Encoding: 7bit X-DLP: MIA1 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1546 Lines: 41 On 29/07/15 15:14, Boris Ostrovsky wrote: >> static inline unsigned long pfn_to_gfn(unsigned long pfn) >> { >> if (xen_feature(XENFEAT_autotranslated_physmap)) >> return pfn; >> else >> return pfn_to_mfn(pfn); >> } > > > But you'd still say 'op.arg1.mfn = pfn_to_gfn(pfn);' in xen_do_pin() > i.e. assign GFN to MFN, right? That's what I was referring to. Well no. I would use op.arg1.mfn = pfn_to_mfn(pfn) given that the code, if I'm right, is only executed for PV. mfn = pfn_to_gfn(...) was valid too because on PV is always an MFN. The suggestion of pfn_to_mfn was just for more readability, > (In general, I am not sure a guest should ever use 'mfn' as it is purely > a hypervisor construct. Including p2m, which I think should really be > p2g as this is what we use to figure out what to stick into page tables) I think avoid to use mfn in the hypervisor interface is out-of-scope for this series. If we ever want to modify the Xen API in Linux, we should do in sync with Xen to avoid inconsistency on naming. Anyway, the oddity of mfn = pfn_to_gfn(...) is mostly contained in the x86 specific code. I don't mind to either add pfn_to_mfn and use it or add a comment /* PV-specific so mfn == gfn */ for every use of mfn = pfn_to_gfn(...). Regards, -- Julien Grall -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/