Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752770AbbKCH3D (ORCPT ); Tue, 3 Nov 2015 02:29:03 -0500 Received: from mga01.intel.com ([192.55.52.88]:53716 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751313AbbKCH27 (ORCPT ); Tue, 3 Nov 2015 02:28:59 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.20,238,1444719600"; d="scan'208";a="593016250" Message-ID: <56386237.9080904@linux.intel.com> Date: Tue, 03 Nov 2015 09:28:55 +0200 From: Jarkko Nikula User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.7.0 MIME-Version: 1.0 To: Jeremiah Mahler , Wolfram Sang , Mika Westerberg , Dudley Du , linux-kernel@vger.kernel.org Subject: Re: [BUG, bisect] i2c: designware: Move common probe code into i2c_dw_probe() References: <20151103040216.GA2843@newt.localdomain> In-Reply-To: <20151103040216.GA2843@newt.localdomain> Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 2975 Lines: 72 Hi On 03.11.2015 06:02, Jeremiah Mahler wrote: > Jarkko, all, > > Commit d80d134182ba5 introduced a bug which causes a cyapa based touch > pad on an Acer C720 Chromebook to become inoperative. This is present > in the latest linux-next (20151101). The patch description is repeated > below. > > From d80d134182ba536ececab8d5fca50d779befc9a6 Mon Sep 17 00:00:00 2001 > From: Jarkko Nikula > Date: Mon, 12 Oct 2015 16:55:35 +0300 > Subject: [PATCH] i2c: designware: Move common probe code into i2c_dw_probe() > > There is some code duplication in i2c-designware-platdrv and > i2c-designware-pcidrv probe functions. What is even worse that duplication > requires i2c_dw_xfer(), i2c_dw_func() and i2c_dw_isr() i2c-designware-core > functions to be exported. > > Therefore move common code into new i2c_dw_probe() and make functions above > local to i2c-designware-core. > > While merging the code patch does following functional changes: > > - I2C Adapter name will be "Synopsys DesignWare I2C adapter". Previously it > was used for platform and ACPI devices but PCI device used > "i2c-designware-pci". > - Using device name for interrupt name. Previous it was platform device name, > ACPI device name or "i2c-designware-pci". > - Error code from devm_request_irq() and i2c_add_numbered_adapter() will be > printed in case of error. > > Signed-off-by: Jarkko Nikula > Signed-off-by: Wolfram Sang > --- > drivers/i2c/busses/i2c-designware-core.c | 49 +++++++++++++++++++++++++---- > drivers/i2c/busses/i2c-designware-core.h | 5 +-- > drivers/i2c/busses/i2c-designware-pcidrv.c | 30 ++---------------- > drivers/i2c/busses/i2c-designware-platdrv.c | 28 ++--------------- > 4 files changed, 49 insertions(+), 63 deletions(-) > Oh, I didn't notice adapter name was used drivers/platform/chrome/chromeos_laptop.c. Could you try does a patch below help? ============================ CUT HERE ============================ diff --git a/drivers/platform/chrome/chromeos_laptop.c b/drivers/platform/chrome/chromeos_laptop.c index 02072749fff3..2b441e9ae593 100644 --- a/drivers/platform/chrome/chromeos_laptop.c +++ b/drivers/platform/chrome/chromeos_laptop.c @@ -47,8 +47,8 @@ static const char *i2c_adapter_names[] = { "SMBus I801 adapter", "i915 gmbus vga", "i915 gmbus panel", - "i2c-designware-pci", - "i2c-designware-pci", + "Synopsys DesignWare I2C adapter", + "Synopsys DesignWare I2C adapter", }; /* Keep this enum consistent with i2c_adapter_names */ ============================ CUT HERE ============================ -- Jarkko -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/