Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S936877AbcCQUuV (ORCPT ); Thu, 17 Mar 2016 16:50:21 -0400 Received: from mail-yw0-f170.google.com ([209.85.161.170]:34712 "EHLO mail-yw0-f170.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S935675AbcCQUuP (ORCPT ); Thu, 17 Mar 2016 16:50:15 -0400 MIME-Version: 1.0 In-Reply-To: <1458247207.9556.28.camel@perches.com> References: <1458235817-28375-1-git-send-email-gustavo@padovan.org> <1458235817-28375-2-git-send-email-gustavo@padovan.org> <1458236486.9556.11.camel@perches.com> <20160317180523.GA2619@joana> <20160317184318.GA2611@joana> <1458246150.9556.17.camel@perches.com> <1458247207.9556.28.camel@perches.com> Date: Thu, 17 Mar 2016 16:50:14 -0400 Message-ID: Subject: Re: [PATCH v9 2/3] kernel.h: add to_user_ptr() From: Rob Clark To: Joe Perches Cc: Gustavo Padovan , Gustavo Padovan , Benjamin Herrenschmidt , Paul Mackerras , Michael Ellerman , Greg Kroah-Hartman , Linux Kernel Mailing List , devel@driverdev.osuosl.org, "dri-devel@lists.freedesktop.org" , Daniel Stone , =?UTF-8?B?QXJ2ZSBIasO4bm5ldsOlZw==?= , Riley Andrews , Daniel Vetter , Greg Hackmann , John Harrison , Maarten Lankhorst , Andrew Morton , David Airlie , Daniel Vetter , linuxppc-dev Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 2727 Lines: 67 On Thu, Mar 17, 2016 at 4:40 PM, Joe Perches wrote: > On Thu, 2016-03-17 at 16:33 -0400, Rob Clark wrote: >> On Thu, Mar 17, 2016 at 4:22 PM, Joe Perches wrote: >> > On Thu, 2016-03-17 at 15:43 -0300, Gustavo Padovan wrote: >> > > 2016-03-17 Gustavo Padovan : >> > > > 2016-03-17 Joe Perches : >> > > > > On Thu, 2016-03-17 at 14:30 -0300, Gustavo Padovan wrote: >> > > > > > This function had copies in 3 different files. Unify them in >> > > > > > kernel.h. >> > > > > This is only used by gpu/drm. >> > > > > >> > > > > I think this is a poor name for a generic function >> > > > > that would be in kernel.h. >> > > > > >> > > > > Isn't there an include file in linux/drm that's >> > > > > appropriate for this. Maybe drmP.h >> > > > > >> > > > > Maybe prefix this function name with drm_ too. >> > > > No, the next patch adds a user to drivers/staging (which will be moved >> > > > to drivers/dma-buf) soon. Maybe move to a different header in >> > > > include/linux/? not sure which one. >> > > > >> > > > > >> > > > > >> > > > > Also, there's this that might conflict: >> > > > > >> > > > > arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ptr_to_compat(p) >> > > > > arch/powerpc/kernel/signal_32.c:#define to_user_ptr(p) ((unsigned long)(p)) >> > > > Right, I'll figure out how to replace these two too. >> > > The powerpc to_user_ptr has a different meaning from the one I'm adding >> > > in this patch. I propose we just rename powerpc's to_user_ptr to >> > > __to_user_ptr and leave the rest as is. >> > I think that's not a good idea, and you should really check >> > this concept with the powerpc folk (added to to:s and cc:ed) >> > >> > If it were really added, then the function meaning is incorrect. >> > >> > This is taking a u64, casting that to (unsigned long/uint_ptr_t), >> > then converting that to a user pointer. >> > >> > Does that naming and use make sense on x86-32 or arm32? >> > >> fwiw Gustavo's version of to_user_ptr() is in use on arm32 and arm64.. >> Not entirely sure what doesn't make sense about it > > It's a name that seems like it should be a straightforward > cast of a kernel pointer to a __user pointer like: > > static inline void __user *to_user_ptr(void *p) > { > return (void __user *)p; > } ahh, ok. I guess I was used to using it in the context of ioctl structs.. in that context u64 -> (void __user *) made more sense. Maybe uapi_to_ptr()? (ok, not super-creative.. maybe someone has a better idea) BR, -R > As a static function in a single file, it's not > great, but OK, fine, it's static. > > As a global function in kernel.h, it's misleading. > >