Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756647AbcC2KC0 (ORCPT ); Tue, 29 Mar 2016 06:02:26 -0400 Received: from smtprelay.synopsys.com ([198.182.60.111]:38632 "EHLO smtprelay.synopsys.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751580AbcC2KCY (ORCPT ); Tue, 29 Mar 2016 06:02:24 -0400 From: Alexey Brodkin To: dri-devel@lists.freedesktop.org Cc: linux-kernel@vger.kernel.org, Alexey Brodkin , Daniel Vetter , David Airlie , Boris Brezillon , Laurent Pinchart , linux-renesas-soc@vger.kernel.org, David Herrmann Subject: [PATCH 0/3 v4] drm: Introduce drm_connector_register_all() helper Date: Tue, 29 Mar 2016 13:02:11 +0300 Message-Id: <1459245734-2392-1-git-send-email-abrodkin@synopsys.com> X-Mailer: git-send-email 2.5.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 2284 Lines: 56 As a pair to already existing drm_connector_unplug_all() (which we'll rename in this series to drm_connector_unregister_all()) we're adding generic implementation of what is already done in some drivers for registering all connectors. After implementation of that new helper we're updating 2 drivers that used to use it's own implementation: [1] atmel_hlcdc [2] rcar_du Other drivers still use load() callback and so should be first modified so their load() gets called from their probe() explicitly. Build- and run-tested on yet to be upstreamed ARC PGU (part of AXS10x board). Changes v3 -> v4: * Based on current drm-intel/topic/drm-misc It's now on commit 6c87e5c3ec6db052f3744804a517b6fb003906e1 And since thet new base already has "drm: Rename drm_connector_unplug_all() to drm_connector_unregister_all()" this series now only includes 3 subsequent patches. * In drm_connector_register_all() fail path which calls unregister_all() is moved outside of loop&locked section (as suggested by Daniel) Changes v2 -> v3: * Added acks for 1, 3 and 4 patches * Updated kerneldoc descriptins of both register_ and unregister_all() * Updated commit messages (mostly spellos and grammar issues) Changes v1 -> v2: * Rename drm_connector_unplug_all() to drm_connector_unregister_all() * Use drm_for_each_connector() instead of list_for_each_entry() * Updated kerneldoc for drm_dev_register() Alexey Brodkin (3): drm: Introduce drm_connector_register_all() helper drm: atmel_hldc: Use generic drm_connector_register_all() helper drm: rcar-du: Use generic drm_connector_register_all() helper Cc: Daniel Vetter Cc: David Airlie Cc: Boris Brezillon Cc: Laurent Pinchart Cc: linux-renesas-soc@vger.kernel.org Cc: David Herrmann drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_dc.c | 39 ++-------------------------- drivers/gpu/drm/drm_crtc.c | 39 ++++++++++++++++++++++++++++ drivers/gpu/drm/drm_drv.c | 6 ++++- drivers/gpu/drm/rcar-du/rcar_du_drv.c | 9 +------ include/drm/drm_crtc.h | 3 ++- 5 files changed, 49 insertions(+), 47 deletions(-) -- 2.5.0