Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752758AbcD1Ne1 (ORCPT ); Thu, 28 Apr 2016 09:34:27 -0400 Received: from hqemgate16.nvidia.com ([216.228.121.65]:9394 "EHLO hqemgate16.nvidia.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752188AbcD1NeZ (ORCPT ); Thu, 28 Apr 2016 09:34:25 -0400 X-PGP-Universal: processed; by hqnvupgp07.nvidia.com on Thu, 28 Apr 2016 06:33:46 -0700 Message-ID: <57220E92.90105@nvidia.com> Date: Thu, 28 Apr 2016 18:52:26 +0530 From: Laxman Dewangan User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0 MIME-Version: 1.0 To: , , , , CC: , , , , , , Subject: Re: [PATCH V11 4/6] pinctrl: max77620: add pincontrol driver for MAX77620/MAX20024 References: <1461837540-17071-1-git-send-email-ldewangan@nvidia.com> <1461837540-17071-5-git-send-email-ldewangan@nvidia.com> In-Reply-To: <1461837540-17071-5-git-send-email-ldewangan@nvidia.com> X-Originating-IP: [10.19.65.30] X-ClientProxiedBy: DRHKMAIL102.nvidia.com (10.25.59.16) To bgmail102.nvidia.com (10.25.59.11) Content-Type: text/plain; charset="ISO-8859-1"; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1784 Lines: 53 Hi Lee, On Thursday 28 April 2016 03:28 PM, Laxman Dewangan wrote: > MAXIM Semiconductor's PMIC, MAX77620/MAX20024 has 8 GPIO pins > which also act as the special function in alternate mode. Also > there is configuration like push-pull, open drain, FPS timing > etc for these pins. > > Add pin control driver to configure these parameters through > pin control APIs. > > Signed-off-by: Laxman Dewangan > Reviewed-by: Linus Walleij It seems there is some mismatches on kernel-next and the mfd/for-next for one of patch for generic function name. /** 2016-04-01 pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map Irina Tirdea 1 -1/+1 d32f7fd3bbc32732b094d938b95169521503a9fb (patch) pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map, since it does not depend on device tree despite the current name. This will enforce a consistent naming in pinctr-utils.c and will make it clear it can be called from outside device tree (e.g. from ACPI handling code). **/ But this is not there in MFD sub system. In mfd tree .dt_free_map = pinctrl_utils_dt_free_map, In kernel next .dt_free_map = pinctrl_utils_free_map, I used APIs from the kernel-next. > +static const struct pinctrl_ops max77620_pinctrl_ops = { > + .get_groups_count = max77620_pinctrl_get_groups_count, > + .get_group_name = max77620_pinctrl_get_group_name, > + .get_group_pins = max77620_pinctrl_get_group_pins, > + .dt_node_to_map = pinconf_generic_dt_node_to_map_pin, > + .dt_free_map = pinctrl_utils_free_map, > +}; If you see any issue on this patch, please drop this patch and we will fix this later once the renamed change available all the places.