Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752209AbcKRII3 (ORCPT ); Fri, 18 Nov 2016 03:08:29 -0500 Received: from mail-pg0-f67.google.com ([74.125.83.67]:36153 "EHLO mail-pg0-f67.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751320AbcKRIIZ (ORCPT ); Fri, 18 Nov 2016 03:08:25 -0500 Date: Fri, 18 Nov 2016 13:29:27 +0530 From: maitysanchayan@gmail.com To: Stefan Agner Cc: broonie@kernel.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, linux-spi@vger.kernel.org Subject: Re: [PATCH 3/4] spi: spi-fsl-dspi: Fix continuous selection format Message-ID: <20161118075927.GA1572@Sanchayan-Arch.localdomain> References: MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: User-Agent: Mutt/1.7.1 (2016-10-04) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1936 Lines: 66 Hello Stefan, On 16-11-17 17:07:24, Stefan Agner wrote: > On 2016-11-17 04:16, Sanchayan Maity wrote: > > Current DMA implementation was not handling the continuous selection > > format viz. SPI chip select would be deasserted even between sequential > > serial transfers. Use the cs_change variable and correctly set or > > reset the CONT bit accordingly for case where peripherals require > > the chip select to be asserted between sequential transfers. > > > > Signed-off-by: Sanchayan Maity > > --- > > drivers/spi/spi-fsl-dspi.c | 13 ++++++++++--- > > 1 file changed, 10 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/spi/spi-fsl-dspi.c b/drivers/spi/spi-fsl-dspi.c > > index aee8c88..164e2e1 100644 > > --- a/drivers/spi/spi-fsl-dspi.c > > +++ b/drivers/spi/spi-fsl-dspi.c > > @@ -258,9 +258,16 @@ static int dspi_next_xfer_dma_submit(struct fsl_dspi *dspi) > > } > > > > val = tx_word ? *(u16 *) dspi->tx : *(u8 *) dspi->tx; > > - dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) | > > - SPI_PUSHR_PCS(dspi->cs) | > > - SPI_PUSHR_CTAS(0); > > + if (dspi->cs_change) { > > + dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) | > > + SPI_PUSHR_PCS(dspi->cs) | > > + SPI_PUSHR_CTAS(0); > > + } else { > > + dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) | > > + SPI_PUSHR_PCS(dspi->cs) | > > + SPI_PUSHR_CTAS(0) | > > + SPI_PUSHR_CONT; > > + } > > How about: > > > dspi->dma->tx_dma_buf[i] = SPI_PUSHR_TXDATA(val) | > SPI_PUSHR_PCS(dspi->cs) | > SPI_PUSHR_CTAS(0); > > + if (dspi->cs_change) > + dspi->dma->tx_dma_buf[i] |= SPI_PUSHR_CONT; > > > Avoids code duplication... Agreed. It's much better. Should be !dspi->cs_change though. Will include it in next iteration. Thanks & Regards, Sanchayan. > > -- > Stefan > > > > > dspi->tx += tx_word + 1; > > > > dma->tx_desc = dmaengine_prep_slave_single(dma->chan_tx,