Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751639AbcLEQX3 (ORCPT ); Mon, 5 Dec 2016 11:23:29 -0500 Received: from mail2-relais-roc.national.inria.fr ([192.134.164.83]:56529 "EHLO mail2-relais-roc.national.inria.fr" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751080AbcLEQX2 (ORCPT ); Mon, 5 Dec 2016 11:23:28 -0500 X-IronPort-AV: E=Sophos;i="5.33,305,1477954800"; d="scan'208";a="248166084" Date: Mon, 5 Dec 2016 17:23:26 +0100 From: Samuel Thibault To: Pavel Machek Cc: "Maciej S. Szmigiero" , Greg Kroah-Hartman , Jiri Slaby , Dmitry Torokhov , linux-kernel Subject: Re: [PATCH] vt: fix Scroll Lock LED trigger name Message-ID: <20161205162326.GC6206@var.bordeaux.inria.fr> Mail-Followup-To: Samuel Thibault , Pavel Machek , "Maciej S. Szmigiero" , Greg Kroah-Hartman , Jiri Slaby , Dmitry Torokhov , linux-kernel References: <20161205134743.GB30774@amd> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20161205134743.GB30774@amd> User-Agent: Mutt/1.5.21+34 (58baf7c9f32f) (2010-12-30) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1582 Lines: 38 Hello, Pavel Machek, on Mon 05 Dec 2016 14:47:43 +0100, wrote: > > There is a disagreement between drivers/tty/vt/keyboard.c and > > drivers/input/input-leds.c with regard to what is a Scroll Lock LED > > trigger name: input calls it "kbd-scrolllock", but vt calls it > > "kbd-scrollock" (two l's). > > This prevents Scroll Lock LED trigger from binding to this LED by default. > > > > Since it is a scroLL Lock LED, this interface was introduced only about a > > year ago and in an Internet search people seem to reference this trigger > > only to set it to this LED let's simply rename it to "kbd-scrolllock". > > > > Also, it looks like this was supposed to be changed before this code was > > merged: https://lkml.org/lkml/2015/6/9/697 but it was done only on > > the input side. > > > > Signed-off-by: Maciej S. Szmigiero > > --- > > drivers/tty/vt/keyboard.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/drivers/tty/vt/keyboard.c b/drivers/tty/vt/keyboard.c > > index d5d81d4d3c04..3dd6a491cdba 100644 > > --- a/drivers/tty/vt/keyboard.c > > +++ b/drivers/tty/vt/keyboard.c > > @@ -982,7 +982,7 @@ static void kbd_led_trigger_activate(struct led_classdev *cdev) > > KBD_LED_TRIGGER((_led_bit) + 8, _name) > > > > static struct kbd_led_trigger kbd_led_triggers[] = { > > - KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrollock"), > > + KBD_LED_TRIGGER(VC_SCROLLOCK, "kbd-scrolllock"), > > Would it be feasible to rename "VC_SCROLLOCK" to "VC_SCROLLLOCK", too? Well, no, that's a misnamed userland API. Samuel