Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752172AbcLFLDr (ORCPT ); Tue, 6 Dec 2016 06:03:47 -0500 Received: from smtpoutz29.laposte.net ([194.117.213.104]:46718 "EHLO smtp.laposte.net" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1751710AbcLFLDo (ORCPT ); Tue, 6 Dec 2016 06:03:44 -0500 Subject: Re: [PATCH] bitops: add equivalent of BIT(x) for bitfields To: Geert Uytterhoeven References: <196dd443-e3c7-2c37-1dd1-bc1d249ea2fb@laposte.net> <55a33378-e235-08da-251e-fff432be72fb@laposte.net> Cc: zijun_hu , Sasha Levin , Andrew Morton , "linux-kernel@vger.kernel.org" , Linus Torvalds , Mason , Maxime Coquelin , Harvey Harrison , Borislav Petkov From: Sebastian Frias Message-ID: Date: Tue, 6 Dec 2016 12:03:36 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-VR-SrcIP: 92.154.11.170 X-VR-FullState: 0 X-VR-Score: -100 X-VR-Cause-1: gggruggvucftvghtrhhoucdtuddrfeelfedrhedtgddtkecutefuodetggdotefrodftvfcurfhrohhf X-VR-Cause-2: ihhlvgemucfntefrqffuvffgnecuuegrihhlohhuthemucehtddtnecusecvtfgvtghiphhivghnthhs X-VR-Cause-3: ucdlqddutddtmdenucfjughrpefuvfhfhffkffgfgggjtgfgsehtjeertddtfeejnecuhfhrohhmpefu X-VR-Cause-4: vggsrghsthhirghnucfhrhhirghsuceoshhfkeegsehlrghpohhsthgvrdhnvghtqeenucffohhmrghi X-VR-Cause-5: nhepmhgrrhgtrdhinhhfohenucfkphepledvrdduheegrdduuddrudejtdenucfrrghrrghmpehmohgu X-VR-Cause-6: vgepshhmthhpohhuthdphhgvlhhopegludejvddrvdejrddtrddvudegngdpihhnvghtpeelvddrudeh X-VR-Cause-7: gedruddurddujedtpdhmrghilhhfrhhomhepshhfkeegsehlrghpohhsthgvrdhnvghtpdhrtghpthht X-VR-Cause-8: ohepghgvvghrtheslhhinhhugidqmheikehkrdhorhhg X-VR-AvState: No X-VR-State: 0 X-VR-State: 0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 2493 Lines: 79 On 06/12/16 11:42, Geert Uytterhoeven wrote: > On Tue, Dec 6, 2016 at 11:31 AM, Sebastian Frias wrote: >> On 05/12/16 18:48, Geert Uytterhoeven wrote: >>> On Mon, Dec 5, 2016 at 2:36 PM, Sebastian Frias wrote: >>>> Introduce SETBITFIELD(msb, lsb, value) macro to ease dealing with >>>> continuous bitfields, just as BIT(x) does for single bits. >>> >>> If it's a bitfield, why not calling it that way? >> >> I don't know if you saw v2 (or v3 for that matter), but the name was changed >> to GENVALUE. > > ... which means "generate a value"?? > Yes. Although I'm not sure if I understood the essence of your point. Are you suggesting that the name should be GENERATE_A_VALUE? There's already GENMASK, which "generates a mask". >> Also a small use case was added to the commit message: >> >> "Introduce GENVALUE(msb, lsb, value) macro..." >> "...This is useful mostly for creating values to be packed together >> via OR operations, ex: >> >> u32 val = 0x11110000; >> val |= GENVALUE(19, 12, 0x5a); > > "val |= 0x5a << 12;" looks much more readable to me... > Well, the idea behind this is that one can use it like: (see https://marc.info/?l=linux-kernel&m=148095872915717&w=2) ... #define TIMEOUT_CLK_UNIT_MHZ BIT(6) #define BUS_CLK_FREQ_FOR_SD_CLK(x) GENVALUE(14,7,x) ... val = 0; val |= TIMEOUT_CLK_UNIT_MHZ; /* unit: MHz */ val |= BUS_CLK_FREQ_FOR_SD_CLK(200); /* SDIO clock: 200MHz */ ... which makes it very practical for writing macros for associated HW documentation. >> now 'val = 0x1115a000'" >> >>> So what about BITFIELD(start ,size), like arch/tile/kernel/tile-desc_32.c has? >>> >>>> SETBITFIELD_ULL(msb, lsb, value) macro is also added. >>> >>> Confused by the need for a "value" parameter... >> >> "value" is the value to be massaged (shifted, masked) into a [msb:lsb] bitfield. > > OK. So it inserts a value into a bitfield. > > Yes, that can be useful. Now let's find a sensible name for this. > Perhaps inspired by a PowerPC mnemonic? At least that would be more > obvious than "GENVALUE", IMHO... I'm open to suggestions. > > Gr{oetje,eeting}s, > > Geert > > -- > Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org > > In personal conversations with technical people, I call myself a hacker. But > when I'm talking to journalists I just say "programmer" or something like that. > -- Linus Torvalds >