Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932071AbdCBB22 (ORCPT ); Wed, 1 Mar 2017 20:28:28 -0500 Received: from vmicros1.altlinux.org ([194.107.17.57]:46340 "EHLO vmicros1.altlinux.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753965AbdCBB2K (ORCPT ); Wed, 1 Mar 2017 20:28:10 -0500 Date: Thu, 2 Mar 2017 03:33:56 +0300 From: "Dmitry V. Levin" To: hpa@zytor.com Cc: Arnd Bergmann , Thomas Gleixner , Ingo Molnar , x86@kernel.org, Linux Kernel Mailing List Subject: Re: [PATCH v2] x86/uapi: fix asm/signal.h userspace compilation error Message-ID: <20170302003356.GD27132@altlinux.org> References: <20170226010156.GA28831@altlinux.org> <20170302001853.GA27097@altlinux.org> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1397 Lines: 46 On Wed, Mar 01, 2017 at 04:26:29PM -0800, hpa@zytor.com wrote: > On March 1, 2017 4:18:54 PM PST, "Dmitry V. Levin" wrote: > >Replace size_t to fix the following asm/signal.h userspace compilation > >error: > > > >/usr/include/asm/signal.h:126:2: error: unknown type name 'size_t' > > size_t ss_size; > > > >size_t is replaced with __kernel_size_t in all cases except x32 where > >unsigned int has to be used instead. > > > >Signed-off-by: Dmitry V. Levin > >--- > >v2: create a separate patch for x86, > > replace size_t instead of including . > > > > arch/x86/include/uapi/asm/signal.h | 6 +++++- > > 1 file changed, 5 insertions(+), 1 deletion(-) > > > >diff --git a/arch/x86/include/uapi/asm/signal.h > >b/arch/x86/include/uapi/asm/signal.h > >index 8264f47..f80473f 100644 > >--- a/arch/x86/include/uapi/asm/signal.h > >+++ b/arch/x86/include/uapi/asm/signal.h > >@@ -127,7 +127,11 @@ struct sigaction { > > typedef struct sigaltstack { > > void __user *ss_sp; > > int ss_flags; > >- size_t ss_size; > >+#if defined(__x86_64__) && defined(__ILP32__) > >+ unsigned int ss_size; > >+#else > >+ __kernel_size_t ss_size; > >+#endif > > } stack_t; > > > > #endif /* __ASSEMBLY__ */ > > Sounds like we still ought to make this a type by itself. A new type would need a name, like __kernel_uapi_size_t. Do you have any preferences? -- ldv