Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751768AbdCHIoC (ORCPT ); Wed, 8 Mar 2017 03:44:02 -0500 Received: from hqemgate16.nvidia.com ([216.228.121.65]:3012 "EHLO hqemgate16.nvidia.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751065AbdCHIn6 (ORCPT ); Wed, 8 Mar 2017 03:43:58 -0500 X-PGP-Universal: processed; by hqpgpgate101.nvidia.com on Tue, 07 Mar 2017 23:20:06 -0800 Subject: Re: [RFC 08/11] mm: make ttu's return boolean To: Minchan Kim , Andrew Morton References: <1488436765-32350-1-git-send-email-minchan@kernel.org> <1488436765-32350-9-git-send-email-minchan@kernel.org> CC: , , , Johannes Weiner , Michal Hocko , "Kirill A. Shutemov" , Naoya Horiguchi X-Nvconfidentiality: public From: John Hubbard Message-ID: <70f60783-e098-c1a9-11b4-544530bcd809@nvidia.com> Date: Tue, 7 Mar 2017 23:13:26 -0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.7.1 MIME-Version: 1.0 In-Reply-To: <1488436765-32350-9-git-send-email-minchan@kernel.org> X-Originating-IP: [10.2.171.174] X-ClientProxiedBy: DRHQMAIL104.nvidia.com (10.27.9.13) To HQMAIL107.nvidia.com (172.20.187.13) Content-Type: text/plain; charset="windows-1252"; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 2778 Lines: 76 On 03/01/2017 10:39 PM, Minchan Kim wrote: > try_to_unmap returns SWAP_SUCCESS or SWAP_FAIL so it's suitable for > boolean return. This patch changes it. Hi Minchan, So, up until this patch, I definitely like the cleanup, because as you observed, the return values didn't need so many different values. However, at this point, I think you should stop, and keep the SWAP_SUCCESS and SWAP_FAIL (or maybe even rename them to UNMAP_* or TTU_RESULT_*, to match their functions' names better), because removing them makes the code considerably less readable. And since this is billed as a cleanup, we care here, even though this is a minor point. :) Bool return values are sometimes perfect, such as when asking a question: bool mode_changed = needs_modeset(crtc_state); The above is very nice. However, for returning success or failure, bools are not as nice, because *usually* success == true, except when you use the errno-based system, in which success == 0 (which would translate to false, if you mistakenly treated it as a bool). That leads to the reader having to remember which system is in use, usually with no visual cues to help. > [...] > if (PageSwapCache(p)) { > @@ -971,7 +971,7 @@ static int hwpoison_user_mappings(struct page *p, unsigned long pfn, > collect_procs(hpage, &tokill, flags & MF_ACTION_REQUIRED); > > ret = try_to_unmap(hpage, ttu); > - if (ret != SWAP_SUCCESS) > + if (!ret) > pr_err("Memory failure: %#lx: failed to unmap page (mapcount=%d)\n", > pfn, page_mapcount(hpage)); > > @@ -986,8 +986,7 @@ static int hwpoison_user_mappings(struct page *p, unsigned long pfn, > * any accesses to the poisoned memory. > */ > forcekill = PageDirty(hpage) || (flags & MF_MUST_KILL); > - kill_procs(&tokill, forcekill, trapno, > - ret != SWAP_SUCCESS, p, pfn, flags); > + kill_procs(&tokill, forcekill, trapno, !ret , p, pfn, flags); The kill_procs() invocation was a little more readable before. > [...] > diff --git a/mm/vmscan.c b/mm/vmscan.c > index 170c61f..e4b74f1 100644 > --- a/mm/vmscan.c > +++ b/mm/vmscan.c > @@ -966,7 +966,6 @@ static unsigned long shrink_page_list(struct list_head *page_list, > int may_enter_fs; > enum page_references references = PAGEREF_RECLAIM_CLEAN; > bool dirty, writeback; > - int ret = SWAP_SUCCESS; > > cond_resched(); > > @@ -1139,13 +1138,9 @@ static unsigned long shrink_page_list(struct list_head *page_list, > * processes. Try to unmap it here. > */ > if (page_mapped(page)) { > - switch (ret = try_to_unmap(page, > - ttu_flags | TTU_BATCH_FLUSH)) { > - case SWAP_FAIL: Again: the SWAP_FAIL makes it crystal clear which case we're in. I also wonder if UNMAP_FAIL or TTU_RESULT_FAIL is a better name? thanks, John Hubbard NVIDIA