Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757769AbdCUOLH (ORCPT ); Tue, 21 Mar 2017 10:11:07 -0400 Received: from mx1.redhat.com ([209.132.183.28]:39605 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1757182AbdCUOLF (ORCPT ); Tue, 21 Mar 2017 10:11:05 -0400 DMARC-Filter: OpenDMARC Filter v1.3.2 mx1.redhat.com 47B9C64DB2 Authentication-Results: ext-mx09.extmail.prod.ext.phx2.redhat.com; dmarc=none (p=none dis=none) header.from=redhat.com Authentication-Results: ext-mx09.extmail.prod.ext.phx2.redhat.com; spf=pass smtp.mailfrom=jpoimboe@redhat.com DKIM-Filter: OpenDKIM Filter v2.11.0 mx1.redhat.com 47B9C64DB2 Date: Tue, 21 Mar 2017 09:03:40 -0500 From: Josh Poimboeuf To: Peter Zijlstra Cc: mingo@kernel.org, tglx@linutronix.de, hpa@zytor.com, linux-kernel@vger.kernel.org, torvalds@linux-foundation.org, arjan@linux.intel.com, bp@alien8.de, richard.weinberger@gmail.com Subject: Re: [PATCH 1/5] x86: Implement __WARN using UD0 Message-ID: <20170321140340.urru2lmjko6txwl5@treble> References: <20170317211918.393791494@infradead.org> <20170317212350.828368979@infradead.org> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <20170317212350.828368979@infradead.org> User-Agent: Mutt/1.6.0.1 (2016-04-01) X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.38]); Tue, 21 Mar 2017 14:03:43 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 2417 Lines: 89 On Fri, Mar 17, 2017 at 10:19:19PM +0100, Peter Zijlstra wrote: > --- a/arch/x86/include/asm/bug.h > +++ b/arch/x86/include/asm/bug.h > @@ -1,36 +1,70 @@ > #ifndef _ASM_X86_BUG_H > #define _ASM_X86_BUG_H > > +#include > + > #define HAVE_ARCH_BUG > > -#ifdef CONFIG_DEBUG_BUGVERBOSE > +/* > + * Since some emulators terminate on UD2, we cannot use it for WARN. > + * Since various instruction decoders disagree on the length of UD1, > + * we cannot use it either. So use UD0 for WARN. > + * > + * (binutils knows about "ud1" but {en,de}codes it as 2 bytes, whereas > + * our kernel decoder thinks it takes a ModRM byte, which seems consistent > + * with various things like the Intel SDM instruction encoding rules) > + */ > + > +#define ASM_UD0 ".byte 0x0f, 0xff" > +#define ASM_UD1 ".byte 0x0f, 0xb9" /* + ModRM */ > +#define ASM_UD2 ".byte 0x0f, 0x0b" Thas ASM_UD1 macro isn't used anywhere. > --- a/arch/x86/kernel/traps.c > +++ b/arch/x86/kernel/traps.c > @@ -169,6 +169,41 @@ void ist_end_non_atomic(void) > preempt_disable(); > } > > +int is_valid_bugaddr(unsigned long addr) > +{ > + unsigned short ud; > + > +#ifdef CONFIG_X86_32 > + if (addr < PAGE_OFFSET) > + return 0; > +#else > + if ((long)addr > 0) > + return 0; > +#endif I think comparing with TASK_SIZE would be more correct and it wouldn't need an ifdef. > + if (probe_kernel_address((unsigned short *)addr, ud)) > + return 0; > + > + return ud == 0x0b0f || ud == 0xff0f; > +} This code would be easier to grok if these were defines IMO. Also, now that some of the BUG-specific functions are now also related to WARN, they should probably be renamed to describe their new purpose, like: "report_bug" -> "report_bug_or_warning" "fixup_bug" -> "fixup_bug_or_warning" On a related note, if warn and bug are going to continue to use two separate ud instructions for the foreseeable future, report_bug() could be cleaned up a bit: e.g., for a ud0 instruction, it doesn't make sense to call find_bug(). > + > +static int fixup_bug(struct pt_regs *regs, int trapnr) > +{ > + if (trapnr != X86_TRAP_UD) > + return 0; > + > + switch (report_bug(regs->ip, regs)) { > + case BUG_TRAP_TYPE_NONE: > + case BUG_TRAP_TYPE_BUG: > + break; > + > + case BUG_TRAP_TYPE_WARN: > + regs->ip += 2; > + return 1; For self-documentation purposes, maybe use a define for the length of the ud0 instruction? -- Josh