Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753909AbXLRKaH (ORCPT ); Tue, 18 Dec 2007 05:30:07 -0500 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1753239AbXLRK34 (ORCPT ); Tue, 18 Dec 2007 05:29:56 -0500 Received: from nat-132.atmel.no ([80.232.32.132]:59016 "EHLO relay.atmel.no" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1752479AbXLRK3z (ORCPT ); Tue, 18 Dec 2007 05:29:55 -0500 Date: Tue, 18 Dec 2007 11:29:07 +0100 From: Haavard Skinnemoen To: "Andrew Victor" Cc: "Remy Bohmer" , linux-kernel@vger.kernel.org, "ARM Linux Mailing List" , "Russell King - ARM Linux" Subject: Re: [PATCH]: Atmel Serial Console interrupt handler splitup Message-ID: <20071218112907.609cc013@dhcp-252-066.norway.atmel.com> In-Reply-To: References: <3efb10970712070724i6fa66666t2b8422329759ce24@mail.gmail.com> <3efb10970712130840r7a2c5f72jca641d1cac545464@mail.gmail.com> <3efb10970712131232j5f747420g4aa8b5bd956e3dd3@mail.gmail.com> <3efb10970712131235t47a9ceb5y7d9a7d5023d07bf6@mail.gmail.com> <3efb10970712140346l1845d563k900d72d8788ac6f5@mail.gmail.com> <20071217131701.6b2cdf2c@dhcp-252-066.norway.atmel.com> <3efb10970712171256v4230eb38q84d01f2d0d554935@mail.gmail.com> <20071217234932.GH23657@flint.arm.linux.org.uk> <20071218100724.3e79629e@dhcp-252-066.norway.atmel.com> Organization: Atmel Norway X-Mailer: Claws Mail 3.1.0 (GTK+ 2.12.1; i486-pc-linux-gnu) Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 1319 Lines: 29 On Tue, 18 Dec 2007 12:08:05 +0200 "Andrew Victor" wrote: > > #define at_readl(port, off) __raw_readl((port)->membase + (off)) > > #define at_writel(v, port, off) __raw_writel(v, (port)->membase + (off)) > > > > #define UART_PUT_CR(port, v) at_writel(v, port, ATMEL_US_CR) > > #define UART_PUT_MR(port, v) at_writel(v, port, ATMEL_US_MR) > > I'd like to point out this relatively recent change to CodingStyle. > http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=dff4982f5cd4e30e2a140a3bca95d8814115bf5b > > So I don't see a reason for complicating the code by adding additional > macro's just to fit it in 80 column's. Hmm...yes, I think that change to the CodingStyle makes sense. But I guess the question is whether the old code "significantly increases readability" and whether the new code "hides information". I don't think so, but I don't feel all that strongly about it. I'd actually prefer if we used at_writel() and at_readl() throughout the code and killed those UART_PUT/UART_GET macros. Haavard -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/