Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1759401AbZDRUif (ORCPT ); Sat, 18 Apr 2009 16:38:35 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1754118AbZDRUiZ (ORCPT ); Sat, 18 Apr 2009 16:38:25 -0400 Received: from mx3.mail.elte.hu ([157.181.1.138]:44015 "EHLO mx3.mail.elte.hu" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753962AbZDRUiY (ORCPT ); Sat, 18 Apr 2009 16:38:24 -0400 Date: Sat, 18 Apr 2009 22:37:18 +0200 From: Ingo Molnar To: Kay Sievers Cc: Greg KH , Yinghai Lu , Linus Torvalds , Jesse Barnes , Andrew Morton , "H. Peter Anvin" , Thomas Gleixner , "linux-kernel@vger.kernel.org" , linux-pci@vger.kernel.org Subject: Re: [PATCH] pci: keep pci device resource name pointer right. Message-ID: <20090418203718.GD30144@elte.hu> References: <20090416235452.GE21405@elte.hu> <20090417131633.GA30578@elte.hu> <49E8FD0B.2050308@zytor.com> <49E96731.1000501@kernel.org> <49EA27B9.3030004@kernel.org> <20090418192314.GA22107@suse.de> <1240086446.2411.9.camel@poy> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <1240086446.2411.9.camel@poy> User-Agent: Mutt/1.5.18 (2008-05-17) X-ELTE-VirusStatus: clean X-ELTE-SpamScore: -1.5 X-ELTE-SpamLevel: X-ELTE-SpamCheck: no X-ELTE-SpamVersion: ELTE 2.0 X-ELTE-SpamCheck-Details: score=-1.5 required=5.9 tests=BAYES_00 autolearn=no SpamAssassin version=3.2.3 -1.5 BAYES_00 BODY: Bayesian spam probability is 0 to 1% [score: 0.0000] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Content-Length: 3128 Lines: 86 * Kay Sievers wrote: > On Sat, 2009-04-18 at 22:00 +0200, Kay Sievers wrote: > > On Sat, Apr 18, 2009 at 21:23, Greg KH wrote: > > > On Sat, Apr 18, 2009 at 12:19:21PM -0700, Yinghai Lu wrote: > > >> Linus Torvalds wrote: > > > > >> > Can we not make the rule be that the name should just be set before? > > > > I guess, that's what they do already, otherwise they could not use dev_name(). > > > > >> pci_bus_add_device will call device_add. > > >> > > >> actually in device_add > > >> > > >> /* first, register with generic layer. */ > > >> error = kobject_add(&dev->kobj, dev->kobj.parent, "%s", dev_name(dev)); > > >> if (error) > > >> goto Error; > > >> > > >> will get one new name for that kobj, old name is freed. > > >> > > >> Will try to make kobject_add more smart to reuse the old one. > > > > > > I don't understand the problem here, how are you going to change the > > > kobject core? Is this just because you aren't getting a name for the > > > resource? If so, why would the driver core care about this? > > > > Seems a bit odd what we do when registering a device. > > > > Usually one sets the name with dev_set_name() which will name the > > kobject. When one later registers the device, we reallocate the same > > name, so the pointer changes. I guess the problem here is that the pci > > code remembers the name pointer after it was set, but it will not be > > the same after the device is live. > > > > We should probably make device_add() pass a NULL as the name, and > > kobject_add() in that case use the name that is properly set already. > > Only to see if we are on the right track, does that fix the problem? If > yes, we will fix it properly without the NULL hack deep in the kobject > call. > > Thanks, > Kay > > diff --git a/drivers/base/core.c b/drivers/base/core.c > index d230ff4..1969b20 100644 > --- a/drivers/base/core.c > +++ b/drivers/base/core.c > @@ -890,8 +890,8 @@ int device_add(struct device *dev) > if (parent) > set_dev_node(dev, dev_to_node(parent)); > > - /* first, register with generic layer. */ > - error = kobject_add(&dev->kobj, dev->kobj.parent, "%s", dev_name(dev)); > + /* we require the name to be set before, and pass NULL */ > + error = kobject_add(&dev->kobj, dev->kobj.parent, NULL); > if (error) > goto Error; > > diff --git a/lib/kobject.c b/lib/kobject.c > index a6dec32..48565d6 100644 > --- a/lib/kobject.c > +++ b/lib/kobject.c > @@ -218,6 +218,9 @@ int kobject_set_name_vargs(struct kobject *kobj, const char *fmt, > const char *old_name = kobj->name; > char *s; > > + if (kobj->name && !fmt) > + return 0; > + > kobj->name = kvasprintf(GFP_KERNEL, fmt, vargs); > if (!kobj->name) > return -ENOMEM; This looks much cleaner to me - a NULL format string looks like a natural extension. Ingo -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/