2022-09-16 03:36:41

by liujing

[permalink] [raw]
Subject: [PATCH] KVM: duplicate code

in "static int FNAME(walk_addr_generic)" function,
there is an explanation that uses two to's, which is redundant code

Signed-off-by: liujing <[email protected]>
---
arch/x86/kvm/mmu/paging_tmpl.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/x86/kvm/mmu/paging_tmpl.h b/arch/x86/kvm/mmu/paging_tmpl.h
index 39e0205e7300..5ab5f94dcb6f 100644
--- a/arch/x86/kvm/mmu/paging_tmpl.h
+++ b/arch/x86/kvm/mmu/paging_tmpl.h
@@ -472,7 +472,7 @@ static int FNAME(walk_addr_generic)(struct guest_walker *walker,

#if PTTYPE == PTTYPE_EPT
/*
- * Use PFERR_RSVD_MASK in error_code to to tell if EPT
+ * Use PFERR_RSVD_MASK in error_code to tell if EPT
* misconfiguration requires to be injected. The detection is
* done by is_rsvd_bits_set() above.
*
--
2.18.2




2022-09-16 17:39:09

by Sean Christopherson

[permalink] [raw]
Subject: Re: [PATCH] KVM: duplicate code

"KVM: x86/mmu:" for the scope.

And explicitly state what the patch does, not what the symptom is, especially since
"duplicate" can be an adjective, noun, or a verb depending on context. And as an
almost nit, state that it's a comment so that it's obvious from the shortlog that
the patch should have no functional impact.

On Thu, Sep 15, 2022, liujing wrote:
> in "static int FNAME(walk_addr_generic)" function,
> there is an explanation that uses two to's, which is redundant code

Again, explicitly state what the patch actually does.

All that said, a patch has already been submitted for this[*]. No need to send a
v2, I'll grab the previous patch.

Thanks!

[*] https://lore.kernel.org/all/[email protected]