2000-11-25 10:58:31

by Gianluca Anzolin

[permalink] [raw]
Subject: PCI problem with an Olivetti M4

I have an old PC, it's an Olivetti M4 (P166) and I tried to
install linux on it. But I got a problem: just after LILO has loaded the
kernel (after 'Loading......') the screen becomes black and I can't see
anything. In other words the video card doesn't seem to work.

I also tested tha same system with FreeBSD and it works
without problems.

I can boot the linux kernel and I can access the system with
ssh. I found something interesting.

The video card is a PCI Trident 9660 integrated on the mainboard but
lspci doesn't show it:

fourier:~# lspci
00:00.0 Host bridge: Intel Corporation 430FX - 82437FX TSC [Triton I]
(rev 02)
00:07.0 ISA bridge: Intel Corporation 82371FB PIIX ISA [Triton I] (rev
00:07.1 IDE interface: Intel Corporation 82371FB PIIX IDE [Triton I]
(rev 02)

it doesn't find the PCI card. FreeBSD detects it with the pci id 00:09.0

I tried to boot either a 2.2.18pre17 kernel or a 2.4.0-test11 kernel.
No kernel worked. I tried also to change the PCI access: pci access
Direct, Any or BIOS... nothing changed...

I tried also to compile the vesa framebuffer (as the card should be
vesda compliant) but it didn't work.

On #kernelnewbies somebody told me to enable the DEBUG definition in the
pci subsystem and this is what I get in the dmesg (kernel 2.4.0-test11):

PCI: BIOS32 Service Directory structure at 0xc00fdb50
PCI: BIOS32 Service Directory entry at 0xfdb60
PCI: BIOS probe returned s=00 hw=01 ver=02.10 l=00
PCI: PCI BIOS revision 2.10 entry at 0xfdb81, last bus=0
PCI: Probing PCI hardware
PCI: IDE base address fixup for 00:07.1
PCI: Scanning for ghost devices on bus 0
PCI: IRQ init
PCI: IRQ fixup
PCI: Allocating resources
PCI: Resource 0000ffa0-0000ffaf (f=101, d=0, p=0)
PCI: Sorting device list...
Limiting direct PCI/PCI transfers.

On http://www.gest.unipd.it/~iig0573/lspci.txt you'll find the output of
lspci -xvv



2000-11-25 11:36:56

by Gianluca Anzolin

[permalink] [raw]
Subject: Re: PCI problem with an Olivetti M4

I've updated the http://www.gest.unipd.it/~iig0573/lspci.txt
to include the output of pciconf -l from FreeBSD