2008-11-16 02:41:27

by XazZ XazZ

[permalink] [raw]
Subject: Re: Problem with bluez and a bluetooth headset

good evening again

I got one step further after deleting my whole bluetooth-configuration
and setting everything bluetooth-related up from scratch :)

I got audio output on my headset working.
Audio input (recording) is sadly still not possible

bluetootd says the following when trying to record audio:
a2dp_source_cfg: no available SEP found
config failed

skype and arecord say the following as soon as I try to record audio:
ALSA lib pcm_bluetooth.c:712:(bluetooth_a2dp_hw_params)
BT_SETCONFIGURATION failed : Input/output error(5)

You can get the full bluetoothd log here: http://nopaste.ch/64aa1a77e7813e4.html

I also noticed that I can neither play nor record something when I set
profile "voice" in ~/.asoundrc
When I set it to profile "hifi" audio playback works fine.

Thanks for any help in advance


2008-11-16 22:16:51

by XazZ XazZ

[permalink] [raw]
Subject: Re: Problem with bluez and a bluetooth headset

Hi

> So BlueZ is trying to connect to A2DP. No wonder recording doesn't work (you
> need HSP/HFP for that). You can force HSP/HFP by adding a "profile voice"
> line to your .asoundrc entry.

Okay, I tried this again.
As soon as I change "profile hifi" to "profile voice" sound playback
stops working

[[email protected] ~]$ hciconfig hci0
hci0: Type: USB
BD Address: 00:11:67:8F:29:0E ACL MTU: 1021:8 SCO MTU: 48:10
UP RUNNING PSCAN
RX bytes:2487 acl:33 sco:0 events:110 errors:0
TX bytes:2126 acl:36 sco:0 commands:65 errors:0

That suggests that no sco packets have been sent (although there
should have been one)
I also get two hci_cmd_task: hci0 command tx timeout in my dmesg as
Brian Rogers said

Again the output of bluetoothd -nd:
http://nopaste.ch/502c8ee33709a6d.html (I hope it helps)
Maybe my device needs some quirk?

Oh, and I'm using the btusb driver which comes with 2.6.28 rc3 (Brian
Rogers uses the same driver)

XazZ