2020-04-19 07:11:48

by Tang Bin

[permalink] [raw]
Subject: [PATCH] crypto: Delete redundant variable definition

The variable "i" is redundant to be assigned a value
of zero,because it's assigned in the for loop, so remove
redundant one here.

Signed-off-by: Shengju Zhang <[email protected]>
Signed-off-by: Tang Bin <[email protected]>

---
drivers/crypto/bcm/cipher.c | 1 -
1 file changed, 1 deletion(-)

diff --git a/drivers/crypto/bcm/cipher.c b/drivers/crypto/bcm/cipher.c
index c8b940854..5db23c18c 100644
--- a/drivers/crypto/bcm/cipher.c
+++ b/drivers/crypto/bcm/cipher.c
@@ -4724,7 +4724,6 @@ static int spu_dt_read(struct platform_device *pdev)
spu->spu_type = matched_spu_type->type;
spu->spu_subtype = matched_spu_type->subtype;

- i = 0;
for (i = 0; (i < MAX_SPUS) && ((spu_ctrl_regs =
platform_get_resource(pdev, IORESOURCE_MEM, i)) != NULL); i++) {

--
2.20.1.windows.1




2020-04-19 11:47:51

by Joe Perches

[permalink] [raw]
Subject: Re: [PATCH] crypto: Delete redundant variable definition

On Sun, 2020-04-19 at 15:12 +0800, Tang Bin wrote:
> The variable "i" is redundant to be assigned a value
> of zero,because it's assigned in the for loop, so remove
> redundant one here.
>
> Signed-off-by: Shengju Zhang <[email protected]>
> Signed-off-by: Tang Bin <[email protected]>
>
> ---
> drivers/crypto/bcm/cipher.c | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/crypto/bcm/cipher.c b/drivers/crypto/bcm/cipher.c
> index c8b940854..5db23c18c 100644
> --- a/drivers/crypto/bcm/cipher.c
> +++ b/drivers/crypto/bcm/cipher.c
> @@ -4724,7 +4724,6 @@ static int spu_dt_read(struct platform_device *pdev)
> spu->spu_type = matched_spu_type->type;
> spu->spu_subtype = matched_spu_type->subtype;
>
> - i = 0;
> for (i = 0; (i < MAX_SPUS) && ((spu_ctrl_regs =
> platform_get_resource(pdev, IORESOURCE_MEM, i)) != NULL); i++) {

Maybe the for loop could be simplified too by
moving the assignment inside the loop.

Also, the %pe extension could be used.

Perhaps:
---
drivers/crypto/bcm/cipher.c | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

diff --git a/drivers/crypto/bcm/cipher.c b/drivers/crypto/bcm/cipher.c
index c8b940..7d6afa4 100644
--- a/drivers/crypto/bcm/cipher.c
+++ b/drivers/crypto/bcm/cipher.c
@@ -4707,7 +4707,6 @@ static int spu_dt_read(struct platform_device *pdev)
{
struct device *dev = &pdev->dev;
struct spu_hw *spu = &iproc_priv.spu;
- struct resource *spu_ctrl_regs;
const struct spu_type_subtype *matched_spu_type;
struct device_node *dn = pdev->dev.of_node;
int err, i;
@@ -4724,19 +4723,23 @@ static int spu_dt_read(struct platform_device *pdev)
spu->spu_type = matched_spu_type->type;
spu->spu_subtype = matched_spu_type->subtype;

- i = 0;
- for (i = 0; (i < MAX_SPUS) && ((spu_ctrl_regs =
- platform_get_resource(pdev, IORESOURCE_MEM, i)) != NULL); i++) {
+ for (i = 0; i < MAX_SPUS; i++) {
+ struct resource *spu_ctrl_regs;
+
+ spu_ctrl_regs = platform_get_resource(pdev, IORESOURCE_MEM, i);
+ if (!spu_ctrl_regs)
+ break;

spu->reg_vbase[i] = devm_ioremap_resource(dev, spu_ctrl_regs);
if (IS_ERR(spu->reg_vbase[i])) {
err = PTR_ERR(spu->reg_vbase[i]);
- dev_err(&pdev->dev, "Failed to map registers: %d\n",
- err);
+ dev_err(&pdev->dev, "Failed to map registers: %pe\n",
+ spu->reg_vbase[i]);
spu->reg_vbase[i] = NULL;
return err;
}
}
+
spu->num_spu = i;
dev_dbg(dev, "Device has %d SPUs", spu->num_spu);


2020-04-21 11:21:20

by Tang Bin

[permalink] [raw]
Subject: Re: [PATCH] crypto: Delete redundant variable definition

Hi, Joe:

On 2020/4/19 19:44, Joe Perches wrote:
> On Sun, 2020-04-19 at 15:12 +0800, Tang Bin wrote:
>> The variable "i" is redundant to be assigned a value
>> of zero,because it's assigned in the for loop, so remove
>> redundant one here.
>>
>> Signed-off-by: Shengju Zhang <[email protected]>
>> Signed-off-by: Tang Bin <[email protected]>
>>
>> ---
>> drivers/crypto/bcm/cipher.c | 1 -
>> 1 file changed, 1 deletion(-)
>>
>> diff --git a/drivers/crypto/bcm/cipher.c b/drivers/crypto/bcm/cipher.c
>> index c8b940854..5db23c18c 100644
>> --- a/drivers/crypto/bcm/cipher.c
>> +++ b/drivers/crypto/bcm/cipher.c
>> @@ -4724,7 +4724,6 @@ static int spu_dt_read(struct platform_device *pdev)
>> spu->spu_type = matched_spu_type->type;
>> spu->spu_subtype = matched_spu_type->subtype;
>>
>> - i = 0;
>> for (i = 0; (i < MAX_SPUS) && ((spu_ctrl_regs =
>> platform_get_resource(pdev, IORESOURCE_MEM, i)) != NULL); i++) {
> Maybe the for loop could be simplified too by
> moving the assignment inside the loop.
>
> Also, the %pe extension could be used.

Sorry for the delay. Thank you for your advice, I was already thinking
about optimizing this place.

Thanks,

Tang Bin


>


2020-04-24 07:48:13

by Herbert Xu

[permalink] [raw]
Subject: Re: [PATCH] crypto: Delete redundant variable definition

On Sun, Apr 19, 2020 at 03:12:45PM +0800, Tang Bin wrote:
> The variable "i" is redundant to be assigned a value
> of zero,because it's assigned in the for loop, so remove
> redundant one here.
>
> Signed-off-by: Shengju Zhang <[email protected]>
> Signed-off-by: Tang Bin <[email protected]>
>
> ---
> drivers/crypto/bcm/cipher.c | 1 -
> 1 file changed, 1 deletion(-)

Patch applied. Thanks.
--
Email: Herbert Xu <[email protected]>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt