2010-09-13 02:25:06

by Jeff Layton

[permalink] [raw]
Subject: Re: [PATCH -v2 2/6] ntlmv2/ntlmssp ntlmssp autentication code

> >
> > Would it be reasonable to split the simple mac_key to session_key
> > rename part into a separate patch from the ones that actually change
> > behavior?
> OK. But I am not sure what we are trying to achieve here churning
> these patches so
> many times for a simple change. Not sure who the audience is.

I'm trying to achieve clarity and bisectability. By separating the
trivial changes from the substantive ones, the patches become smaller
and the changes they introduce are more evident.

For the clarity piece, the audience is those of us who are spending
time to review them (so far, Steve, Suresh and I). All of us have
limited amounts of time available to spend on review. None of us
want to spend time sifting through the trivial changes in these patches
to hunt down the ones that actually change behavior.

Jeff Layton <[email protected]>