2010-09-13 02:43:01

by Shirish Pargaonkar

[permalink] [raw]
Subject: Re: [PATCH -v2 2/6] ntlmv2/ntlmssp ntlmssp autentication code

On Sun, Sep 12, 2010 at 9:25 PM, Jeff Layton <[email protected]> wrote:
>> >
>> > Would it be reasonable to split the simple mac_key to session_key
>> > rename part into a separate patch from the ones that actually change
>> > behavior?
>> OK. But I am not sure what we are trying to achieve here churning
>> these patches so
>> many times for a simple change. ?Not sure who the audience is.
> I'm trying to achieve clarity and bisectability. By separating the
> trivial changes from the substantive ones, the patches become smaller
> and the changes they introduce are more evident.
> For the clarity piece, the audience is those of us who are spending
> time to review them (so far, Steve, Suresh and I). All of us have
> limited amounts of time available to spend on review. None of us
> want to spend time sifting through the trivial changes in these patches
> to hunt down the ones that actually change behavior.
> --
> Jeff Layton <[email protected]>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-cifs" in
> the body of a message to [email protected]
> More majordomo info at ?http://vger.kernel.org/majordomo-info.html

OK, I will make the change. I am now not sure whether that should be
a separate patch altogether or one of the patches that belongs to this patchset
i.e. 2 of x or 3 of x etc..