2008-04-02 14:03:22

by Jose R. Santos

[permalink] [raw]
Subject: [PATCH][TRIVIAL][e2fsprogs] Rename uninit_groups to uninit_bg.

From: Jose R. Santos <[email protected]>

Rename uninit_groups to uninit_bg.

<meta_bg> <flex_bg> <uninit_groups> <lazy_bg>

One of these things is not like the others,
One of these things just doesn't belong,
Can you tell which thing is not like the others
By the time I finish my song?
by Joe Raposo

Signed-off-by: Jose R. Santos <[email protected]>
--

e2fsck/unix.c | 2 +-
lib/e2p/feature.c | 2 +-
misc/mke2fs.8.in | 2 +-
misc/tune2fs.8.in | 4 ++--
resize/main.c | 2 +-
5 files changed, 6 insertions(+), 6 deletions(-)


diff --git a/e2fsck/unix.c b/e2fsck/unix.c
index 7b662e4..a868d87 100644
--- a/e2fsck/unix.c
+++ b/e2fsck/unix.c
@@ -559,7 +559,7 @@ static void parse_extended_opts(e2fsck_t ctx, const char *opts)
"is set off by an equals ('=') sign. "
"Valid extended options are:\n"
"\tea_ver=<ea_version (1 or 2)>\n"
- "\tuninit_groups\n"
+ "\tuninit_bg\n"
"\tinit_groups\n\n"), stderr);
exit(1);
}
diff --git a/lib/e2p/feature.c b/lib/e2p/feature.c
index cf37447..3fc4f91 100644
--- a/lib/e2p/feature.c
+++ b/lib/e2p/feature.c
@@ -45,7 +45,7 @@ static struct feature feature_list[] = {
{ E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_HUGE_FILE,
"huge_file" },
{ E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_GDT_CSUM,
- "uninit_groups" },
+ "uninit_bg" },
{ E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_DIR_NLINK,
"dir_nlink" },
{ E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_EXTRA_ISIZE,
diff --git a/misc/mke2fs.8.in b/misc/mke2fs.8.in
index 9cc3895..7eebe40 100644
--- a/misc/mke2fs.8.in
+++ b/misc/mke2fs.8.in
@@ -443,7 +443,7 @@ to create a large virtual block group).
.B has_journal
Create an ext3 journal (as if using the
.TP
-.B uninit_groups
+.B uninit_bg
Create a filesystem without initializing all of the groups. This speeds
up filesystem creation time noticably, and can also reduce
.BR e2fsck time
diff --git a/misc/tune2fs.8.in b/misc/tune2fs.8.in
index b5af4d0..3215808 100644
--- a/misc/tune2fs.8.in
+++ b/misc/tune2fs.8.in
@@ -440,7 +440,7 @@ future.
.B Tune2fs
only supports clearing this filesystem feature.
.TP
-.B uninit_groups
+.B uninit_bg
Allow the kernel to initialize bitmaps and inode tables and keep a high
watermark for the unused inodes in a filesystem, to reduce
.BR e2fsck (8)
@@ -449,7 +449,7 @@ time.
.IP
After setting or clearing
.BR sparse_super ,
-.BR uninit_groups ,
+.BR uninit_bg ,
.BR filetype ,
or
.B resize_inode
diff --git a/resize/main.c b/resize/main.c
index 2e5c89c..8b90e96 100644
--- a/resize/main.c
+++ b/resize/main.c
@@ -309,7 +309,7 @@ int main (int argc, char ** argv)

if (fs->super->s_feature_ro_compat & EXT4_FEATURE_RO_COMPAT_GDT_CSUM) {
com_err(program_name, EXT2_ET_RO_UNSUPP_FEATURE,
- ":- uninit_groups");
+ ":- uninit_bg");
exit(1);
}




2008-04-10 16:37:05

by Andreas Dilger

[permalink] [raw]
Subject: Re: [PATCH][TRIVIAL][e2fsprogs] Rename uninit_groups to uninit_bg.

On Apr 02, 2008 09:03 -0500, Jose R. Santos wrote:
> Rename uninit_groups to uninit_bg.
>
> <meta_bg> <flex_bg> <uninit_groups> <lazy_bg>
>
> One of these things is not like the others,
> One of these things just doesn't belong,
> Can you tell which thing is not like the others
> By the time I finish my song?
> by Joe Raposo

Jose,
I don't disagree with this change, but can you please keep compatibility
with the old name for some time, as we have been using the "uninit_groups"
name for some time already.

> diff --git a/lib/e2p/feature.c b/lib/e2p/feature.c
> index cf37447..3fc4f91 100644
> --- a/lib/e2p/feature.c
> +++ b/lib/e2p/feature.c
> @@ -45,7 +45,7 @@ static struct feature feature_list[] = {
> { E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_HUGE_FILE,
> "huge_file" },
> { E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_GDT_CSUM,
> - "uninit_groups" },
> + "uninit_bg" },

I think we just need an additional stanza here after this one which has
the old name in it. That way lookup-by-value will find uninit_bg, and
lookup-by-name will still work.

Cheers, Andreas
--
Andreas Dilger
Sr. Staff Engineer, Lustre Group
Sun Microsystems of Canada, Inc.


2008-04-10 17:06:15

by Jose R. Santos

[permalink] [raw]
Subject: Re: [PATCH][TRIVIAL][e2fsprogs] Rename uninit_groups to uninit_bg.

On Thu, 10 Apr 2008 10:33:14 -0600
Andreas Dilger <[email protected]> wrote:

> On Apr 02, 2008 09:03 -0500, Jose R. Santos wrote:
> > Rename uninit_groups to uninit_bg.
> >
> > <meta_bg> <flex_bg> <uninit_groups> <lazy_bg>
> >
> > One of these things is not like the others,
> > One of these things just doesn't belong,
> > Can you tell which thing is not like the others
> > By the time I finish my song?
> > by Joe Raposo
>
> Jose,
> I don't disagree with this change, but can you please keep compatibility
> with the old name for some time, as we have been using the "uninit_groups"
> name for some time already.

I thought that since the uninit patches where still cooking in the pu
branch and not made part of any official release, changing a feature
name without caring about backward compatibility was OK. Or is it to
maintain compatibility with Luster?

> > diff --git a/lib/e2p/feature.c b/lib/e2p/feature.c
> > index cf37447..3fc4f91 100644
> > --- a/lib/e2p/feature.c
> > +++ b/lib/e2p/feature.c
> > @@ -45,7 +45,7 @@ static struct feature feature_list[] = {
> > { E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_HUGE_FILE,
> > "huge_file" },
> > { E2P_FEATURE_RO_INCOMPAT, EXT4_FEATURE_RO_COMPAT_GDT_CSUM,
> > - "uninit_groups" },
> > + "uninit_bg" },
>
> I think we just need an additional stanza here after this one which has
> the old name in it. That way lookup-by-value will find uninit_bg, and
> lookup-by-name will still work.

I will send another patch with the added stanza.

> Cheers, Andreas
> --
> Andreas Dilger
> Sr. Staff Engineer, Lustre Group
> Sun Microsystems of Canada, Inc.
>



-JRS