2013-03-05 23:09:44

by Alexander Mezin

[permalink] [raw]
Subject: Re: BCM4313 problems connecting to AP since 3.8

Arend van Spriel <[email protected]> writes:

>
> On 03/04/13 22:47, Ján Veselý wrote:
> > Hi,
> >
> > after upgrading to 3.8 I started running into a timeout problem on
> > BCM4313 wifi using brcmsmac driver (compiled as module, x86_64).
> > the card is unable to connect to ap after startup of resume.
> > Although it eventually connects it takes a long time (several minutes)
> > and dmesg log is spammed with:
> >
> > [ 144.725431] wlan0: authenticate with 00:23:f8:8f:29:14
> > [ 144.727786] wlan0: capabilities/regulatory prevented using AP
> > HT/VHT configuration, downgraded
> > [ 144.727820] wlan0: direct probe to 00:23:f8:8f:29:14 (try 1/3)
> > [ 144.930780] wlan0: direct probe to 00:23:f8:8f:29:14 (try 2/3)
> > [ 145.133855] wlan0: direct probe to 00:23:f8:8f:29:14 (try 3/3)
> > [ 145.336931] wlan0: authentication with 00:23:f8:8f:29:14 timed out
> > [ 151.217245] wlan0: authenticate with 00:23:f8:8f:29:14
> >
> > (30+ times in some cases)

Had the same problem.
It seems that this commit introduces the bug:
https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?
id=b6fc28a158076ca2764edc9a6d1e1402f56e1c0c
I reverted it and now I have successful connection on first attempt. Linux
3.8.2, BCM4313 802.11b/g/n Wireless LAN Controller.



2013-03-06 22:05:39

by Ján Veselý

[permalink] [raw]
Subject: Re: BCM4313 problems connecting to AP since 3.8

On Wed, Mar 6, 2013 at 9:00 PM, Ján Veselý <[email protected]> wrote:
> hi,
> this is what my card says:
>
> # cat /sys/kernel/debug/brcmsmac/bcma0\:0/hardware
> board vendor: 1028
> board type: 10
> board revision: 2400
> board flags: 8002a00
> board flags2: 0
> firmware revision: 262032b
>
> I'll try to verify that reverting that commit fixes my problem as well.

I confirm that reverting said commit fixes my problems (tested on 3.9-rc1),

>
> Jan
>
> On Wed, Mar 6, 2013 at 11:20 AM, Piotr Haber <[email protected]> wrote:
>> On 03/06/13 00:06, Alexander Mezin wrote:
>>> Arend van Spriel <[email protected]> writes:
>>>
>>>>
>>>> On 03/04/13 22:47, Ján Veselý wrote:
>>>>> Hi,
>>>>>
>>>>> after upgrading to 3.8 I started running into a timeout problem on
>>>>> BCM4313 wifi using brcmsmac driver (compiled as module, x86_64).
>>>>> the card is unable to connect to ap after startup of resume.
>>>>> Although it eventually connects it takes a long time (several minutes)
>>>>> and dmesg log is spammed with:
>>>>>
>>>>> [ 144.725431] wlan0: authenticate with 00:23:f8:8f:29:14
>>>>> [ 144.727786] wlan0: capabilities/regulatory prevented using AP
>>>>> HT/VHT configuration, downgraded
>>>>> [ 144.727820] wlan0: direct probe to 00:23:f8:8f:29:14 (try 1/3)
>>>>> [ 144.930780] wlan0: direct probe to 00:23:f8:8f:29:14 (try 2/3)
>>>>> [ 145.133855] wlan0: direct probe to 00:23:f8:8f:29:14 (try 3/3)
>>>>> [ 145.336931] wlan0: authentication with 00:23:f8:8f:29:14 timed out
>>>>> [ 151.217245] wlan0: authenticate with 00:23:f8:8f:29:14
>>>>>
>>>>> (30+ times in some cases)
>>>
>>> Had the same problem.
>>> It seems that this commit introduces the bug:
>>> https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?
>>> id=b6fc28a158076ca2764edc9a6d1e1402f56e1c0c
>>> I reverted it and now I have successful connection on first attempt. Linux
>>> 3.8.2, BCM4313 802.11b/g/n Wireless LAN Controller.
>>>
>> Hi,
>> that's disturbing.
>> I wonder what hardware version you have.
>> Could you share the contents of this debugfs file:
>> <debugfs_mount>/brcmsmac/bcma0:0/hardware
>>
>> Piotr
>>
>>
>>

2013-03-06 20:00:25

by Ján Veselý

[permalink] [raw]
Subject: Re: BCM4313 problems connecting to AP since 3.8

hi,
this is what my card says:

# cat /sys/kernel/debug/brcmsmac/bcma0\:0/hardware
board vendor: 1028
board type: 10
board revision: 2400
board flags: 8002a00
board flags2: 0
firmware revision: 262032b

I'll try to verify that reverting that commit fixes my problem as well.

Jan

On Wed, Mar 6, 2013 at 11:20 AM, Piotr Haber <[email protected]> wrote:
> On 03/06/13 00:06, Alexander Mezin wrote:
>> Arend van Spriel <[email protected]> writes:
>>
>>>
>>> On 03/04/13 22:47, Ján Veselý wrote:
>>>> Hi,
>>>>
>>>> after upgrading to 3.8 I started running into a timeout problem on
>>>> BCM4313 wifi using brcmsmac driver (compiled as module, x86_64).
>>>> the card is unable to connect to ap after startup of resume.
>>>> Although it eventually connects it takes a long time (several minutes)
>>>> and dmesg log is spammed with:
>>>>
>>>> [ 144.725431] wlan0: authenticate with 00:23:f8:8f:29:14
>>>> [ 144.727786] wlan0: capabilities/regulatory prevented using AP
>>>> HT/VHT configuration, downgraded
>>>> [ 144.727820] wlan0: direct probe to 00:23:f8:8f:29:14 (try 1/3)
>>>> [ 144.930780] wlan0: direct probe to 00:23:f8:8f:29:14 (try 2/3)
>>>> [ 145.133855] wlan0: direct probe to 00:23:f8:8f:29:14 (try 3/3)
>>>> [ 145.336931] wlan0: authentication with 00:23:f8:8f:29:14 timed out
>>>> [ 151.217245] wlan0: authenticate with 00:23:f8:8f:29:14
>>>>
>>>> (30+ times in some cases)
>>
>> Had the same problem.
>> It seems that this commit introduces the bug:
>> https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?
>> id=b6fc28a158076ca2764edc9a6d1e1402f56e1c0c
>> I reverted it and now I have successful connection on first attempt. Linux
>> 3.8.2, BCM4313 802.11b/g/n Wireless LAN Controller.
>>
> Hi,
> that's disturbing.
> I wonder what hardware version you have.
> Could you share the contents of this debugfs file:
> <debugfs_mount>/brcmsmac/bcma0:0/hardware
>
> Piotr
>
>
>

2013-03-06 10:21:11

by Piotr Haber

[permalink] [raw]
Subject: Re: BCM4313 problems connecting to AP since 3.8

On 03/06/13 00:06, Alexander Mezin wrote:
> Arend van Spriel <[email protected]> writes:
>
>>
>> On 03/04/13 22:47, Ján Veselý wrote:
>>> Hi,
>>>
>>> after upgrading to 3.8 I started running into a timeout problem on
>>> BCM4313 wifi using brcmsmac driver (compiled as module, x86_64).
>>> the card is unable to connect to ap after startup of resume.
>>> Although it eventually connects it takes a long time (several minutes)
>>> and dmesg log is spammed with:
>>>
>>> [ 144.725431] wlan0: authenticate with 00:23:f8:8f:29:14
>>> [ 144.727786] wlan0: capabilities/regulatory prevented using AP
>>> HT/VHT configuration, downgraded
>>> [ 144.727820] wlan0: direct probe to 00:23:f8:8f:29:14 (try 1/3)
>>> [ 144.930780] wlan0: direct probe to 00:23:f8:8f:29:14 (try 2/3)
>>> [ 145.133855] wlan0: direct probe to 00:23:f8:8f:29:14 (try 3/3)
>>> [ 145.336931] wlan0: authentication with 00:23:f8:8f:29:14 timed out
>>> [ 151.217245] wlan0: authenticate with 00:23:f8:8f:29:14
>>>
>>> (30+ times in some cases)
>
> Had the same problem.
> It seems that this commit introduces the bug:
> https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/?
> id=b6fc28a158076ca2764edc9a6d1e1402f56e1c0c
> I reverted it and now I have successful connection on first attempt. Linux
> 3.8.2, BCM4313 802.11b/g/n Wireless LAN Controller.
>
Hi,
that's disturbing.
I wonder what hardware version you have.
Could you share the contents of this debugfs file:
<debugfs_mount>/brcmsmac/bcma0:0/hardware

Piotr