2021-03-24 12:24:18

by Paulius Zaleckas

[permalink] [raw]
Subject: Intel AX210 does not work on 5.11

It was working on 5.10.16:
[ 4.274856] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
[ 4.279014] iwlwifi 0000:3c:00.0: api flags index 2 larger than
supported by driver
[ 4.279031] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
Version: 93.8.63.28
[ 4.279401] iwlwifi 0000:3c:00.0: loaded firmware version
59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[ 4.456228] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
160MHz, REV=0x420
[ 4.607524] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
[ 4.673134] iwlwifi 0000:3c:00.0: base HW address: d8:f8:83:d9:35:87
[ 6.055731] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
[ 6.288461] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
[ 72.546602] iwlwifi 0000:3c:00.0 wlan0: disabling HT/VHT/HE as
WMM/QoS is not supported by the AP

And fails to start on 5.11.8:
[ 3.882744] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
[ 3.937708] iwlwifi 0000:3c:00.0: api flags index 2 larger than
supported by driver
[ 3.937720] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
Version: 93.8.63.28
[ 3.937891] iwlwifi 0000:3c:00.0: loaded firmware version
59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[ 4.341262] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
160MHz, REV=0x420
[ 4.486405] iwlwifi 0000:3c:00.0: loaded PNVM version 0x324cd670
[ 4.588212] iwlwifi 0000:3c:00.0: Timeout waiting for PNVM load!
[ 4.588213] iwlwifi 0000:3c:00.0: Failed to start RT ucode: -110
[ 4.588215] iwlwifi 0000:3c:00.0: iwl_trans_send_cmd bad state = 1
[ 4.796206] iwlwifi 0000:3c:00.0: firmware didn't ACK the reset -
continue anyway
[ 4.808321] iwlwifi 0000:3c:00.0: Failed to run INIT ucode: -110

Please add me to Cc as I am not on the list.


2021-03-24 12:27:13

by Ben Greear

[permalink] [raw]
Subject: Re: Intel AX210 does not work on 5.11

On 3/24/21 5:21 AM, Paulius Zaleckas wrote:
> It was working on 5.10.16:
> [ 4.274856] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> [ 4.279014] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> supported by driver
> [ 4.279031] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> Version: 93.8.63.28
> [ 4.279401] iwlwifi 0000:3c:00.0: loaded firmware version
> 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> [ 4.456228] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> 160MHz, REV=0x420
> [ 4.607524] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> [ 4.673134] iwlwifi 0000:3c:00.0: base HW address: d8:f8:83:d9:35:87
> [ 6.055731] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> [ 6.288461] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> [ 72.546602] iwlwifi 0000:3c:00.0 wlan0: disabling HT/VHT/HE as
> WMM/QoS is not supported by the AP
>
> And fails to start on 5.11.8:
> [ 3.882744] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> [ 3.937708] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> supported by driver
> [ 3.937720] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> Version: 93.8.63.28
> [ 3.937891] iwlwifi 0000:3c:00.0: loaded firmware version
> 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> [ 4.341262] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> 160MHz, REV=0x420
> [ 4.486405] iwlwifi 0000:3c:00.0: loaded PNVM version 0x324cd670
> [ 4.588212] iwlwifi 0000:3c:00.0: Timeout waiting for PNVM load!
> [ 4.588213] iwlwifi 0000:3c:00.0: Failed to start RT ucode: -110
> [ 4.588215] iwlwifi 0000:3c:00.0: iwl_trans_send_cmd bad state = 1
> [ 4.796206] iwlwifi 0000:3c:00.0: firmware didn't ACK the reset -
> continue anyway
> [ 4.808321] iwlwifi 0000:3c:00.0: Failed to run INIT ucode: -110
>
> Please add me to Cc as I am not on the list.
>

You probably need to get latest firmware from https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
and splat the intel related firmware into /lib/firmware/

This is the pnvm that is on my system:

-rw-r--r-- 1 root root 1455104 Mar 9 16:42 iwlwifi-ty-a0-gf-a0-62.ucode
-rw-r--r-- 1 root root 1292672 Mar 10 08:40 iwlwifi-cc-a0-62.ucode
-rw-r--r-- 1 root root 27456 Mar 19 10:25 iwlwifi-ty-a0-gf-a0.pnvm

Thanks,
Ben

--
Ben Greear <[email protected]>
Candela Technologies Inc http://www.candelatech.com

2021-03-24 13:49:26

by Paulius Zaleckas

[permalink] [raw]
Subject: Re: Intel AX210 does not work on 5.11

On Wed, Mar 24, 2021 at 2:24 PM Ben Greear <[email protected]> wrote:
>
> On 3/24/21 5:21 AM, Paulius Zaleckas wrote:
> > It was working on 5.10.16:
> > [ 4.274856] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > [ 4.279014] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > supported by driver
> > [ 4.279031] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > Version: 93.8.63.28
> > [ 4.279401] iwlwifi 0000:3c:00.0: loaded firmware version
> > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > [ 4.456228] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > 160MHz, REV=0x420
> > [ 4.607524] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > [ 4.673134] iwlwifi 0000:3c:00.0: base HW address: d8:f8:83:d9:35:87
> > [ 6.055731] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > [ 6.288461] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > [ 72.546602] iwlwifi 0000:3c:00.0 wlan0: disabling HT/VHT/HE as
> > WMM/QoS is not supported by the AP
> >
> > And fails to start on 5.11.8:
> > [ 3.882744] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > [ 3.937708] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > supported by driver
> > [ 3.937720] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > Version: 93.8.63.28
> > [ 3.937891] iwlwifi 0000:3c:00.0: loaded firmware version
> > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > [ 4.341262] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > 160MHz, REV=0x420
> > [ 4.486405] iwlwifi 0000:3c:00.0: loaded PNVM version 0x324cd670
> > [ 4.588212] iwlwifi 0000:3c:00.0: Timeout waiting for PNVM load!
> > [ 4.588213] iwlwifi 0000:3c:00.0: Failed to start RT ucode: -110
> > [ 4.588215] iwlwifi 0000:3c:00.0: iwl_trans_send_cmd bad state = 1
> > [ 4.796206] iwlwifi 0000:3c:00.0: firmware didn't ACK the reset -
> > continue anyway
> > [ 4.808321] iwlwifi 0000:3c:00.0: Failed to run INIT ucode: -110
> >
> > Please add me to Cc as I am not on the list.
> >
>
> You probably need to get latest firmware from https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
> and splat the intel related firmware into /lib/firmware/

Did that, but still the same issue...

2021-03-24 16:18:18

by Paulius Zaleckas

[permalink] [raw]
Subject: Re: Intel AX210 does not work on 5.11

On Wed, Mar 24, 2021 at 3:46 PM Paulius Zaleckas
<[email protected]> wrote:
>
> On Wed, Mar 24, 2021 at 2:24 PM Ben Greear <greea[email protected]> wrote:
> >
> > On 3/24/21 5:21 AM, Paulius Zaleckas wrote:
> > > It was working on 5.10.16:
> > > [ 4.274856] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > > [ 4.279014] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > > supported by driver
> > > [ 4.279031] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > > Version: 93.8.63.28
> > > [ 4.279401] iwlwifi 0000:3c:00.0: loaded firmware version
> > > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > > [ 4.456228] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > > 160MHz, REV=0x420
> > > [ 4.607524] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > [ 4.673134] iwlwifi 0000:3c:00.0: base HW address: d8:f8:83:d9:35:87
> > > [ 6.055731] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > [ 6.288461] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > [ 72.546602] iwlwifi 0000:3c:00.0 wlan0: disabling HT/VHT/HE as
> > > WMM/QoS is not supported by the AP
> > >
> > > And fails to start on 5.11.8:
> > > [ 3.882744] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > > [ 3.937708] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > > supported by driver
> > > [ 3.937720] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > > Version: 93.8.63.28
> > > [ 3.937891] iwlwifi 0000:3c:00.0: loaded firmware version
> > > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > > [ 4.341262] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > > 160MHz, REV=0x420
> > > [ 4.486405] iwlwifi 0000:3c:00.0: loaded PNVM version 0x324cd670
> > > [ 4.588212] iwlwifi 0000:3c:00.0: Timeout waiting for PNVM load!
> > > [ 4.588213] iwlwifi 0000:3c:00.0: Failed to start RT ucode: -110
> > > [ 4.588215] iwlwifi 0000:3c:00.0: iwl_trans_send_cmd bad state = 1
> > > [ 4.796206] iwlwifi 0000:3c:00.0: firmware didn't ACK the reset -
> > > continue anyway
> > > [ 4.808321] iwlwifi 0000:3c:00.0: Failed to run INIT ucode: -110
> > >
> > > Please add me to Cc as I am not on the list.
> > >
> >
> > You probably need to get latest firmware from https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
> > and splat the intel related firmware into /lib/firmware/
>
> Did that, but still the same issue...

Removing /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm fixed this issue.

2021-03-24 16:28:26

by Paulius Zaleckas

[permalink] [raw]
Subject: Re: Intel AX210 does not work on 5.11

On Wed, Mar 24, 2021 at 6:16 PM Paulius Zaleckas
<[email protected]> wrote:
>
> On Wed, Mar 24, 2021 at 3:46 PM Paulius Zaleckas
> <[email protected]> wrote:
> >
> > On Wed, Mar 24, 2021 at 2:24 PM Ben Greear <[email protected]> wrote:
> > >
> > > On 3/24/21 5:21 AM, Paulius Zaleckas wrote:
> > > > It was working on 5.10.16:
> > > > [ 4.274856] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > > > [ 4.279014] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > > > supported by driver
> > > > [ 4.279031] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > > > Version: 93.8.63.28
> > > > [ 4.279401] iwlwifi 0000:3c:00.0: loaded firmware version
> > > > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > > > [ 4.456228] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > > > 160MHz, REV=0x420
> > > > [ 4.607524] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > > [ 4.673134] iwlwifi 0000:3c:00.0: base HW address: d8:f8:83:d9:35:87
> > > > [ 6.055731] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > > [ 6.288461] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > > [ 72.546602] iwlwifi 0000:3c:00.0 wlan0: disabling HT/VHT/HE as
> > > > WMM/QoS is not supported by the AP
> > > >
> > > > And fails to start on 5.11.8:
> > > > [ 3.882744] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > > > [ 3.937708] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > > > supported by driver
> > > > [ 3.937720] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > > > Version: 93.8.63.28
> > > > [ 3.937891] iwlwifi 0000:3c:00.0: loaded firmware version
> > > > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > > > [ 4.341262] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > > > 160MHz, REV=0x420
> > > > [ 4.486405] iwlwifi 0000:3c:00.0: loaded PNVM version 0x324cd670
> > > > [ 4.588212] iwlwifi 0000:3c:00.0: Timeout waiting for PNVM load!
> > > > [ 4.588213] iwlwifi 0000:3c:00.0: Failed to start RT ucode: -110
> > > > [ 4.588215] iwlwifi 0000:3c:00.0: iwl_trans_send_cmd bad state = 1
> > > > [ 4.796206] iwlwifi 0000:3c:00.0: firmware didn't ACK the reset -
> > > > continue anyway
> > > > [ 4.808321] iwlwifi 0000:3c:00.0: Failed to run INIT ucode: -110
> > > >
> > > > Please add me to Cc as I am not on the list.
> > > >
> > >
> > > You probably need to get latest firmware from https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
> > > and splat the intel related firmware into /lib/firmware/
> >
> > Did that, but still the same issue...
>
> Removing /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm fixed this issue.

Found more info on Gentoo bugs: https://bugs.gentoo.org/777324#c6
So either commit 000735e5dbbb739ca3742413858c1d9cac899e10 should be
ported to 5.11-stable or PNVM loading disabled.

2021-03-26 06:46:56

by Coelho, Luciano

[permalink] [raw]
Subject: Re: Intel AX210 does not work on 5.11

On Wed, 2021-03-24 at 18:25 +0200, Paulius Zaleckas wrote:
> On Wed, Mar 24, 2021 at 6:16 PM Paulius Zaleckas
> <[email protected]> wrote:
> >
> > On Wed, Mar 24, 2021 at 3:46 PM Paulius Zaleckas
> > <[email protected]> wrote:
> > >
> > > On Wed, Mar 24, 2021 at 2:24 PM Ben Greear <[email protected]> wrote:
> > > >
> > > > On 3/24/21 5:21 AM, Paulius Zaleckas wrote:
> > > > > It was working on 5.10.16:
> > > > > [ 4.274856] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > > > > [ 4.279014] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > > > > supported by driver
> > > > > [ 4.279031] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > > > > Version: 93.8.63.28
> > > > > [ 4.279401] iwlwifi 0000:3c:00.0: loaded firmware version
> > > > > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > > > > [ 4.456228] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > > > > 160MHz, REV=0x420
> > > > > [ 4.607524] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > > > [ 4.673134] iwlwifi 0000:3c:00.0: base HW address: d8:f8:83:d9:35:87
> > > > > [ 6.055731] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > > > [ 6.288461] iwlwifi 0000:3c:00.0: invalid TLV len: 8/12
> > > > > [ 72.546602] iwlwifi 0000:3c:00.0 wlan0: disabling HT/VHT/HE as
> > > > > WMM/QoS is not supported by the AP
> > > > >
> > > > > And fails to start on 5.11.8:
> > > > > [ 3.882744] iwlwifi 0000:3c:00.0: enabling device (0000 -> 0002)
> > > > > [ 3.937708] iwlwifi 0000:3c:00.0: api flags index 2 larger than
> > > > > supported by driver
> > > > > [ 3.937720] iwlwifi 0000:3c:00.0: TLV_FW_FSEQ_VERSION: FSEQ
> > > > > Version: 93.8.63.28
> > > > > [ 3.937891] iwlwifi 0000:3c:00.0: loaded firmware version
> > > > > 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
> > > > > [ 4.341262] iwlwifi 0000:3c:00.0: Detected Intel(R) Wi-Fi 6 AX210
> > > > > 160MHz, REV=0x420
> > > > > [ 4.486405] iwlwifi 0000:3c:00.0: loaded PNVM version 0x324cd670
> > > > > [ 4.588212] iwlwifi 0000:3c:00.0: Timeout waiting for PNVM load!
> > > > > [ 4.588213] iwlwifi 0000:3c:00.0: Failed to start RT ucode: -110
> > > > > [ 4.588215] iwlwifi 0000:3c:00.0: iwl_trans_send_cmd bad state = 1
> > > > > [ 4.796206] iwlwifi 0000:3c:00.0: firmware didn't ACK the reset -
> > > > > continue anyway
> > > > > [ 4.808321] iwlwifi 0000:3c:00.0: Failed to run INIT ucode: -110
> > > > >
> > > > > Please add me to Cc as I am not on the list.
> > > > >
> > > >
> > > > You probably need to get latest firmware from https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/linux-firmware.git
> > > > and splat the intel related firmware into /lib/firmware/
> > >
> > > Did that, but still the same issue...
> >
> > Removing /lib/firmware/iwlwifi-ty-a0-gf-a0.pnvm fixed this issue.
>
> Found more info on Gentoo bugs: https://bugs.gentoo.org/777324#c6
> So either commit 000735e5dbbb739ca3742413858c1d9cac899e10 should be
> ported to 5.11-stable or PNVM loading disabled.

Unfortunately we can't just backport the FW version bump. There are
actual API changes that need to be supported, so that would require an
unfeasible amount of changes for a stable tree.

We have two options:

1. Try to take a fix to the -59.ucode firmware (I'll take this
internally)

2. Prevent the driver from loading the PNVM file when older firmwares
are used (I'll check if there is a proper way to do this without
relying on the actual version number).

--
Cheers,
Luca.