2002-09-15 18:13:28

by Pavel Machek

[permalink] [raw]
Subject: vesafb one pixel left?!

Hi!

On 2.5.34 I noticed that one pixel at the left was missing. I switched
consoles and problem went away. Weird.
Pavel
--
Worst form of spam? Adding advertisment signatures ala sourceforge.net.
What goes next? Inserting advertisment *into* email?


2002-09-15 18:23:49

by John Levon

[permalink] [raw]
Subject: Re: vesafb one pixel left?!

On Sun, Sep 15, 2002 at 08:16:32PM +0200, Pavel Machek wrote:

> Hi!
>
> On 2.5.34 I noticed that one pixel at the left was missing. I switched
> consoles and problem went away. Weird.

I have had pixel droppings and missing pixels with vesafb for as long as
I remember (that is, years)

regards
john
--
"Be advised. Your bedroom may quietly detach from the house while you sleep."
- Sarah Bee

2002-09-15 21:15:06

by Gerhard Mack

[permalink] [raw]
Subject: Re: vesafb one pixel left?!

On Sun, 15 Sep 2002, John Levon wrote:

> On Sun, Sep 15, 2002 at 08:16:32PM +0200, Pavel Machek wrote:
>
> > Hi!
> >
> > On 2.5.34 I noticed that one pixel at the left was missing. I switched
> > consoles and problem went away. Weird.
>
> I have had pixel droppings and missing pixels with vesafb for as long as
> I remember (that is, years)

I could be mistaken but I seem to recall that problem with DOS as well
afik vesa tends to be a bit lossy due to some sort of design problem.

Gerhard


--
Gerhard Mack

[email protected]

<>< As a computer I find your faith in technology amusing.

2002-09-16 01:10:07

by Alan Cox

[permalink] [raw]
Subject: Re: vesafb one pixel left?!

On Sun, 2002-09-15 at 22:20, Gerhard Mack wrote:
> I could be mistaken but I seem to recall that problem with DOS as well
> afik vesa tends to be a bit lossy due to some sort of design problem.

Shouldn't be but X at least can leave cards in a state vesa can't
handle. For one example X leaves my sis6326 in a state that takes a
power off to get vesa back working

2002-09-18 09:36:43

by Pavel Machek

[permalink] [raw]
Subject: Re: vesafb one pixel left?!

Hi!

> > On 2.5.34 I noticed that one pixel at the left was missing. I switched
> > consoles and problem went away. Weird.
>
> I have had pixel droppings and missing pixels with vesafb for as long as
> I remember (that is, years)

2.4.X works perfectly on same hardware.

Actually vesafb is in so bad state I often need to ^L in emacs because
of font corruption. One pixel left was merely first thing I saw.

Pavel
--
Philips Velo 1: 1"x4"x8", 300gram, 60, 12MB, 40bogomips, linux, mutt,
details at http://atrey.karlin.mff.cuni.cz/~pavel/velo/index.html.