2000-11-06 05:33:15

by Steffen Moser

[permalink] [raw]
Subject: "ip_dynaddr" broken in 2.4.0-test10

Hello,

I have configured, compiled and installed "linux-2.4.0-test10" on my
SuSE Linux 6.3 machine. After doing some necessary updates the system
works quite fine now. But there is one thing which makes still some
problems: "ip_dynaddr" seems not to work anymore.

I use an ISDN connection (dial on demand) to my ISP (that assigns me a
dynamic IP address when dialling up), so I should make use of
"ip_dynaddr" to prevent the first packet from being lost. Running
"linux-2.2.17" (or any other "2.2.X") this worked without any problems:
as soon as the connection is established the source address of the first
packet is shifted to the officially assigned address.

But this seems not to work with "linux-2.4.0-test10": I don't get
response to a packet which was sent before the connection was
established, i.e. if I try -for example- to establish an
"ssh"-connection to a machine when I am "off-line", my machine starts to
dial up, but the "ssh"-connection times out, so I have to interrupt
"ssh" and start it again after the ISDN connection is established,
because the first packet always gets lost.

The "ip_dynaddr" is activated:

[email protected]:~ > cat /proc/sys/net/ipv4/ip_dynaddr
1
[email protected]:~ >


Does anybody have the same problem? Is it a bug of "2.4.0-test10" or is
it the result of missing updates of userspace programmes?

Regards,
Steffen


2000-11-06 05:38:26

by David Miller

[permalink] [raw]
Subject: Re: "ip_dynaddr" broken in 2.4.0-test10


Does this fix it?

echo "1" >/proc/sys/net/ipv4/ip_nonlocal_bind

Later,
David S. Miller
[email protected]

2000-11-06 06:09:34

by Steffen Moser

[permalink] [raw]
Subject: Re: "ip_dynaddr" broken in 2.4.0-test10

Hello,

thank you for your fast answer!

"David S. Miller" wrote:

> Does this fix it?
>
> echo "1" >/proc/sys/net/ipv4/ip_nonlocal_bind

I tried this - but no success. The problem persists...

Bye,
Steffen

2000-11-06 18:59:11

by Henner Eisen

[permalink] [raw]
Subject: Re: "ip_dynaddr" broken in 2.4.0-test10


>>>>> "Steffen" == Steffen Moser <[email protected]> writes:

>> Does this fix it?
>>
>> echo "1" >/proc/sys/net/ipv4/ip_nonlocal_bind

Steffen> I tried this - but no success. The problem persists...

I just wrote a tool that does re-sending and address-rewriting
of the first packet from user space. If the bug is that ip_dynaddr fails
to re-send the first packet, the tool should work around this and thus
be a good diagnostic aid. (And BTW, it also works around other
`first packet lost' problems that are not handled by ip_dynaddr like
lost DNS lookup). See http://www.baty.hanse.de/ip_resend/ip_resend-0.3.tar.gz

Henner