2000-11-22 03:56:51

by Joseph Gooch

[permalink] [raw]
Subject: ECN causing problems

My RaptorNT 6.5 firewall rejects all connections from my linux box when ECN
is enabled. The error is attached. Perhaps this feature should be disabled
by default? Or is there already an option of the sort that i'm missing? I
only got the idea to disable it after a search of linux-kernel.

Plz cc me, I"m not on the list.

Later!
Joe Gooch

TCP packet dropped (10.204.186.7->x.x.x.x: Protocol=TCP[SYN 0xc0] Port
1255->2401): Bad TCP flags combination (received on interface 192.168.1.1)
(probable QueSO probe as flags=0xc2)


2000-11-22 04:16:58

by David Weinehall

[permalink] [raw]
Subject: Re: ECN causing problems

On Tue, Nov 21, 2000 at 10:26:24PM -0500, Joseph Gooch wrote:
> My RaptorNT 6.5 firewall rejects all connections from my linux box when ECN
> is enabled. The error is attached. Perhaps this feature should be disabled
> by default? Or is there already an option of the sort that i'm missing? I
> only got the idea to disable it after a search of linux-kernel.

I suggest you file a bugreport against RaptorNT, which evidently is
malfunctioning by detecting legit TCP-flags as something illegal.

> Plz cc me, I"m not on the list.
>
> Later!
> Joe Gooch
>
> TCP packet dropped (10.204.186.7->x.x.x.x: Protocol=TCP[SYN 0xc0] Port
> 1255->2401): Bad TCP flags combination (received on interface 192.168.1.1)
> (probable QueSO probe as flags=0xc2)


/David Weinehall
_ _
// David Weinehall <[email protected]> /> Northern lights wander \\
// Project MCA Linux hacker // Dance across the winter sky //
\> http://www.acc.umu.se/~tao/ </ Full colour fire </

2000-11-22 11:06:03

by Igmar Palsenberg

[permalink] [raw]
Subject: Re: ECN causing problems

On Tue, 21 Nov 2000, Joseph Gooch wrote:

> My RaptorNT 6.5 firewall rejects all connections from my linux box when ECN
> is enabled. The error is attached. Perhaps this feature should be disabled
> by default? Or is there already an option of the sort that i'm missing? I
> only got the idea to disable it after a search of linux-kernel.

The're is variable in /proc somewhere. Teh firewall should be fixed, what
Linux is doing is legal to the RFC. Cisco fixed most of their products
that misbehaved. Complain to the guys who moade RaptorNT :)

> Plz cc me, I"m not on the list.
>
> Later!
> Joe Gooch
>



Igmar

2000-11-22 12:31:07

by Alan Cox

[permalink] [raw]
Subject: Re: ECN causing problems

> My RaptorNT 6.5 firewall rejects all connections from my linux box when ECN
> is enabled. The error is attached. Perhaps this feature should be disabled
> by default? Or is there already an option of the sort that i'm missing? I
> only got the idea to disable it after a search of linux-kernel.

Your raptorNT 6.5 firewall is faulty, its as simple as that. Check if they have
an upgrade to fix their error.

Alan

2000-11-22 13:08:51

by James A Sutherland

[permalink] [raw]
Subject: Re: ECN causing problems

On Wed, 22 Nov 2000, Joseph Gooch wrote:
> My RaptorNT 6.5 firewall rejects all connections from my linux box when ECN
> is enabled. The error is attached. Perhaps this feature should be disabled
> by default? Or is there already an option of the sort that i'm missing? I
> only got the idea to disable it after a search of linux-kernel.

It's a faulty firewall. Have you checked for updates?

> Plz cc me, I"m not on the list.
>
> Later!
> Joe Gooch
>
> TCP packet dropped (10.204.186.7->x.x.x.x: Protocol=TCP[SYN 0xc0] Port
> 1255->2401): Bad TCP flags combination (received on interface 192.168.1.1)
> (probable QueSO probe as flags=0xc2)

ECN is NOT a "bad flags combination", RaptorNT is a bad firewall. Upgrade or
replace with something RFC compliant.


James.