2000-11-23 20:37:32

by Phil Stracchino

[permalink] [raw]
Subject: VMWare will not run on kernel 2.4.0-test11

I just compiled and installed kernel 2.4.0-test11. Upon rebooting,
vmware-2.0.3-786 refused to run. Running vmware-config.pl resulted in a
the following message:

"Your processor does not have a Time Stamp Counter. VMware will
not run on this system."

Since (1) my hardware has not changed, (2) this VMware release ran
perfectly on 2.4.0-test10, and (3) I changed nothing but the kernel in
between 2.4.0-test10 and 2.4.0-test11, I feel quite confident in believing
that I do indeed possess a Time Stamp Counter (whatever such a fabulous
beast may be), but for some reason VMware is unable to detect its presence
when running on kernel 2.4.0-test11. Evidently there has been some change
in the kernel which renders VMware unable to detect this mysterious - but
apparently crucial - feature.


I would appreciate any insights from either kernel folks or VMware folks
as to where this problem may lie, with an eventual aim of patching either
VMware or the kernel to allow VMware to run on this kernel.



--
Linux Now! ..........Because friends don't let friends use Microsoft.
phil stracchino -- the renaissance man -- mystic zen biker geek
Vr00m: 2000 Honda CBR929RR -- Cage: 2000 Dodge Intrepid R/T
Previous vr00mage: 1986 VF500F (sold), 1991 VFR750F3 (foully murdered)


2000-11-23 20:45:55

by Mohammad A. Haque

[permalink] [raw]
Subject: Re: VMWare will not run on kernel 2.4.0-test11

--- vmware-config.pl.old Thu Nov 23 15:12:32 2000
+++ vmware-config.pl Thu Nov 23 15:12:55 2000
@@ -1113,7 +1113,7 @@
if (direct_command(shell_string($gHelper{'grep'}) . ' ' . shell_string('^cpuid') . ' /proc/cpuinfo') eq '') {
error('Your ' . (($gSystem{'smp'} eq 'yes') ? 'processors do' : 'processor does') . ' not support the cpuid instruction. VMware will not run on this system.' . "\n\n");
}
- if (direct_command(shell_string($gHelper{'grep'}) . ' ' . shell_string('^flags.* tsc') . ' /proc/cpuinfo') eq '') {
+ if (direct_command(shell_string($gHelper{'grep'}) . ' ' . shell_string('^features.* tsc') . ' /proc/cpuinfo') eq '') {
error('Your ' . (($gSystem{'smp'} eq 'yes') ? 'processors do' : 'processor does') . ' not have a Time Stamp Counter. VMware will not run on this system.' . "\n\n");
}
}


Attachments:
vmware-config-2.4.0-test11.patch (829.00 B)

2000-11-23 20:47:45

by Phil Stracchino

[permalink] [raw]
Subject: Re: VMWare will not run on kernel 2.4.0-test11

On Thu, Nov 23, 2000 at 03:15:25PM -0500, Mohammad A. Haque wrote:
> Tiny patch for vmware-config.pl

Thanks, Mohammed! That was fast. :)




--
Linux Now! ..........Because friends don't let friends use Microsoft.
phil stracchino -- the renaissance man -- mystic zen biker geek
Vr00m: 2000 Honda CBR929RR -- Cage: 2000 Dodge Intrepid R/T
Previous vr00mage: 1986 VF500F (sold), 1991 VFR750F3 (foully murdered)

2000-11-23 20:49:55

by Jan Dvorak

[permalink] [raw]
Subject: Re: VMWare will not run on kernel 2.4.0-test11

On Thu, Nov 23, 2000 at 12:07:01PM -0800, Phil Stracchino wrote:
> I just compiled and installed kernel 2.4.0-test11. Upon rebooting,
> vmware-2.0.3-786 refused to run. Running vmware-config.pl resulted in a
> the following message:
>
> "Your processor does not have a Time Stamp Counter. VMware will
> not run on this system."
>
> Since (1) my hardware has not changed, (2) this VMware release ran
> perfectly on 2.4.0-test10, and (3) I changed nothing but the kernel in
> between 2.4.0-test10 and 2.4.0-test11, I feel quite confident in believing
> that I do indeed possess a Time Stamp Counter (whatever such a fabulous
> beast may be), but for some reason VMware is unable to detect its presence
> when running on kernel 2.4.0-test11. Evidently there has been some change
> in the kernel which renders VMware unable to detect this mysterious - but
> apparently crucial - feature.
>
>
> I would appreciate any insights from either kernel folks or VMware folks
> as to where this problem may lie, with an eventual aim of patching either
> VMware or the kernel to allow VMware to run on this kernel.
>

It's probably due to /proc/cpuinfo change - 'flags' has changed to 'features'.

Jan Dvorak <[email protected]>

2000-11-23 20:52:46

by Alan Cox

[permalink] [raw]
Subject: Re: VMWare will not run on kernel 2.4.0-test11

> vmware-2.0.3-786 refused to run. Running vmware-config.pl resulted in a
> the following message:

Run 2.4.0-test11-ac3

2000-11-23 22:00:44

by Petr Vandrovec

[permalink] [raw]
Subject: Re: VMWare will not run on kernel 2.4.0-test11

On 23 Nov 00 at 20:22, Alan Cox wrote:
> > vmware-2.0.3-786 refused to run. Running vmware-config.pl resulted in a
> > the following message:
>
> Run 2.4.0-test11-ac3

Hi Alan,
is change to field name temporary, and name will be reverted back
to flags, even although contents may differ between 2.2.x and 2.4.x,
or is there features to stay? Currently VMware does

"^\(features\|flags\).* tsc"

but question is - should we leave it here, or revert it back?

BTW, as I told couple of times here, if you have problem with VMware
on 2.3.x/2.4.x kernel, please first visit news server news.vmware.com
and look into vmware.for-linux.experimental newsgroup. If you'll not
find fix/workaround here (this one is there since Tigran pointed it to
me more than week ago - Nov 15, 02:59 CET), post question to that forum.
I watch that newsgroup almost continuously during my working hours (that
is aprox. 12:00-24:00 CET Mon-Fri).
Thanks,
Petr Vandrovec
[email protected]

2000-11-23 22:46:13

by Alan Cox

[permalink] [raw]
Subject: Re: VMWare will not run on kernel 2.4.0-test11

> is change to field name temporary, and name will be reverted back
> to flags, even although contents may differ between 2.2.x and 2.4.x,
> or is there features to stay? Currently VMware does
>
> "^\(features\|flags\).* tsc"
>
> but question is - should we leave it here, or revert it back?

I believe we should change it back. Until Linus makes a decision then I
dont think its final by any means.

features breaks stuff, flags seems not to

2000-11-24 23:22:03

by Andrew Park

[permalink] [raw]
Subject: changing BIOS setting

Hi,
Is there a way to change BIOS setting (like boot sequence)
from the kernel space? Any pointers would be appreciated.
Thanks

-A.

2000-11-24 23:29:51

by Jeff Garzik

[permalink] [raw]
Subject: Re: changing BIOS setting

Andrew Park wrote:
> Is there a way to change BIOS setting (like boot sequence)
> from the kernel space? Any pointers would be appreciated.

Yes. All the BIOS does is configure your hardware. Get docs on your
hardware, and you can do anything that BIOS does. For example, if your
parallel port is disabled in BIOS, and you have the datasheet for your
southbridge, then you can "manually" enable the parallel port by writing
certain values to certain PCI config registers.

That said, it is generally a bad idea to do this sort of thing. Unless
you have a cluster full of machines that all have a BIOS-related
problem, or similar, you should just reboot and adjust your BIOS...

Of course, if you are really motivated, you could just flash your own
BIOS. Check out http://www.acl.lanl.gov/linuxbios/

Regards,

Jeff


--
Jeff Garzik |
Building 1024 | The chief enemy of creativity is "good" sense
MandrakeSoft | -- Picasso

2000-11-26 12:35:29

by Chris Wedgwood

[permalink] [raw]
Subject: Re: changing BIOS setting

However , this won't change boot sequence at that is store in the
CMOS on your RTC chip... if you really wanted though; you could mess
with that via /dev/nvram or whatever it's called.

Not that I suggest this is a good idea, most likely you will corrupt
it and the BIOS will get a checksum error and reinitialize the nvram
to defaults.




--cw

On Fri, Nov 24, 2000 at 05:59:28PM -0500, Jeff Garzik wrote:

Andrew Park wrote:

> Is there a way to change BIOS setting (like boot sequence) from
> the kernel space? Any pointers would be appreciated.

Yes. All the BIOS does is configure your hardware. Get docs on
your hardware, and you can do anything that BIOS does. For
example, if your parallel port is disabled in BIOS, and you have
the datasheet for your southbridge, then you can "manually"
enable the parallel port by writing certain values to certain PCI
config registers.