2000-11-23 23:34:28

by Roland Orre

[permalink] [raw]
Subject: Can't mount SCSI CDROM in 2.4.*

Since I started running the 2.4.0-test kernels a couple of months ago
I'm not able to use my scsi cdrom and cdwriter.

Today I installed 2.4.0-test11, still the same problem.

bayes:/dev# ls -l /dev/scd0
brw-rw---- 1 root cdrom 11, 0 Oct 21 04:53 /dev/scd0

bayes:/dev# mount -t iso9660 /dev/scd0 /cdrom
mount: /dev/scd0 has wrong major or minor number

bayes:/dev# mount -V
mount: mount-2.10o

Each time I want to access the cdrom or cdwriter I have to reboot w 2.2.17
where it works fine.

I've even tried with creating a generic block device
bayes:/dev# ls -l /dev/scg0
brw-r--r-- 1 root root 21, 0 Nov 23 23:41 /dev/scg0

byes:/dev# mount -t iso9660 /dev/scg0 /cdrom
mount: /dev/scg0 has wrong major or minor number

Apart from this the 2.4.0-test kernels have been running very stable
for me. My systems are dual PII on ASUS PL97-DS and P2B-DS

According to Documentation/devices.txt nothing has changed according
major numbers for these devices from 2.2 to 2.4.

I'm grateful for any hint.

Best regards
Roland Orre