2000-11-28 00:06:30

by Lee Brown

[permalink] [raw]
Subject: 9750 vs. blade3D gives freaky ttyS3 problem)

Dear smart people on the kernel mailing list:

I have celeron 300 MHz box (overcl'ked to 450)
I am running 2.4 test11.
ISA PnP enabled.
I am using the fbconsole(VESA VGA).
I have a tried and true serial modem.

When I put in a Trident 975AGP the /dev/ttyS3 (modem) works fine. I can tell
this because the response to minicom is snappy and KPPP works(after I startx).

When I remove the 975 and install my new Trident Blade3D (9880) I have
different results. When I run minicom
1) The initialization box appears.
2) The box then disappears (as it supposed to)
3) I wait several seconds
4) The initial string _crawls_ across the screen and finally gives me OK

Why am I getting sluggish (to the point where I can't use the modem) response
with this second setup? the 975 and the Blade3D are very similar I imagine.
And what is the connection between a video card and the serial port?

If you need any more system info I'll be glad to give it.

(Please CC me as I am not on the List)
Thank You Ahead.
Lee Brown Jr.
[email protected]

2000-12-01 08:29:18

by Lee Brown

[permalink] [raw]
Subject: Re: 9750 vs. blade3D gives freaky ttyS3 problem)

> On Thu, 30 Nov 2000, [email protected] wrote:
> At a guess, it's an IRQ conflict. The Blade3D card may be trying to
> use the same interrupt as the serial port, and that's probably what's
> causing problems.

1) You nailed it. IRQ 3 was the culprit. Why I assumed my
box was PnP compatible I don't know (I guess I'm an optimist), but I will not
be fooled again.

2) Thanks for answering. You just made my good guy list ;-)

Lee Brown Jr.
[email protected]