2000-12-09 10:12:21

by David D.W. Downey

[permalink] [raw]
Subject: Network delays with NE2K-PCI

KERNEL VER: 2.4.0-test11
ADD. PATCHES: reiserfs patch
NETWORK CARD: NE2K-PCI Kingston KNE-111TX (P/N: 4460170-001.A00)
MOBO: MSI BX-Master with 20001013 BIOS update

PROBLEM: Network hangs on all initial outbound traffic.

I need to do a ping in order to get any type of connection. Network response
starts out in the high thousand ms then "connects" and drops to a normal 23
ms average. If I do NOT do this initial ping or several nslookups or some
sort of outbound traffic I can not connect to the net nor does the box
respond to inbound packets. But once I do that first set of pings everything
works fine.. until the next reboot and I end up having to do that first set
of pings again.

This problem does not happen under any of the 2.2.x series of kernels with
reiserfs patch and same NIC module and network config. All versions of
network daemons like named, postfix, sendmail sshd ect ect are the same. (I
purposely built the setups under 2.2 and 2.4 the same just to make sure it
wasn't a daemon issue.)

I've searched through the list archvies under SUBJECT and found nothing
related to this.

POSSIBILITY: Driver issue with the 2.4.0-test11 and the ne2k-pci module when
used with this particular network card? It acts almost like the card is
"sleeping". I thought it might possibly be the WAKE ON LAN option in the
BIOS but I turned off all APM options in BIOS, disabled the apmd daemon and
compiled the kernel without APM support.

I thought it might be the fact that it's a 32 bit bus mastering PCI adapter
but I've tried enabling and disabling bus mastering in the BIOS to what
extent it allows.

At this point I'm totally clueless where to look.

All my other machines running various versions of 2.4.0 (test6 through
test11) all use the NetGear FA-310TX and i don't get this problem. Only with
this brand of card. (Tried 3 different physical cards of the same model.)

Any ideas?

David D.W. Downey