2000-12-11 04:35:41

by Eddy

[permalink] [raw]
Subject: APM-Bios Hang at Boot-up 2.2.16 2.2.17 2.2.18pre26

I can't seem to get my A&T 486 to boot-up. If I disable APM from the above kernels my computer resets and re-boots automatically immediately following the kernel message "Ok booting the kernel"

With APM enabled in the kernel config the system boots and gets to the kernel message.
ne.c:v1.10 9/23/94 Donald Becker ([email protected])
NE*000 ethercard probe at 0x280: 00:40:05:3f:20:d6
eth0: NE2000 found at 0x280, using IRQ 9.
and then hangs.

Probing with magic-sysreq-P led me to APM-Code.

After turning on APM_DEBUG in arch/i386/kernel/apm.c I now get the continuous message
"apm: received normal resume notify"

How can I get around this. I've tried different APM-BIOS settings and different kernel configurations to no avail. I really don't understand what is really going on here to be able to fix it.

I have 66Mhz Intel-486-D2 with AMIBIOS Date 12/15/93
AMIBIOS 1993 release 07/08/1994
Rom Label = AI.8-1 AB7130565

2000-12-11 09:22:19

by Eddy

[permalink] [raw]
Subject: Re: APM-Bios Hang at Boot-up 2.2.16 2.2.17 2.2.18pre26

Right Thanks. I did not realize I was not in text mode.

I have somehow fixed the problem by doing something to the apm-bios
settings. I disabled a bunch of stuff in the bios and the thing is working
apparently ok now. Don't ask me what cause I really don't know. It's just
working now.

Thanks, anyway.

This message should not now be in html format... I hope.

----- Original Message -----
From: "David Feuer" <[email protected]>
To: "Eddy" <[email protected]>
Sent: Sunday, December 10, 2000 8:55 PM
Subject: Re: APM-Bios Hang at Boot-up 2.2.16 2.2.17 2.2.18pre26

> Note for next time: don't post HTML mail messages to linux-kernel. This
> annoys many people.
> --
> This message has been brought to you by the letter alpha and the number
> Open Source: Think locally; act globally.
> David Feuer
> [email protected]