2008-01-28 15:35:17

by Kevin Coffman

[permalink] [raw]
Subject: Re: [NFS] nfs2/3 ESTALE bug on mount point (v2.6.24-rc8)

On Jan 27, 2008 11:37 PM, Erez Zadok <[email protected]> wrote:
> I tried to bisect nfs-utils but it didn't work. First, the latest version
> of nfs-utils didn't configure for me. It complained
> Unable to locate information required to use librpcsecgss. If you
> have pkgconfig installed, you might try setting environment variable
> PKG_CONFIG_PATH to /usr/local/lib/pkgconfig
> The above appears to be an error if you don't have librpcsecgss API >=
> 0.10. But mine, on FC7. is 0.11. (I'm using a vanilla FC7.)

Argh. The dependencies changed recently because libgssapi was renamed
to libgssglue to avoid a conflict with other libraries with the same
name. librpcsecgss has a dependency on libgssapi/libgssglue.

> So I ran configure --disable-gss and was finally able to build the utils.
> But then, I was having mount.nfs hanging often; stracing it revealed that
> mount(2) was getting EACESS as if the dir wasn't exported (but exportfs said
> it was). I don't know if disabling gss at configure time could have
> resulted in these hangs.

I see you aren't using Kerberos mounts, so gssd shouldn't be involved or needed.

> I continued and tried a few more intermediate versions in the bisection, and
> several of them failed to compile and/or configure and/or autogen.sh.

Yes, there were other dependency changes that might cause problems. I
know of at least one other problem that causes git bisect to fail.

I'm sorry for my part in the git bisection problem.

Short of narrowing it down to a particular commit, perhaps you can
narrow it down to a released version of nfs-utils? (Assuming it might
be nfs-utils related.)