2008-02-07 21:36:44

by Pascal A. Dupuis

[permalink] [raw]
Subject: [NFS] troubles with nohide -- crossmnt

Hello,

I'd like to export two filesystems, mounted on one another. The setup is :

some partition mounted as /home/user (parent)
another one as /home/user/archive (child)

The export file contains:
/home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
/home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)

I tried:
-setting the 'nohide' option on the child
-setting the crossmnt on the parent
-permuting the order

Whatever case I try, on the client I ALWAYS see the child directory,
and not the parent. Any clue ?

Both systems are linux-2.6.24, debian SID, nfs-kernel-package for the
server, nfsv4 compiled as a module.

TIA

Pascal Dupuis

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs



2008-02-07 21:41:47

by Jeff Layton

[permalink] [raw]
Subject: Re: [NFS] troubles with nohide -- crossmnt

On Thu, 7 Feb 2008 22:36:05 +0100
"Pascal A. Dupuis" <[email protected]> wrote:

> Hello,
>
> I'd like to export two filesystems, mounted on one another. The setup is :
>
> some partition mounted as /home/user (parent)
> another one as /home/user/archive (child)
>
> The export file contains:
> /home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
> /home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)
>

You shouldn't have 2 exports with the same fsid= option. They
should be different. I'd suggest giving /home/user fsid=0
and /home/user/archive fsid=1 (or something else).

> I tried:
> -setting the 'nohide' option on the child
> -setting the crossmnt on the parent
> -permuting the order
>
> Whatever case I try, on the client I ALWAYS see the child directory,
> and not the parent. Any clue ?
>
> Both systems are linux-2.6.24, debian SID, nfs-kernel-package for the
> server, nfsv4 compiled as a module.
>
> TIA
>
> Pascal Dupuis
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2008.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> NFS maillist - [email protected]
> https://lists.sourceforge.net/lists/listinfo/nfs
> _______________________________________________
> Please note that [email protected] is being discontinued.
> Please subscribe to [email protected] instead.
> http://vger.kernel.org/vger-lists.html#linux-nfs
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-nfs" in
> the body of a message to [email protected]
> More majordomo info at http://vger.kernel.org/majordomo-info.html
>


--
Jeff Layton <[email protected]>

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs


2008-02-07 21:53:23

by Pascal A. Dupuis

[permalink] [raw]
Subject: Re: [NFS] troubles with nohide -- crossmnt

On Thu, Feb 07, 2008 at 04:41:10PM -0500, Jeff Layton wrote:

> > /home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
> > /home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)
> >
>
> You shouldn't have 2 exports with the same fsid= option. They
> should be different. I'd suggest giving /home/user fsid=0
> and /home/user/archive fsid=1 (or something else).
>

OK. It made the trick. I didn't notice that both exported FS had the
same fsid. Thanks. Maybe this should be included in the FAQS ?

Regards

Pascal Dupuis

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs


2008-02-07 22:40:40

by Steve Dickson

[permalink] [raw]
Subject: Re: [NFS] troubles with nohide -- crossmnt



Pascal A. Dupuis wrote:
> On Thu, Feb 07, 2008 at 04:41:10PM -0500, Jeff Layton wrote:
>
>>> /home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
>>> /home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)
>>>
>> You shouldn't have 2 exports with the same fsid= option. They
>> should be different. I'd suggest giving /home/user fsid=0
>> and /home/user/archive fsid=1 (or something else).
>>
>
> OK. It made the trick. I didn't notice that both exported FS had the
> same fsid. Thanks. Maybe this should be included in the FAQS ?
We are working on changing things so the fsid=0 is not needed...

steved.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs


2008-02-07 22:54:12

by [email protected]

[permalink] [raw]
Subject: Re: [NFS] troubles with nohide -- crossmnt

On Thu, Feb 07, 2008 at 05:38:20PM -0500, Steve Dickson wrote:
>
>
> Pascal A. Dupuis wrote:
> > On Thu, Feb 07, 2008 at 04:41:10PM -0500, Jeff Layton wrote:
> >
> >>> /home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
> >>> /home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)
> >>>
> >> You shouldn't have 2 exports with the same fsid= option. They
> >> should be different. I'd suggest giving /home/user fsid=0
> >> and /home/user/archive fsid=1 (or something else).
> >>
> >
> > OK. It made the trick. I didn't notice that both exported FS had the
> > same fsid. Thanks. Maybe this should be included in the FAQS ?
> We are working on changing things so the fsid=0 is not needed...

More helpful than a FAQ entry might just be a warning from exportfs or
mountd or whatever--it shouldn't be hard to check for the above.

I've added this to the list at:

http://wiki.linux-nfs.org/wiki/index.php/To_do

--b.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs


2008-02-07 23:14:29

by Trond Myklebust

[permalink] [raw]
Subject: Re: [NFS] troubles with nohide -- crossmnt


On Thu, 2008-02-07 at 17:52 -0500, J. Bruce Fields wrote:
> On Thu, Feb 07, 2008 at 05:38:20PM -0500, Steve Dickson wrote:
> >
> >
> > Pascal A. Dupuis wrote:
> > > On Thu, Feb 07, 2008 at 04:41:10PM -0500, Jeff Layton wrote:
> > >
> > >>> /home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
> > >>> /home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)
> > >>>
> > >> You shouldn't have 2 exports with the same fsid= option. They
> > >> should be different. I'd suggest giving /home/user fsid=0
> > >> and /home/user/archive fsid=1 (or something else).
> > >>
> > >
> > > OK. It made the trick. I didn't notice that both exported FS had the
> > > same fsid. Thanks. Maybe this should be included in the FAQS ?
> > We are working on changing things so the fsid=0 is not needed...
>
> More helpful than a FAQ entry might just be a warning from exportfs or
> mountd or whatever--it shouldn't be hard to check for the above.
>
> I've added this to the list at:
>
> http://wiki.linux-nfs.org/wiki/index.php/To_do

It might not be a bad idea to also warn if we detect that the user
changes the fsid mapping in /etc/exports. If there are active clients at
the time of the modification, then that will cause trouble for them.

Cheers
Trond


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs


2008-02-07 23:20:49

by [email protected]

[permalink] [raw]
Subject: Re: [NFS] troubles with nohide -- crossmnt

On Thu, Feb 07, 2008 at 06:13:28PM -0500, Trond Myklebust wrote:
>
> On Thu, 2008-02-07 at 17:52 -0500, J. Bruce Fields wrote:
> > On Thu, Feb 07, 2008 at 05:38:20PM -0500, Steve Dickson wrote:
> > >
> > >
> > > Pascal A. Dupuis wrote:
> > > > On Thu, Feb 07, 2008 at 04:41:10PM -0500, Jeff Layton wrote:
> > > >
> > > >>> /home/user/archive 192.168.1.10(rw,subtree_check,fsid=0)
> > > >>> /home/user 192.168.1.10(rw,subtree_check,fsid=0,crossmnt)
> > > >>>
> > > >> You shouldn't have 2 exports with the same fsid= option. They
> > > >> should be different. I'd suggest giving /home/user fsid=0
> > > >> and /home/user/archive fsid=1 (or something else).
> > > >>
> > > >
> > > > OK. It made the trick. I didn't notice that both exported FS had the
> > > > same fsid. Thanks. Maybe this should be included in the FAQS ?
> > > We are working on changing things so the fsid=0 is not needed...
> >
> > More helpful than a FAQ entry might just be a warning from exportfs or
> > mountd or whatever--it shouldn't be hard to check for the above.
> >
> > I've added this to the list at:
> >
> > http://wiki.linux-nfs.org/wiki/index.php/To_do
>
> It might not be a bad idea to also warn if we detect that the user
> changes the fsid mapping in /etc/exports. If there are active clients at
> the time of the modification, then that will cause trouble for them.

Sure. I've added that too.

(Lots of easy stuff on that list! Help yourselves! OK, probably some
dumb or out-of-date stuff there too--may want to ask first.)

--b.

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
NFS maillist - [email protected]
https://lists.sourceforge.net/lists/listinfo/nfs
_______________________________________________
Please note that [email protected] is being discontinued.
Please subscribe to [email protected] instead.
http://vger.kernel.org/vger-lists.html#linux-nfs