2008-07-28 18:48:38

by Gary Hawco

[permalink] [raw]
Subject: Unable to disable barriers

Subject pretty much says it all.

For testing purposes I tried to disable barriers in fstab (barriers=0). On
reboot the filesystem will not mount read/write until barriers are reenabled.

This occurs whether I use ordered data mode or data writeback mode, in both
Gentoo and Slackware 12.1

Is this behavior by design (that barriers can not be disabled)?

Thanks,
Gary



2008-07-30 16:37:50

by Eric Sandeen

[permalink] [raw]
Subject: Re: Unable to disable barriers

Gary Hawco wrote:
> Subject pretty much says it all.
>
> For testing purposes I tried to disable barriers in fstab (barriers=0). On
> reboot the filesystem will not mount read/write until barriers are reenabled.

What errors do you get?

> This occurs whether I use ordered data mode or data writeback mode, in both
> Gentoo and Slackware 12.1
>
> Is this behavior by design (that barriers can not be disabled)?
>
> Thanks,
> Gary

Hm, it's not supposed to be :)

Perhaps you just spelled it wrong:

[email protected] ~]# mount -o barriers=0 /dev/sdb2 /mnt/test
mount: wrong fs type, bad option, bad superblock on /dev/sdb2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

[[email protected] ~]# mount -o barrier=0 /dev/sdb2 /mnt/test
[[email protected] ~]#

-Eric