2013-02-11 13:53:21

by Wojciech Dubowik

[permalink] [raw]
Subject: [BUG] Beacon loss event every second

Hello,

On latest testing and mac80211-next I am getting beacon loss event
every second even when connection is perfect.

Feb 11 14:49:52 wlanTS kernel: [14148.599482] wlan0: cancelling probereq
poll due to a received beacon
Feb 11 14:49:53 wlanTS kernel: [14149.565491] wlan0: detected beacon
loss from AP - sending probe request
Feb 11 14:49:53 wlanTS kernel: [14149.578845] wlan0: cancelling probereq
poll due to a received beacon
Feb 11 14:49:54 wlanTS kernel: [14150.561985] wlan0: detected beacon
loss from AP - sending probe request
Feb 11 14:49:54 wlanTS kernel: [14150.588223] wlan0: cancelling probereq
poll due to a received beacon
Feb 11 14:49:56 wlanTS kernel: [14152.554968] wlan0: detected beacon
loss from AP - sending probe request
Feb 11 14:49:56 wlanTS kernel: [14152.578055] wlan0: cancelling probereq
poll due to a received beacon
Feb 11 14:49:57 wlanTS kernel: [14153.551461] wlan0: detected beacon
loss from AP - sending probe request
Feb 11 14:49:57 wlanTS kernel: [14153.556825] wlan0: cancelling probereq
poll due to a received beacon
Feb 11 14:49:58 wlanTS kernel: [14154.595765] wlan0: detected beacon
loss from AP - sending probe request
Feb 11 14:49:58 wlanTS kernel: [14154.597777] wlan0: cancelling probereq
poll due to a received beacon

and so on...

Has somebody already fixed it? Just asking before I start digging in.

Br,
Wojtek



2013-02-12 10:52:07

by Wojciech Dubowik

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

On 02/12/2013 11:24 AM, Wojciech Dubowik wrote:
> On 02/12/2013 11:23 AM, Kalle Valo wrote:
>> Wojciech Dubowik <[email protected]> writes:
>>
>>> I have a test pc with 3x AR9590 and 2x AR9390. Machine is based on i7
>>> and hyperthreading is on so I have 8 cores.
>>> I am using latest wireless testing ath9k and 3.8rc7 kernel.
>>>
>>> What I see is that for some extended periods odf time beacons are not
>>> processed in ieee80211_rx_mgmt_beacon
>>> and that's why I get beacon loss. I am using 30ms beacon period.
>>>
>>>
>>> What is really funny, that I get this beacon loss message every
>>> second. Like is sth was locking ifmgd->mtx mutex
>>> at constant intervals.
>>>
>>>
>>> I will try to disable all cores and run in again to see if it's rcu
>>> problem.
>> You could also try wireless-next or wireless-testing to pinpoint if the
>> problem is in wireless code or not.
>>
> I see it on wireless-testing and mac80211-next. I will try with other
> driver later today.
>
> I can see also other problem like authentication frame always timing
> out the first time
> but I will handle it later.
It has turned out that I had bad irq, switch to polling problem. Without
interrupts for wireless
cards I will for sure see such problems.

Sorry for spamming.

Wojtek
> --
> To unsubscribe from this list: send the line "unsubscribe
> linux-wireless" in
> the body of a message to [email protected]
> More majordomo info at http://vger.kernel.org/majordomo-info.html


2013-02-12 10:19:15

by Wojciech Dubowik

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

On 02/12/2013 11:04 AM, Kalle Valo wrote:
> Wojciech Dubowik <[email protected]> writes:
>
>> I have connection without sending any data.
>>
>> I have seen that ieee80211_sta_rx_notify doesn't count beacons
>> so the time is not resetted. What was the reason not to count them
>> for beacon loss work? Something connected with PS?
>>
>> Anyway I should get the event every
>>
>> IEEE80211_BEACON_LOSS_COUNT * bcn period
>>
>> which in my case should be 7 * 30 ms = 210 ms and not 1 second.
>>
>> I will keep on digging.
> What driver are you using?
>
I have a test pc with 3x AR9590 and 2x AR9390. Machine is based on i7
and hyperthreading is on so I have 8 cores.
I am using latest wireless testing ath9k and 3.8rc7 kernel.

What I see is that for some extended periods odf time beacons are not
processed in ieee80211_rx_mgmt_beacon
and that's why I get beacon loss. I am using 30ms beacon period.


What is really funny, that I get this beacon loss message every second.
Like is sth was locking ifmgd->mtx mutex
at constant intervals.


I will try to disable all cores and run in again to see if it's rcu problem.

Wojtek

2013-02-12 10:04:57

by Kalle Valo

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

Wojciech Dubowik <[email protected]> writes:

> I have connection without sending any data.
>
> I have seen that ieee80211_sta_rx_notify doesn't count beacons
> so the time is not resetted. What was the reason not to count them
> for beacon loss work? Something connected with PS?
>
> Anyway I should get the event every
>
> IEEE80211_BEACON_LOSS_COUNT * bcn period
>
> which in my case should be 7 * 30 ms = 210 ms and not 1 second.
>
> I will keep on digging.

What driver are you using?

--
Kalle Valo

2013-02-11 14:27:45

by Johannes Berg

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

On Mon, 2013-02-11 at 14:47 +0100, Wojciech Dubowik wrote:
> Hello,
>
> On latest testing and mac80211-next I am getting beacon loss event
> every second even when connection is perfect.
>
> Feb 11 14:49:52 wlanTS kernel: [14148.599482] wlan0: cancelling probereq
> poll due to a received beacon

> Has somebody already fixed it? Just asking before I start digging in.

I'm not aware of that.

johannes


2013-02-13 12:50:36

by Wojciech Dubowik

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

On 02/12/2013 11:46 AM, Wojciech Dubowik wrote:
> On 02/12/2013 11:24 AM, Wojciech Dubowik wrote:
>> On 02/12/2013 11:23 AM, Kalle Valo wrote:
>>> Wojciech Dubowik <Wojciech.Dubo[email protected]> writes:
>>>
>>>> I have a test pc with 3x AR9590 and 2x AR9390. Machine is based on i7
>>>> and hyperthreading is on so I have 8 cores.
>>>> I am using latest wireless testing ath9k and 3.8rc7 kernel.
>>>>
>>>> What I see is that for some extended periods odf time beacons are not
>>>> processed in ieee80211_rx_mgmt_beacon
>>>> and that's why I get beacon loss. I am using 30ms beacon period.
>>>>
>>>>
>>>> What is really funny, that I get this beacon loss message every
>>>> second. Like is sth was locking ifmgd->mtx mutex
>>>> at constant intervals.
>>>>
>>>>
>>>> I will try to disable all cores and run in again to see if it's rcu
>>>> problem.
>>> You could also try wireless-next or wireless-testing to pinpoint if the
>>> problem is in wireless code or not.
>>>
>> I see it on wireless-testing and mac80211-next. I will try with other
>> driver later today.
>>
>> I can see also other problem like authentication frame always timing
>> out the first time
>> but I will handle it later.
> It has turned out that I had bad irq, switch to polling problem.
> Without interrupts for wireless
> cards I will for sure see such problems.
After solving the bad irq problems I can still see the issue.

It has turned out that when I set beacon interval to less than 40ms I
get beacon loss events.

My setup is ath9k AP and ath9k STA on the same pc connected with rf
cable and 40dB attenuator.

I have seen this problem also with earlier versions of wireless testing
and next.

Wojtek
>
> Sorry for spamming.
>
> Wojtek
>> --
>> To unsubscribe from this list: send the line "unsubscribe
>> linux-wireless" in
>> the body of a message to [email protected]
>> More majordomo info at http://vger.kernel.org/majordomo-info.html
>
> --
> To unsubscribe from this list: send the line "unsubscribe
> linux-wireless" in
> the body of a message to [email protected]
> More majordomo info at http://vger.kernel.org/majordomo-info.html


2013-02-12 10:23:48

by Kalle Valo

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

Wojciech Dubowik <[email protected]> writes:

> I have a test pc with 3x AR9590 and 2x AR9390. Machine is based on i7
> and hyperthreading is on so I have 8 cores.
> I am using latest wireless testing ath9k and 3.8rc7 kernel.
>
> What I see is that for some extended periods odf time beacons are not
> processed in ieee80211_rx_mgmt_beacon
> and that's why I get beacon loss. I am using 30ms beacon period.
>
>
> What is really funny, that I get this beacon loss message every
> second. Like is sth was locking ifmgd->mtx mutex
> at constant intervals.
>
>
> I will try to disable all cores and run in again to see if it's rcu problem.

You could also try wireless-next or wireless-testing to pinpoint if the
problem is in wireless code or not.

--
Kalle Valo

2013-02-11 14:47:43

by Wojciech Dubowik

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

On 02/11/2013 03:27 PM, Johannes Berg wrote:
> On Mon, 2013-02-11 at 14:47 +0100, Wojciech Dubowik wrote:
>> Hello,
>>
>> On latest testing and mac80211-next I am getting beacon loss event
>> every second even when connection is perfect.
>>
>> Feb 11 14:49:52 wlanTS kernel: [14148.599482] wlan0: cancelling probereq
>> poll due to a received beacon
>> Has somebody already fixed it? Just asking before I start digging in.
> I'm not aware of that.
I have connection without sending any data.

I have seen that ieee80211_sta_rx_notify doesn't count beacons
so the time is not resetted. What was the reason not to count them
for beacon loss work? Something connected with PS?

Anyway I should get the event every

IEEE80211_BEACON_LOSS_COUNT * bcn period

which in my case should be 7 * 30 ms = 210 ms and not 1 second.

I will keep on digging.

Wojtek
>
> johannes
>


2013-02-12 10:30:14

by Wojciech Dubowik

[permalink] [raw]
Subject: Re: [BUG] Beacon loss event every second

On 02/12/2013 11:23 AM, Kalle Valo wrote:
> Wojciech Dubowik <[email protected]> writes:
>
>> I have a test pc with 3x AR9590 and 2x AR9390. Machine is based on i7
>> and hyperthreading is on so I have 8 cores.
>> I am using latest wireless testing ath9k and 3.8rc7 kernel.
>>
>> What I see is that for some extended periods odf time beacons are not
>> processed in ieee80211_rx_mgmt_beacon
>> and that's why I get beacon loss. I am using 30ms beacon period.
>>
>>
>> What is really funny, that I get this beacon loss message every
>> second. Like is sth was locking ifmgd->mtx mutex
>> at constant intervals.
>>
>>
>> I will try to disable all cores and run in again to see if it's rcu problem.
> You could also try wireless-next or wireless-testing to pinpoint if the
> problem is in wireless code or not.
>
I see it on wireless-testing and mac80211-next. I will try with other
driver later today.

I can see also other problem like authentication frame always timing out
the first time
but I will handle it later.