2013-03-08 21:02:33

by Larry Finger

[permalink] [raw]
Subject: Re: PROBLEM: linux kernel 3.9 rc1 and rtl8187 wireless, unable to connect to any available hotspots.

On 03/08/2013 01:51 PM, Jenya Y wrote:
>
> I just recompiled the kernel with CONFIG_USB_DEBUG flag and here is the output
> of the same commands you provided me with earlier + output of dmesg (though it's
> might be superfluous)

No, it was not. At the end were the lines

[ 19.322729] rtl8187: wireless switch is on
[ 19.322763] usbcore: registered new interface driver rtl8187
[ 19.423269] systemd-udevd[272]: renamed network interface wlan0 to wlp0s29f7u7u3
[ 21.321746] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u7u3: link is not ready

Why are your udev rules renaming wlan0 to that crazy string?

Your ESSID for the AP of "1.618029" is also strange, but that works OK here.

Note that I added the ML to this reply.

Larry



2013-03-08 21:23:09

by Jenya Y

[permalink] [raw]
Subject: Re: PROBLEM: linux kernel 3.9 rc1 and rtl8187 wireless, unable to connect to any available hotspots.

On 03/08/2013 10:02 PM, Larry Finger wrote:
> No, it was not. At the end were the lines
>
> [ 19.322729] rtl8187: wireless switch is on
> [ 19.322763] usbcore: registered new interface driver rtl8187
> [ 19.423269] systemd-udevd[272]: renamed network interface wlan0 to
> wlp0s29f7u7u3
> [ 21.321746] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u7u3: link is not
> ready
>
> Why are your udev rules renaming wlan0 to that crazy string?
>
> Your ESSID for the AP of "1.618029" is also strange, but that works OK
> here.
>
> Note that I added the ML to this reply.
>
> Larry
>

The ID didn't cause any issues before, neither did the strange names
(courtesy of systemd 197) and they are indeed very strange but as you
have already seen the same setup is working in 3.8.2

Here are relevant dmesg output in 3.8.2 //

[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.8.2-1-jy ([email protected]) (gcc version 4.7.2 (GCC)
) #1 SMP PREEMPT Thu Mar 7 23:37:49 CET 2013
....
[ 17.868726] cfg80211: Calling CRDA to update world regulatory domain
[ 17.991571] cfg80211: World regulatory domain updated:
[ 17.991574] cfg80211: (start_freq - end_freq @ bandwidth),
(max_antenna_gain, max_eirp)
[ 17.991576] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300
mBi, 2000 mBm)
[ 17.991578] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300
mBi, 2000 mBm)
[ 17.991580] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300
mBi, 2000 mBm)
[ 17.991582] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300
mBi, 2000 mBm)
[ 17.991583] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300
mBi, 2000 mBm)
[ 18.393371] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 18.393650] ieee80211 phy0: hwaddr 00:15:af:03:b1:88, RTL8187vB
(default) V1 + rtl8225z2, rfkill mask 2
[ 18.404459] rtl8187: Customer ID is 0x00
[ 18.404944] rtl8187: wireless switch is on
[ 18.404970] usbcore: registered new interface driver rtl8187
[ 18.518265] systemd-udevd[326]: renamed network interface wlan0 to
wlp0s29f7u7u3
[ 20.419743] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u7u3: link is not ready
[ 30.480518] wlp0s29f7u7u3: authenticate with 00:13:49:df:22:72
[ 30.515723] wlp0s29f7u7u3: capabilities/regulatory prevented using AP
HT/VHT configuration, downgraded
[ 30.552709] wlp0s29f7u7u3: send auth to 00:13:49:df:22:72 (try 1/3)
[ 30.554577] wlp0s29f7u7u3: authenticated
[ 30.554666] rtl8187 5-7.3:1.0 wlp0s29f7u7u3: disabling HT as WMM/QoS
is not supported by the AP
[ 30.554669] rtl8187 5-7.3:1.0 wlp0s29f7u7u3: disabling VHT as WMM/QoS
is not supported by the AP
[ 30.555028] wlp0s29f7u7u3: associate with 00:13:49:df:22:72 (try 1/3)
[ 30.557461] wlp0s29f7u7u3: RX AssocResp from 00:13:49:df:22:72
(capab=0x411 status=0 aid=1)
[ 30.558206] wlp0s29f7u7u3: associated
[ 30.558237] IPv6: ADDRCONF(NETDEV_CHANGE): wlp0s29f7u7u3: link
becomes ready


so is there maybe a quick fix?

I have another idea, I should try out. Maybe I should try to disable
IPv6 in my network settings.


2013-03-09 01:35:52

by Larry Finger

[permalink] [raw]
Subject: Re: PROBLEM: linux kernel 3.9 rc1 and rtl8187 wireless, unable to connect to any available hotspots.

On 03/08/2013 03:23 PM, Jenya Y wrote:
> On 03/08/2013 10:02 PM, Larry Finger wrote:
>> No, it was not. At the end were the lines
>>
>> [ 19.322729] rtl8187: wireless switch is on
>> [ 19.322763] usbcore: registered new interface driver rtl8187
>> [ 19.423269] systemd-udevd[272]: renamed network interface wlan0 to
>> wlp0s29f7u7u3
>> [ 21.321746] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u7u3: link is not ready
>>
>> Why are your udev rules renaming wlan0 to that crazy string?
>>
>> Your ESSID for the AP of "1.618029" is also strange, but that works OK here.
>>
>> Note that I added the ML to this reply.
>>
>> Larry
>>
>
> The ID didn't cause any issues before, neither did the strange names (courtesy
> of systemd 197) and they are indeed very strange but as you have already seen
> the same setup is working in 3.8.2
>
> Here are relevant dmesg output in 3.8.2 //
>
> [ 0.000000] Initializing cgroup subsys cpuset
> [ 0.000000] Initializing cgroup subsys cpu
> [ 0.000000] Linux version 3.8.2-1-jy ([email protected]) (gcc version 4.7.2 (GCC) ) #1
> SMP PREEMPT Thu Mar 7 23:37:49 CET 2013
> ....
> [ 17.868726] cfg80211: Calling CRDA to update world regulatory domain
> [ 17.991571] cfg80211: World regulatory domain updated:
> [ 17.991574] cfg80211: (start_freq - end_freq @ bandwidth),
> (max_antenna_gain, max_eirp)
> [ 17.991576] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi,
> 2000 mBm)
> [ 17.991578] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi,
> 2000 mBm)
> [ 17.991580] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi,
> 2000 mBm)
> [ 17.991582] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi,
> 2000 mBm)
> [ 17.991583] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi,
> 2000 mBm)
> [ 18.393371] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
> [ 18.393650] ieee80211 phy0: hwaddr 00:15:af:03:b1:88, RTL8187vB (default) V1
> + rtl8225z2, rfkill mask 2
> [ 18.404459] rtl8187: Customer ID is 0x00
> [ 18.404944] rtl8187: wireless switch is on
> [ 18.404970] usbcore: registered new interface driver rtl8187
> [ 18.518265] systemd-udevd[326]: renamed network interface wlan0 to wlp0s29f7u7u3
> [ 20.419743] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u7u3: link is not ready
> [ 30.480518] wlp0s29f7u7u3: authenticate with 00:13:49:df:22:72
> [ 30.515723] wlp0s29f7u7u3: capabilities/regulatory prevented using AP HT/VHT
> configuration, downgraded
> [ 30.552709] wlp0s29f7u7u3: send auth to 00:13:49:df:22:72 (try 1/3)
> [ 30.554577] wlp0s29f7u7u3: authenticated
> [ 30.554666] rtl8187 5-7.3:1.0 wlp0s29f7u7u3: disabling HT as WMM/QoS is not
> supported by the AP
> [ 30.554669] rtl8187 5-7.3:1.0 wlp0s29f7u7u3: disabling VHT as WMM/QoS is not
> supported by the AP
> [ 30.555028] wlp0s29f7u7u3: associate with 00:13:49:df:22:72 (try 1/3)
> [ 30.557461] wlp0s29f7u7u3: RX AssocResp from 00:13:49:df:22:72 (capab=0x411
> status=0 aid=1)
> [ 30.558206] wlp0s29f7u7u3: associated
> [ 30.558237] IPv6: ADDRCONF(NETDEV_CHANGE): wlp0s29f7u7u3: link becomes ready
>
>
> so is there maybe a quick fix?
>
> I have another idea, I should try out. Maybe I should try to disable IPv6 in my
> network settings.

I see that had no effect. You need to bisect between HEAD and v3.8.

Larry



2013-03-09 02:11:04

by Jenya Y

[permalink] [raw]
Subject: Re: PROBLEM: linux kernel 3.9 rc1 and rtl8187 wireless, unable to connect to any available hotspots.


> I see that had no effect. You need to bisect between HEAD and v3.8.
>
> Larry

Larry, I'm very happy to report that after recompiling the kernel from
git master just a few minutes ago all is working again! Thank you very
much for your patience with my ignorance. (and all kudos to you, friend,
comrade, sister or brother....whoever you are on other end of the wire
who managed to fix this :)

So I'm off bothering Mighty Alan again until the other problem with my
usb hub in the display is solved :) Have to brace myself for another
round of awkward comments, I guess.

Thank you again! I will familiar with bisecting soon enough.

// Jenya



[ 0.000000] Linux version 3.9.0-1-jy-alpha ([email protected]) (gcc version 4.7.2
(GCC) ) #1 SMP PREEMPT Sat Mar 9 02:33:53 CET 2013
.....
[ 18.412863] ieee80211 phy0: hwaddr 00:15:af:03:b1:88, RTL8187vB
(default) V1 + rtl8225z2, rfkill mask 2
[ 18.423761] rtl8187: Customer ID is 0x00
[ 18.424413] rtl8187: wireless switch is on
[ 18.424799] usbcore: registered new interface driver rtl8187
[ 18.466185] systemd-udevd[294]: renamed network interface wlan0 to
wlp0s29f7u7u3
[ 20.361794] IPv6: ADDRCONF(NETDEV_UP): wlp0s29f7u7u3: link is not ready
[ 23.724490] wlp0s29f7u7u3: authenticate with 00:13:49:df:22:72
[ 23.868638] wlp0s29f7u7u3: send auth to 00:13:49:df:22:72 (try 1/3)
[ 23.871268] wlp0s29f7u7u3: authenticated
[ 23.871402] rtl8187 5-7.3:1.0 wlp0s29f7u7u3: disabling HT as WMM/QoS
is not supported by the AP
[ 23.871407] rtl8187 5-7.3:1.0 wlp0s29f7u7u3: disabling VHT as WMM/QoS
is not supported by the AP
[ 23.872038] wlp0s29f7u7u3: associate with 00:13:49:df:22:72 (try 1/3)
[ 23.874879] wlp0s29f7u7u3: RX AssocResp from 00:13:49:df:22:72
(capab=0x411 status=0 aid=1)
[ 23.875634] wlp0s29f7u7u3: associated
[ 23.875662] IPv6: ADDRCONF(NETDEV_CHANGE): wlp0s29f7u7u3: link
becomes ready