2021-05-09 19:39:36

by rtl8821cerfe2

[permalink] [raw]
Subject: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

Hi!

My system freezes if I use this driver. My laptop's wifi card is RTL8821CE, type RFE 2. My laptop is HP 250 G7, model 6MQ29EA.

It happens within a few minutes after booting if I don't do anything out of the ordinary. If I do a speed test at speedtest.net, the system usually freezes during the test. I have to hold the power button to shut it down.

This happens with the 5.12/5.12.1 kernel provided by Arch Linux, but it also happens with the latest rtw88 code from https://github.com/lwfinger/rtw88, revision 22f319b11d6d3c4a3ac9e1f90e3433ed9f5ecf11.

I have been using the driver from https://github.com/tomaspinho/rtl8821ce since late 2019 with no problems, even with Linux 5.12/5.12.1.

I tested all combinations of rtw_pci parameters "disable_msi" and "disable_aspm". Nothing helped.

I set up netconsole and added the parameter "loglevel=7" to the kernel command line. Unfortunately all the messages that came through netconsole also appear in journalctl, so I got no new information that way. I used the driver from the stock Arch Linux kernel for this test.

I'm attaching the file "journalctl-nono.txt", which contains the output of "sudo journalctl _TRANSPORT=kernel" from the time I tested the code from lwfinger/rtw88.

I'm also attaching the file "journalctl-senorsnor.txt", which comes from another user who has the same problem. Their wifi card is also RFE 2. Maybe there is something relevant, I don't know.

I'm happy to provide more information, test possible fixes, etc.


Attachments:
journalctl-nono.txt (103.36 kB)
journalctl-senorsnor.txt (154.81 kB)
Download all attachments

2021-05-10 01:19:52

by Larry Finger

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On 5/9/21 2:35 PM, rtl8821cerfe2 wrote:
> Hi!
>
> My system freezes if I use this driver. My laptop's wifi card is RTL8821CE, type RFE 2. My laptop is HP 250 G7, model 6MQ29EA.
>
> It happens within a few minutes after booting if I don't do anything out of the ordinary. If I do a speed test at speedtest.net, the system usually freezes during the test. I have to hold the power button to shut it down.
>
> This happens with the 5.12/5.12.1 kernel provided by Arch Linux, but it also happens with the latest rtw88 code from https://github.com/lwfinger/rtw88, revision 22f319b11d6d3c4a3ac9e1f90e3433ed9f5ecf11.
>
> I have been using the driver from https://github.com/tomaspinho/rtl8821ce since late 2019 with no problems, even with Linux 5.12/5.12.1.
>
> I tested all combinations of rtw_pci parameters "disable_msi" and "disable_aspm". Nothing helped.
>
> I set up netconsole and added the parameter "loglevel=7" to the kernel command line. Unfortunately all the messages that came through netconsole also appear in journalctl, so I got no new information that way. I used the driver from the stock Arch Linux kernel for this test.
>
> I'm attaching the file "journalctl-nono.txt", which contains the output of "sudo journalctl _TRANSPORT=kernel" from the time I tested the code from lwfinger/rtw88.
>
> I'm also attaching the file "journalctl-senorsnor.txt", which comes from another user who has the same problem. Their wifi card is also RFE 2. Maybe there is something relevant, I don't know.
>
> I'm happy to provide more information, test possible fixes, etc.
>

The only splat that shows in either attachment is due to you not installing the
regulatory database that sets the channels etc. for your domain. I do not know
what it is called for your distro - it is wireless-regdb on mine. It is unlikely
that this is the cause of your problem, but who knows?

Larry

2021-05-10 13:32:09

by rtl8821cerfe2

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On Monday, May 10, 2021 4:16 AM, Larry Finger <[email protected]> wrote:
> The only splat that shows in either attachment is due to you not installing the
> regulatory database that sets the channels etc. for your domain. I do not know
> what it is called for your distro - it is wireless-regdb on mine. It is unlikely
> that this is the cause of your problem, but who knows?
>
> Larry

I installed the wireless-regdb package. The error message about
regulatory.db went away, but the system still froze.

I'll try the rtw_core parameter disable_lps_deep=1 now.

2021-05-10 13:53:08

by rtl8821cerfe2

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On Monday, May 10, 2021 3:06 PM, rtl8821cerfe2 <[email protected]> wrote:

> On Monday, May 10, 2021 4:16 AM, Larry Finger [email protected] wrote:
>
> > The only splat that shows in either attachment is due to you not installing the
> > regulatory database that sets the channels etc. for your domain. I do not know
> > what it is called for your distro - it is wireless-regdb on mine. It is unlikely
> > that this is the cause of your problem, but who knows?
> > Larry
>
> I installed the wireless-regdb package. The error message about
> regulatory.db went away, but the system still froze.
>
> I'll try the rtw_core parameter disable_lps_deep=1 now.

disable_lps_deep=1 did not help.

2021-05-11 19:52:56

by Andreas Hartmann

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

Hi!

I'm using probably the same device and the same modules here from
Larry's repository. They are working perfectly - much better then any
other existing modules. Absolutely stable and good throughput on even
bad radio conditions.

My device:
04:00.0 0280: 10ec:c821
Subsystem: 1a3b:3041
Flags: bus master, fast devsel, latency 0, IRQ 76
I/O ports at d000 [size=256]
Memory at f7600000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [148] Device Serial Number 00-e0-4c-ff-fe-c8-21-01
Capabilities: [158] Latency Tolerance Reporting
Capabilities: [160] L1 PM Substates
Capabilities: [170] Precision Time Measurement
Capabilities: [17c] Vendor Specific Information: ID=0003 Rev=1
Len=054 <?>
Kernel driver in use: rtw_8821ce
Kernel modules: rtw_8821ce

on Linux 5.10.27 / self build

I saw you're using network manager - I'm using just wpa_supplicant
(EAPTLS) - nothing else. Maybe that's the problem?
One more thing: I'm on 2.4 GHz / 40 MHz.


Thanks
Andreas

2021-05-19 21:17:56

by rtl8821cerfe2

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On Monday, May 10, 2021 4:49 PM, rtl8821cerfe2 <[email protected]> wrote:

&gt; On Monday, May 10, 2021 3:06 PM, rtl8821cerfe2 [email protected] wrote:
&gt;
&gt; &gt; On Monday, May 10, 2021 4:16 AM, Larry Finger [email protected] wrote:
&gt; &gt;
&gt; &gt; &gt; The only splat that shows in either attachment is due to you not installing the
&gt; &gt; &gt; regulatory database that sets the channels etc. for your domain. I do not know
&gt; &gt; &gt; what it is called for your distro - it is wireless-regdb on mine. It is unlikely
&gt; &gt; &gt; that this is the cause of your problem, but who knows?
&gt; &gt; &gt; Larry
&gt; &gt;
&gt; &gt; I installed the wireless-regdb package. The error message about
&gt; &gt; regulatory.db went away, but the system still froze.
&gt; &gt; I'll try the rtw_core parameter disable_lps_deep=1 now.
&gt;
&gt; disable_lps_deep=1 did not help.

The patch set called "rtw88: add scan notify to firmware and refine fw_feature check" may have fixed this problem. I've been running commit 6ccdad5a58e18eac6b1335f05f94bf2b36146e00 from lwfinger/rtw88 for 3 days now with no freeze. It was impossible to go more than a few hours without a freeze before these patches.

2021-05-20 05:54:35

by Larry Finger

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On 5/19/21 4:00 PM, rtl8821cerfe2 wrote:
> On Monday, May 10, 2021 4:49 PM, rtl8821cerfe2 <[email protected]> wrote:
>
> &gt; On Monday, May 10, 2021 3:06 PM, rtl8821cerfe2 [email protected] wrote:
> &gt;
> &gt; &gt; On Monday, May 10, 2021 4:16 AM, Larry Finger [email protected] wrote:
> &gt; &gt;
> &gt; &gt; &gt; The only splat that shows in either attachment is due to you not installing the
> &gt; &gt; &gt; regulatory database that sets the channels etc. for your domain. I do not know
> &gt; &gt; &gt; what it is called for your distro - it is wireless-regdb on mine. It is unlikely
> &gt; &gt; &gt; that this is the cause of your problem, but who knows?
> &gt; &gt; &gt; Larry
> &gt; &gt;
> &gt; &gt; I installed the wireless-regdb package. The error message about
> &gt; &gt; regulatory.db went away, but the system still froze.
> &gt; &gt; I'll try the rtw_core parameter disable_lps_deep=1 now.
> &gt;
> &gt; disable_lps_deep=1 did not help.
>
> The patch set called "rtw88: add scan notify to firmware and refine fw_feature check" may have fixed this problem. I've been running commit 6ccdad5a58e18eac6b1335f05f94bf2b36146e00 from lwfinger/rtw88 for 3 days now with no freeze. It was impossible to go more than a few hours without a freeze before these patches.
>

Sounds good. I will keep porting the patches submitted to wreless-drivers-next
to the rtw88 repo at GitHub. I have no idea why this would preclude a system
freeze, but the Realtek guys might.

Larry

2021-05-25 10:55:16

by rtl8821cerfe2

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On Thursday, May 20, 2021 8:51 AM, Larry Finger <[email protected]> wrote:

> On 5/19/21 4:00 PM, rtl8821cerfe2 wrote:
>
> > On Monday, May 10, 2021 4:49 PM, rtl8821cerfe2 [email protected] wrote:
> > > On Monday, May 10, 2021 3:06 PM, rtl8821cerfe2 [email protected] wrote:
> > >
> > > > On Monday, May 10, 2021 4:16 AM, Larry Finger [email protected] wrote:
> > > >
> > > > > The only splat that shows in either attachment is due to you not installing the
> > > > > regulatory database that sets the channels etc. for your domain. I do not know
> > > > > what it is called for your distro - it is wireless-regdb on mine. It is unlikely
> > > > > that this is the cause of your problem, but who knows?
> > > > > Larry
> > > >
> > > > I installed the wireless-regdb package. The error message about
> > > > regulatory.db went away, but the system still froze.
> > > > I'll try the rtw_core parameter disable_lps_deep=1 now.
> > >
> > > disable_lps_deep=1 did not help.
> > The patch set called "rtw88: add scan notify to firmware and refine fw_feature check" may have fixed this problem. I've been running commit 6ccdad5a58e18eac6b1335f05f94bf2b36146e00 from lwfinger/rtw88 for 3 days now with no freeze. It was impossible to go more than a few hours without a freeze before these patches.
>
> Sounds good. I will keep porting the patches submitted to wreless-drivers-next
> to the rtw88 repo at GitHub. I have no idea why this would preclude a system
> freeze, but the Realtek guys might.
>
> Larry

I spoke too soon. It does still freeze even with that patch set.

2021-06-07 02:45:09

by Larry Finger

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

I just push a patch from Realtek with the following commit message:

8821CE with ASPM cannot work properly on Protempo Ltd L116HTN6SPW. Add a
quirk to disable the cap.

The reporter describes the symptom is that this module (driver) causes
frequent freezes, randomly but usually within a few minutes of running
(thus very soon after boot): screen display remains frozen, no response
to either keyboard or mouse input. All I can do is to hold the power
button to power off, then reboot.


Please do a 'git pull' and try the new code. If you still have the problem, the
quirk may need to be extended for your system. Please run the command:

sudo dmidecode > dmidecode.txt

Then post that .txt file.

Larry

2021-06-07 09:18:48

by rtl8821cerfe2

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type




Sent with ProtonMail Secure Email.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Wednesday, May 26, 2021 10:03 PM, Larry Finger <[email protected]> wrote:

> On 5/23/21 1:36 PM, rtl8821cerfe2 wrote:
>
> > On Thursday, May 20, 2021 8:51 AM, Larry Finger [email protected] wrote:
> >
> > > On 5/19/21 4:00 PM, rtl8821cerfe2 wrote:
> > >
> > > > On Monday, May 10, 2021 4:49 PM, rtl8821cerfe2 [email protected] wrote:
> > > >
> > > > > On Monday, May 10, 2021 3:06 PM, rtl8821cerfe2 [email protected] wrote:
> > > > > disable_lps_deep=1 did not help.
> > > > > The patch set called "rtw88: add scan notify to firmware and refine fw_feature check" may have fixed this problem. I've been running commit 6ccdad5a58e18eac6b1335f05f94bf2b36146e00 from lwfinger/rtw88 for 3 days now with no freeze. It was impossible to go more than a few hours without a freeze before these patches.
> > >
> > > Sounds good. I will keep porting the patches submitted to wreless-drivers-next
> > > to the rtw88 repo at GitHub. I have no idea why this would preclude a system
> > > freeze, but the Realtek guys might.
> > > Larry
> >
> > I spoke too soon. It does still freeze even with that patch set.
>
> Can you provide any more information about the freezes? As I recall, you did say
> that nothing was logged, but are the CPU fans working hard indicating the the
> CPU is active? On the desktop, does the mouse pointer move?
>
> Larry

Sorry, I forgot to check my email.

Nothing was logged, the CPU fan was spinning at a normal speed which is barely audible, and the mouse pointer didn't move anymore.

Also, I tried the rtw_core option debug_mask=65535, which activates all the debug messages available, hoping to capture some useful information during the freeze, but with that option the freeze didn't happen. This suggests to me a timing problem, but who knows. I'm mostly clueless about kernel programming.

2021-06-07 09:31:42

by rtl8821cerfe2

[permalink] [raw]
Subject: Re: rtw88: Guaranteed system freeze with RTL8821CE with RFE 2 type

On Monday, June 7, 2021 5:40 AM, Larry Finger <[email protected]> wrote:

> I just push a patch from Realtek with the following commit message:
>
> 8821CE with ASPM cannot work properly on Protempo Ltd L116HTN6SPW. Add a
> quirk to disable the cap.
>
> The reporter describes the symptom is that this module (driver) causes
> frequent freezes, randomly but usually within a few minutes of running
> (thus very soon after boot): screen display remains frozen, no response
> to either keyboard or mouse input. All I can do is to hold the power
> button to power off, then reboot.
>
> Please do a 'git pull' and try the new code. If you still have the problem, the
> quirk may need to be extended for your system. Please run the command:
>
> sudo dmidecode > dmidecode.txt
>
> Then post that .txt file.
>
> Larry

That patch seems to do the same thing as the rtw_pci option disable_aspm=1. I tried that option, with and without disable_msi=1, and it didn't help.

I'm attaching dmidecode.txt.


Attachments:
dmidecode.txt (19.67 kB)